summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-06-16 12:08:06 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-06-16 12:08:06 +0000
commitb163dd4901a3fe585da6262786acd8d607643123 (patch)
tree9b9555127e76457cdee9f0fd6c80894e939c2c63 /app-emulation/wine/wine-9999.ebuild
parentStable for amd64 wrt bug #510150 (diff)
downloadgentoo-2-b163dd4901a3fe585da6262786acd8d607643123.tar.gz
gentoo-2-b163dd4901a3fe585da6262786acd8d607643123.tar.bz2
gentoo-2-b163dd4901a3fe585da6262786acd8d607643123.zip
Version bump, see http://www.winehq.org/announce/1.7.20 for the announcement. Use samba with ABI_X86="32 64" for win32 netapi support; note that there is no emul-linux-x86-* alternative for netapi. Switch to multilib-minimal.eclass (bugs #494394 and #511184, thanks to Michał Górny). Enable experimental pthreads patch from winepulse patchset, otherwise gstreamer support is simply broken with any version of dev-libs/glib we have in portage.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation/wine/wine-9999.ebuild')
-rw-r--r--app-emulation/wine/wine-9999.ebuild229
1 files changed, 111 insertions, 118 deletions
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index b9e6baff21f7..f348eba71dd1 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.169 2014/06/12 14:30:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.170 2014/06/16 12:08:06 tetromino Exp $
EAPI="5"
@@ -8,7 +8,7 @@ AUTOTOOLS_AUTORECONF=1
PLOCALES="ar bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru sk sl sr_RS@cyrillic sr_RS@latin sv te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools-multilib eutils fdo-mime flag-o-matic gnome2-utils l10n multilib pax-utils toolchain-funcs virtualx
+inherit autotools-utils eutils fdo-mime flag-o-matic gnome2-utils l10n multilib multilib-minimal pax-utils toolchain-funcs virtualx
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
@@ -24,8 +24,8 @@ fi
GV="2.24"
MV="4.5.2"
-PULSE_PATCHES="winepulse-patches-1.7.12"
-COMPHOLIOV="1.7.18-1"
+PULSE_PATCHES="winepulse-patches-1.7.20"
+COMPHOLIOV="1.7.20"
COMPHOLIO_PATCHES="wine-compholio-daily-${COMPHOLIOV}"
WINE_GENTOO="wine-gentoo-2013.06.24"
DESCRIPTION="Free implementation of Windows(tm) on Unix"
@@ -46,8 +46,10 @@ IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fon
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
test? ( abi_x86_32 )
elibc_glibc? ( threads )
+ gstreamer? ( pulseaudio )
mono? ( abi_x86_32 )
osmesa? ( opengl )" #286560
+# winepulse patches needed for gstreamer due to http://bugs.winehq.org/show_bug.cgi?id=30557
# FIXME: the test suite is unsuitable for us; many tests require net access
# or fail due to Xvfb's opengl limitations.
@@ -101,132 +103,133 @@ COMMON_DEPEND="
abi_x86_64? ( ${NATIVE_DEPEND} )
abi_x86_32? (
truetype? ( || (
- >=app-emulation/emul-linux-x86-xlibs-2.1[development]
- >=media-libs/freetype-2.0.0[abi_x86_32]
+ >=app-emulation/emul-linux-x86-xlibs-2.1[development,-abi_x86_32(-)]
+ >=media-libs/freetype-2.0.0[abi_x86_32(-)]
) )
ncurses? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- sys-libs/ncurses[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ sys-libs/ncurses[abi_x86_32(-)]
) )
udisks? ( || (
- >=app-emulation/emul-linux-x86-baselibs-20130224[development]
- sys-apps/dbus[abi_x86_32]
+ >=app-emulation/emul-linux-x86-baselibs-20130224[development,-abi_x86_32(-)]
+ sys-apps/dbus[abi_x86_32(-)]
) )
fontconfig? ( || (
- app-emulation/emul-linux-x86-xlibs[development]
- media-libs/fontconfig[abi_x86_32]
+ app-emulation/emul-linux-x86-xlibs[development,-abi_x86_32(-)]
+ media-libs/fontconfig[abi_x86_32(-)]
) )
gphoto2? ( || (
- app-emulation/emul-linux-x86-medialibs[development]
- media-libs/libgphoto2[abi_x86_32]
+ app-emulation/emul-linux-x86-medialibs[development,-abi_x86_32(-)]
+ media-libs/libgphoto2[abi_x86_32(-)]
) )
openal? ( || (
- app-emulation/emul-linux-x86-sdl[development]
- media-libs/openal[abi_x86_32]
+ app-emulation/emul-linux-x86-sdl[development,-abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]
) )
- gstreamer? (
- app-emulation/emul-linux-x86-medialibs[development]
+ gstreamer? ( || (
+ app-emulation/emul-linux-x86-medialibs[development,-abi_x86_32(-)]
(
- media-libs/gstreamer:0.10[abi_x86_32]
- media-libs/gst-plugins-base:0.10[abi_x86_32]
+ media-libs/gstreamer:0.10[abi_x86_32(-)]
+ media-libs/gst-plugins-base:0.10[abi_x86_32(-)]
)
- )
+ ) )
X? ( || (
- app-emulation/emul-linux-x86-xlibs[development]
+ app-emulation/emul-linux-x86-xlibs[development,-abi_x86_32(-)]
(
- x11-libs/libXcursor[abi_x86_32]
- x11-libs/libXext[abi_x86_32]
- x11-libs/libXrandr[abi_x86_32]
- x11-libs/libXi[abi_x86_32]
- x11-libs/libXxf86vm[abi_x86_32]
+ x11-libs/libXcursor[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXrandr[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
)
) )
xinerama? ( || (
- app-emulation/emul-linux-x86-xlibs[development]
- x11-libs/libXinerama[abi_x86_32]
+ app-emulation/emul-linux-x86-xlibs[development,-abi_x86_32(-)]
+ x11-libs/libXinerama[abi_x86_32(-)]
) )
alsa? ( || (
- app-emulation/emul-linux-x86-soundlibs[alsa,development]
- media-libs/alsa-lib[abi_x86_32]
+ app-emulation/emul-linux-x86-soundlibs[alsa,development,-abi_x86_32(-)]
+ media-libs/alsa-lib[abi_x86_32(-)]
) )
cups? ( || (
app-emulation/emul-linux-x86-baselibs
- net-print/cups[abi_x86_32]
+ net-print/cups[abi_x86_32(-)]
) )
- opencl? ( virtual/opencl[abi_x86_32] )
+ opencl? ( virtual/opencl[abi_x86_32(-)] )
opengl? ( || (
- app-emulation/emul-linux-x86-opengl[development]
+ app-emulation/emul-linux-x86-opengl[development,-abi_x86_32(-)]
(
- virtual/glu[abi_x86_32]
- virtual/opengl[abi_x86_32]
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
)
) )
gsm? ( || (
- app-emulation/emul-linux-x86-soundlibs[development]
- media-sound/gsm[abi_x86_32]
+ app-emulation/emul-linux-x86-soundlibs[development,-abi_x86_32(-)]
+ media-sound/gsm[abi_x86_32(-)]
) )
jpeg? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- virtual/jpeg:0[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ virtual/jpeg:0[abi_x86_32(-)]
) )
ldap? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- net-nds/openldap:=[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ net-nds/openldap:=[abi_x86_32(-)]
) )
lcms? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- media-libs/lcms:2[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ media-libs/lcms:2[abi_x86_32(-)]
) )
mp3? ( || (
- app-emulation/emul-linux-x86-soundlibs[development]
- >=media-sound/mpg123-1.5.0[abi_x86_32]
+ app-emulation/emul-linux-x86-soundlibs[development,-abi_x86_32(-)]
+ >=media-sound/mpg123-1.5.0[abi_x86_32(-)]
) )
+ netapi? ( net-fs/samba[netapi(+),abi_x86_32(-)] )
nls? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- sys-devel/gettext[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ sys-devel/gettext[abi_x86_32(-)]
) )
odbc? ( || (
- app-emulation/emul-linux-x86-db[development]
- dev-db/unixODBC:=[abi_x86_32]
+ app-emulation/emul-linux-x86-db[development,-abi_x86_32(-)]
+ dev-db/unixODBC:=[abi_x86_32(-)]
) )
osmesa? ( || (
- >=app-emulation/emul-linux-x86-opengl-20121028[development]
- media-libs/mesa[osmesa,abi_x86_32]
+ >=app-emulation/emul-linux-x86-opengl-20121028[development,-abi_x86_32(-)]
+ media-libs/mesa[osmesa,abi_x86_32(-)]
) )
pipelight? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- sys-apps/attr[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ sys-apps/attr[abi_x86_32(-)]
) )
pulseaudio? ( || (
- app-emulation/emul-linux-x86-soundlibs[development]
- >=media-sound/pulseaudio-4.0-r1[abi_x86_32]
+ app-emulation/emul-linux-x86-soundlibs[development,-abi_x86_32(-)]
+ >=media-sound/pulseaudio-4.0-r1[abi_x86_32(-)]
) )
xml? ( || (
- >=app-emulation/emul-linux-x86-baselibs-20131008[development]
+ >=app-emulation/emul-linux-x86-baselibs-20131008[development,-abi_x86_32(-)]
(
- dev-libs/libxml2[abi_x86_32]
- dev-libs/libxslt[abi_x86_32]
+ dev-libs/libxml2[abi_x86_32(-)]
+ dev-libs/libxslt[abi_x86_32(-)]
)
) )
scanner? ( || (
- app-emulation/emul-linux-x86-medialibs[development]
- media-gfx/sane-backends:=[abi_x86_32]
+ app-emulation/emul-linux-x86-medialibs[development,-abi_x86_32(-)]
+ media-gfx/sane-backends:=[abi_x86_32(-)]
) )
ssl? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- net-libs/gnutls:=[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ net-libs/gnutls:=[abi_x86_32(-)]
) )
png? ( || (
- app-emulation/emul-linux-x86-baselibs[development]
- media-libs/libpng:0[abi_x86_32]
+ app-emulation/emul-linux-x86-baselibs[development,-abi_x86_32(-)]
+ media-libs/libpng:0[abi_x86_32(-)]
) )
v4l? ( || (
- app-emulation/emul-linux-x86-medialibs[development]
- media-libs/libv4l[abi_x86_32]
+ app-emulation/emul-linux-x86-medialibs[development,-abi_x86_32(-)]
+ media-libs/libv4l[abi_x86_32(-)]
) )
xcomposite? ( || (
- app-emulation/emul-linux-x86-xlibs[development]
- x11-libs/libXcomposite[abi_x86_32]
+ app-emulation/emul-linux-x86-xlibs[development,-abi_x86_32(-)]
+ x11-libs/libXcomposite[abi_x86_32(-)]
) )
)
)"
@@ -346,33 +349,15 @@ src_prepare() {
l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
}
-do_configure() {
- local myeconfargs=( "${myeconfargs[@]}" )
-
- if use amd64; then
- if [[ ${ABI} == amd64 ]]; then
- myeconfargs+=( --enable-win64 )
- else
- use netapi && ewarn "Disabling netapi in wine32; see https://bugs.gentoo.org/494394"
- # We currently don't have 32-bit libnetapi on amd64; #494394
- myeconfargs+=(
- --without-netapi
- --disable-win64
- )
- fi
-
- # Note: using --with-wine64 results in problems with multilib.eclass
- # CC/LD hackery. We're using separate tools instead.
- fi
-
- autotools-utils_src_configure
-}
-
src_configure() {
export LDCONFIG=/bin/true
use custom-cflags || strip-flags
- local myeconfargs=( # common
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local myconf=(
--sysconfdir=/etc/wine
$(use_with alsa)
$(use_with capi)
@@ -409,46 +394,55 @@ src_configure() {
$(use_with xml xslt)
)
- use pulseaudio && myeconfargs+=( --with-pulse )
- use pipelight && myeconfargs+=( --with-xattr )
+ use pulseaudio && myconf+=( --with-pulse )
+ use pipelight && myconf+=( --with-xattr )
- if use amd64 && use abi_x86_32; then
- # Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
- # set AR and RANLIB to make QA scripts happy; #483342
- tc-export PKG_CONFIG AR RANLIB
+ local PKG_CONFIG AR RANLIB
+ # Avoid crossdev's i686-pc-linux-gnu-pkg-config if building wine32 on amd64; #472038
+ # set AR and RANLIB to make QA scripts happy; #483342
+ tc-export PKG_CONFIG AR RANLIB
+
+ if use amd64; then
+ if [[ ${ABI} == amd64 ]]; then
+ myconf+=( --enable-win64 )
+ else
+ myconf+=( --disable-win64 )
+ fi
+
+ # Note: using --with-wine64 results in problems with multilib.eclass
+ # CC/LD hackery. We're using separate tools instead.
fi
- multilib_parallel_foreach_abi do_configure
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+ emake depend
}
-src_compile() {
- autotools-multilib_src_compile depend
- autotools-multilib_src_compile all
-}
+multilib_src_test() {
+ # FIXME: win32-only; wine64 tests fail with "could not find the Wine loader"
+ if [[ ${ABI} == x86 ]]; then
+ if [[ $(id -u) == 0 ]]; then
+ ewarn "Skipping tests since they cannot be run under the root user."
+ ewarn "To run the test ${PN} suite, add userpriv to FEATURES in make.conf"
+ return
+ fi
-src_test() {
- if [[ $(id -u) == 0 ]]; then
- ewarn "Skipping tests since they cannot be run under the root user."
- ewarn "To run the test ${PN} suite, add userpriv to FEATURES in make.conf"
- return
+ WINEPREFIX="${T}/.wine-${ABI}" \
+ Xemake test
fi
-
- # FIXME: win32-only; wine64 tests fail with "could not find the Wine loader"
- multilib_toolchain_setup x86
- local BUILD_DIR="${S}-${ABI}"
- cd "${BUILD_DIR}" || die
- WINEPREFIX="${T}/.wine-${ABI}" Xemake test
}
-src_install() {
+multilib_src_install_all() {
local DOCS=( ANNOUNCE AUTHORS README )
local l
add_locale_docs() {
local locale_doc="documentation/README.$1"
- [[ ! -e ${locale_doc} ]] || DOCS=( "${DOCS[@]}" ${locale_doc} )
+ [[ ! -e ${locale_doc} ]] || DOCS+=( ${locale_doc} )
}
l10n_for_each_locale_do add_locale_docs
- autotools-multilib_src_install
+
+ einstalldocs
+ prune_libtool_files --all
emake -C "../${WINE_GENTOO}" install DESTDIR="${D}" EPREFIX="${EPREFIX}"
if use gecko ; then
@@ -476,7 +470,6 @@ src_install() {
for l in de fr pl; do
use linguas_${l} || rm -r "${D}"usr/share/man/${l}*
done
-
}
pkg_preinst() {