summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-09-01 06:25:28 +0000
committerTilman Klar <phoenix@gentoo.org>2002-09-01 06:25:28 +0000
commit1c388e9834e187721b7d9daed269887ed739dd32 (patch)
tree44ff70f19bbd0e74ed7a51da8ae5204ba080d200 /app-emulation
parentMasked winex-cvs (diff)
downloadgentoo-2-1c388e9834e187721b7d9daed269887ed739dd32.tar.gz
gentoo-2-1c388e9834e187721b7d9daed269887ed739dd32.tar.bz2
gentoo-2-1c388e9834e187721b7d9daed269887ed739dd32.zip
This is the new winex-cvs ebuild. Check the ChangeLog for further details.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winex-cvs/ChangeLog15
-rw-r--r--app-emulation/winex-cvs/files/digest-winex-cvs-200208310
-rw-r--r--app-emulation/winex-cvs/files/winex-cvs-20020831-fake_windows.tar.bz2bin0 -> 500 bytes
-rw-r--r--app-emulation/winex-cvs/files/winex-cvs-20020831-regedit23
-rw-r--r--app-emulation/winex-cvs/files/winex-cvs-20020831-winex48
-rw-r--r--app-emulation/winex-cvs/winex-cvs-20020831.ebuild119
6 files changed, 205 insertions, 0 deletions
diff --git a/app-emulation/winex-cvs/ChangeLog b/app-emulation/winex-cvs/ChangeLog
new file mode 100644
index 000000000000..bd50d95a71ed
--- /dev/null
+++ b/app-emulation/winex-cvs/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for app-emulation/winex-cvs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.1 2002/09/01 06:25:28 phoenix Exp $
+
+*winex-20020831 (01 September 2002)
+
+ 01 Sep 2002; phoen][x <phoenix@gentoo.org> ChangeLog, winex-cvs-20020831.ebuild,
+ files/winex-cvs-20020831-fake_windows.tar.bz2, files/winex-cvs-20020831-regedit,
+ files/winex-cvs-20020831-winex :
+
+ Initial release of the winex-cvs package. In order to have both winex versions
+ (the normal one and the cvs one) installed at the same time, i made this one go
+ into /usr/lib/winex-cvs. The wrapper is called /usr/bin/winex-cvs and the
+ regedit is named /usr/bin/regedit-winex-cvs.
+
diff --git a/app-emulation/winex-cvs/files/digest-winex-cvs-20020831 b/app-emulation/winex-cvs/files/digest-winex-cvs-20020831
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emulation/winex-cvs/files/digest-winex-cvs-20020831
diff --git a/app-emulation/winex-cvs/files/winex-cvs-20020831-fake_windows.tar.bz2 b/app-emulation/winex-cvs/files/winex-cvs-20020831-fake_windows.tar.bz2
new file mode 100644
index 000000000000..d60f11e08ee3
--- /dev/null
+++ b/app-emulation/winex-cvs/files/winex-cvs-20020831-fake_windows.tar.bz2
Binary files differ
diff --git a/app-emulation/winex-cvs/files/winex-cvs-20020831-regedit b/app-emulation/winex-cvs/files/winex-cvs-20020831-regedit
new file mode 100644
index 000000000000..38986bfada06
--- /dev/null
+++ b/app-emulation/winex-cvs/files/winex-cvs-20020831-regedit
@@ -0,0 +1,23 @@
+#!/bin/bash
+# The wineX regapi wrapper
+
+# Kindly distributed by Martin Schlemmer
+# Modified by phoen][x
+
+export INSTALLDIR="/usr/lib/winex-cvs"
+
+export WINEPREFIX="$HOME/.winex-cvs"
+
+export LD_LIBRARY_PATH="$INSTALLDIR/lib/wine:$INSTALLDIR/lib:$LD_LIBRARY_PATH"
+export WINEDLLPATH="$LD_LIBRARY_PATH"
+
+export WINE_LOADER=wine
+
+export RUNWINE="$INSTALLDIR/bin/wine"
+export REGAPI="$INSTALLDIR/bin/regapi"
+
+if([ -z ${1} ]) then
+ echo "Usage: regedit-winex-cvs foo.reg"
+else
+ "$REGAPI" setValue < ${1} &> /dev/null
+fi
diff --git a/app-emulation/winex-cvs/files/winex-cvs-20020831-winex b/app-emulation/winex-cvs/files/winex-cvs-20020831-winex
new file mode 100644
index 000000000000..1fd1a609d0d5
--- /dev/null
+++ b/app-emulation/winex-cvs/files/winex-cvs-20020831-winex
@@ -0,0 +1,48 @@
+#!/bin/bash
+# The wineX wrapper
+
+# Kindly distributed by Martin Schlemmer
+# Modified by phoen][x
+
+export INSTALLDIR="/usr/lib/winex-cvs"
+
+export WINEPREFIX="$HOME/.winex-cvs"
+
+export LD_LIBRARY_PATH="$INSTALLDIR/lib/wine:$INSTALLDIR/lib:$LD_LIBRARY_PATH"
+export WINEDLLPATH="$LD_LIBRARY_PATH"
+
+export WINE_LOADER=wine
+
+export RUNWINE="$INSTALLDIR/bin/wine"
+export REGAPI="$INSTALLDIR/bin/regapi"
+
+if [ ! -f $WINEPREFIX/config ]
+then
+ echo "!! ~/.winex-cvs/config misses"
+ echo "!! Setting up a config file"
+
+ mkdir -p $WINEPREFIX/fake_windows
+
+ # First copy in the new config file.
+ cp "$INSTALLDIR/.data/config" "$WINEPREFIX/config"
+
+ echo "!! Setting up ~/.winex-cvs/fake_windows/"
+ cp -R $INSTALLDIR/.data/fake_windows/* $WINEPREFIX/fake_windows
+
+ echo "!! Setting up default registry."
+ "$REGAPI" setValue < "$INSTALLDIR/.data/winedefault.reg" &> /dev/null
+
+ echo "!! Installation complete."
+ echo "!! Modify ~/.winex-cvs/config to reflect your systems setup."
+ exit
+fi
+
+# Force the use of the more memory-efficient MSVC 5 allocator with
+# any programs that use MSVCRT. This reduces memory consumption
+# significantly.
+export __MSVCRT_HEAP_SELECT=__GLOBAL_HEAP_SELECTED,2
+
+
+PATH="$INSTALLDIR/bin:$PATH"
+
+"$RUNWINE" --debugmsg -all "$@"
diff --git a/app-emulation/winex-cvs/winex-cvs-20020831.ebuild b/app-emulation/winex-cvs/winex-cvs-20020831.ebuild
new file mode 100644
index 000000000000..a60c4ebdd71e
--- /dev/null
+++ b/app-emulation/winex-cvs/winex-cvs-20020831.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-20020831.ebuild,v 1.1 2002/09/01 06:25:28 phoenix Exp $
+
+# Modify this if you want some other branch. Possible values are:
+# winex-2-1
+# winex-2-0
+# winex
+# You can find more branches on http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/winex/wine/
+
+WINEX_BRANCH="winex-2-1"
+ECVS_SERVER="cvs.winex.sourceforge.net:/cvsroot/winex"
+ECVS_MODULE="wine"
+ECVS_CVS_OPTIONS="-r${WINEX_BRANCH} -dP"
+
+inherit cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming.
+ This ebuild will fetch the newest cvs sources from the cvs-server."
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="x86 -ppc"
+LICENSE="Aladdin"
+
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk
+ opengl? ( virtual/opengl )
+ cups? ( net-print/cups )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+
+ # the folks at #winehq were really angry about custom optimization
+ unset CFLAGS
+ unset CXXFLAGS
+
+ ./configure --prefix=/usr/lib/winex-cvs \
+ --sysconfdir=/etc/winex-cvs \
+ --host=${CHOST} \
+ --enable-curses \
+ --with-x \
+ ${myconf} || die "configure failed"
+
+ # Fixes a winetest issue
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # This persuades wineshelllink that "winex-cvs" is a better loader :)
+ cd ${S}/tools
+ cp wineshelllink 1
+ sed -e 's/\(WINE_LOADER=\)\(\${WINE_LOADER:-wine}\)/\1winex-cvs/' 1 > wineshelllink
+
+ cd ${S}
+ make depend all || die "make depend all failed"
+ cd programs && emake || die "emake died"
+}
+
+src_install () {
+ local WINEXMAKEOPTS="prefix=${D}/usr/lib/winex-cvs"
+
+ # Installs winex to /usr/lib/winex-cvs
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+
+
+ # Creates /usr/lib/winex-cvs/.data with fake_windows in it
+ # This is needed for our new winex-cvs wrapper script
+ mkdir ${D}/usr/lib/winex-cvs/.data
+ pushd ${D}/usr/lib/winex-cvs/.data
+ tar jxvf ${FILESDIR}/${P}-fake_windows.tar.bz2
+ popd
+ cp ${S}/documentation/samples/config ${S}/documentation/samples/config.orig
+ sed -e 's/"Path" = "\/c"/"Path" = "\$\{HOME\}\/.winex-cvs\/fake_windows"/' \
+ ${S}/documentation/samples/config.orig > ${S}/documentation/samples/config
+ cp ${S}/documentation/samples/config ${D}/usr/lib/winex-cvs/.data/config
+ cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/winex-cvs/.data/winedefault.reg
+ # Install the wrapper script
+ mkdir ${D}/usr/bin
+ cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex-cvs
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex-cvs
+
+ # Take care of the other stuff
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/winex-cvs/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/winex-cvs/bin
+ chmod a-x *.so
+
+}
+
+pkg_postinst() {
+ einfo "**********************************************************************"
+ einfo "* NOTE: Use /usr/bin/winex-cvs to start winex. *"
+ einfo "* This is a wrapper-script which will take care of everything *"
+ einfo "* else. If you have further questions, enhancements or patches *"
+ einfo "* send an email to phoenix@gentoo.org *"
+ einfo "**********************************************************************"
+}
+