summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-01-28 08:25:49 +0000
committerYixun Lan <dlan@gentoo.org>2014-01-28 08:25:49 +0000
commit3d93c22c98b74e7d2d82000c449f89814ebd1430 (patch)
treee3a00f8237b4bc07ee7f427db2961cf0bd777654 /app-emulation
parentbump (diff)
downloadgentoo-2-3d93c22c98b74e7d2d82000c449f89814ebd1430.tar.gz
gentoo-2-3d93c22c98b74e7d2d82000c449f89814ebd1430.tar.bz2
gentoo-2-3d93c22c98b74e7d2d82000c449f89814ebd1430.zip
fix local variable collision, thanks Cyril Nahon
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog5
-rwxr-xr-xapp-emulation/xen-tools/files/xenstored.initd6
2 files changed, 9 insertions, 2 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 8580b4a9ad87..c9a148ab007f 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.214 2014/01/27 08:58:09 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.215 2014/01/28 08:25:49 dlan Exp $
+
+ 28 Jan 2014; Yixun Lan <dlan@gentoo.org> files/xenstored.initd:
+ fix local variable collision, thanks Cyril Nahon
27 Jan 2014; Yixun Lan <dlan@gentoo.org> xen-tools-4.2.2-r5.ebuild,
xen-tools-4.3.1-r3.ebuild, files/xenstored.initd:
diff --git a/app-emulation/xen-tools/files/xenstored.initd b/app-emulation/xen-tools/files/xenstored.initd
index 3cd9cf7510cf..baa4d2e6a45d 100755
--- a/app-emulation/xen-tools/files/xenstored.initd
+++ b/app-emulation/xen-tools/files/xenstored.initd
@@ -7,13 +7,17 @@ depend() {
need xencommons
}
-start() {
+xenstored_dir_check() {
# create dir dynamically
+ local i
for i in /var/lock/subsys /run/xen /run/xend/boot /run/xenstored; do
[ -x $i ] || mkdir -p $i
done
+}
+start() {
ebegin "Starting xenstored daemon"
+ xenstored_dir_check
start-stop-daemon --start --exec /usr/sbin/xenstored \
--pidfile /run/xenstored.pid \
-- --pid-file=/run/xenstored.pid \