summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2014-03-07 03:50:02 +0000
committerPatrick McLean <chutzpah@gentoo.org>2014-03-07 03:50:02 +0000
commit4fb7d817188a8c0c903b48dc998c7bd3a1ccaacb (patch)
tree815f945d3295feb5d4137de9cfc2fb1306239fa7 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-4fb7d817188a8c0c903b48dc998c7bd3a1ccaacb.tar.gz
gentoo-2-4fb7d817188a8c0c903b48dc998c7bd3a1ccaacb.tar.bz2
gentoo-2-4fb7d817188a8c0c903b48dc998c7bd3a1ccaacb.zip
Fix problem where ganeti-2.10 was installing lots of broken symlinks. Add patch to use /run rather than /var/run. Remove 2.10.0.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xE3F69979BB4B8928DA78E3D17CBF44EF)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti/ChangeLog7
-rw-r--r--app-emulation/ganeti/files/ganeti-2.10-rundir.patch35
-rw-r--r--app-emulation/ganeti/ganeti-2.10.0.ebuild166
-rw-r--r--app-emulation/ganeti/ganeti-2.10.1.ebuild17
4 files changed, 53 insertions, 172 deletions
diff --git a/app-emulation/ganeti/ChangeLog b/app-emulation/ganeti/ChangeLog
index ca966fff11f3..df8a05e9d45b 100644
--- a/app-emulation/ganeti/ChangeLog
+++ b/app-emulation/ganeti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/ganeti
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.81 2014/03/06 19:56:01 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ChangeLog,v 1.82 2014/03/07 03:50:02 chutzpah Exp $
+
+ 07 Mar 2014; Patrick McLean <chutzpah@gentoo.org> -ganeti-2.10.0.ebuild,
+ ganeti-2.10.1.ebuild, +files/ganeti-2.10-rundir.patch:
+ Fix problem where ganeti-2.10 was installing lots of broken symlinks. Add
+ patch to use /run rather than /var/run. Remove 2.10.0.
*ganeti-2.10.1 (06 Mar 2014)
diff --git a/app-emulation/ganeti/files/ganeti-2.10-rundir.patch b/app-emulation/ganeti/files/ganeti-2.10-rundir.patch
new file mode 100644
index 000000000000..a723f2b63d85
--- /dev/null
+++ b/app-emulation/ganeti/files/ganeti-2.10-rundir.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile.am b/Makefile.am
+index df62fdf..b034d32 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1865,7 +1865,7 @@ $(SHELL_ENV_INIT): Makefile stamp-directories
+ echo; \
+ echo 'readonly PKGLIBDIR=$(libdir)/ganeti'; \
+ echo 'readonly LOG_DIR="$$LOCALSTATEDIR/log/ganeti"'; \
+- echo 'readonly RUN_DIR="$$LOCALSTATEDIR/run/ganeti"'; \
++ echo 'readonly RUN_DIR="/run/ganeti"'; \
+ echo 'readonly DATA_DIR="$$LOCALSTATEDIR/lib/ganeti"'; \
+ echo 'readonly CONF_DIR="$$SYSCONFDIR/ganeti"'; \
+ } > $@
+@@ -2208,7 +2208,7 @@ dist-release: dist
+ install-exec-local:
+ @mkdir_p@ "$(DESTDIR)${localstatedir}/lib/ganeti" \
+ "$(DESTDIR)${localstatedir}/log/ganeti" \
+- "$(DESTDIR)${localstatedir}/run/ganeti"
++ "$(DESTDIR)/run/ganeti"
+ for dir in $(SYMLINK_TARGET_DIRS); do \
+ @mkdir_p@ $(DESTDIR)$$dir; \
+ done
+diff --git a/lib/pathutils.py b/lib/pathutils.py
+index f075e22..38b02e9 100644
+--- a/lib/pathutils.py
++++ b/lib/pathutils.py
+@@ -62,7 +62,7 @@ ETC_HOSTS = vcluster.ETC_HOSTS
+ DATA_DIR = LOCALSTATEDIR + "/lib/ganeti"
+ LOCK_DIR = LOCALSTATEDIR + "/lock"
+ LOG_DIR = LOCALSTATEDIR + "/log/ganeti"
+-RUN_DIR = LOCALSTATEDIR + "/run/ganeti"
++RUN_DIR = "/run/ganeti"
+
+ #: Script to configure master IP address
+ DEFAULT_MASTER_SETUP_SCRIPT = TOOLSDIR + "/master-ip-setup"
diff --git a/app-emulation/ganeti/ganeti-2.10.0.ebuild b/app-emulation/ganeti/ganeti-2.10.0.ebuild
deleted file mode 100644
index 303359a348aa..000000000000
--- a/app-emulation/ganeti/ganeti-2.10.0.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.10.0.ebuild,v 1.2 2014/03/04 00:12:09 chutzpah Exp $
-
-EAPI=5
-PYTHON_COMPAT=(python2_{6,7})
-use test && PYTHON_REQ_USE="ipv6"
-
-inherit eutils confutils autotools bash-completion-r1 python-single-r1 versionator
-
-MY_PV="${PV/_rc/~rc}"
-#MY_PV="${PV/_beta/~beta}"
-MY_P="${PN}-${MY_PV}"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.ganeti.org/ganeti.git"
- inherit git-2
- KEYWORDS=""
- # you will need to pull in the haskell overlay for pandoc
- GIT_DEPEND="app-text/pandoc
- dev-python/docutils
- dev-python/sphinx
- media-libs/gd[fontconfig,jpeg,png,truetype]
- media-gfx/graphviz
- media-fonts/urw-fonts"
-else
- SRC_URI="http://downloads.ganeti.org/releases/$(get_version_component_range 1-2)/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Ganeti is a virtual server management software tool"
-HOMEPAGE="http://code.google.com/p/ganeti/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="kvm xen lxc drbd htools syslog ipv6 haskell-daemons rbd test"
-REQUIRED_USE="|| ( kvm xen lxc )"
-
-S="${WORKDIR}/${MY_P}"
-
-HASKELL_DEPS=">=dev-lang/ghc-6.12:0=
- dev-haskell/json:0=
- dev-haskell/curl:0=
- dev-haskell/network:0=
- dev-haskell/parallel
- dev-haskell/hslogger:0=
- dev-haskell/utf8-string:0=
- dev-haskell/deepseq:0=
- dev-haskell/attoparsec:0=
- dev-haskell/crypto:0="
-
-DEPEND="xen? ( >=app-emulation/xen-3.0 )
- kvm? ( app-emulation/qemu )
- lxc? ( app-emulation/lxc )
- drbd? ( <sys-cluster/drbd-8.5 )
- rbd? ( sys-cluster/ceph )
- ipv6? ( net-misc/ndisc6 )
- haskell-daemons? (
- ${HASKELL_DEPS}
- dev-haskell/text:0=
- dev-haskell/hinotify:0=
- dev-haskell/regex-pcre-builtin:0=
- dev-haskell/vector:0=
- )
- dev-libs/openssl
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/ipaddr[${PYTHON_USEDEP}]
- dev-python/bitarray[${PYTHON_USEDEP}]
- net-analyzer/arping
- net-analyzer/fping
- net-misc/bridge-utils
- net-misc/curl[ssl]
- net-misc/openssh
- net-misc/socat
- sys-apps/iproute2
- sys-fs/lvm2
- >=sys-apps/baselayout-2.0
- ${PYTHON_DEPS}
- ${GIT_DEPEND}"
-RDEPEND="${DEPEND}
- !app-emulation/ganeti-htools"
-DEPEND+="${HASKELL_DEPS}
- sys-devel/m4
- test? (
- dev-python/mock
- dev-python/pyyaml
- dev-haskell/test-framework:0=
- dev-haskell/test-framework-hunit:0=
- dev-haskell/test-framework-quickcheck2:0=
- dev-haskell/temporary:0=
- sys-apps/fakeroot
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.6-fix-args.patch"
- "${FILESDIR}/${PN}-2.6-add-pgrep.patch"
- "${FILESDIR}/${PN}-2.7-fix-tests.patch"
- "${FILESDIR}/${PN}-2.9-disable-root-tests.patch"
- "${FILESDIR}/${PN}-2.9-regex-builtin.patch"
- "${FILESDIR}/${PN}-2.9-skip-cli-test.patch"
-)
-
-pkg_setup () {
- confutils_use_depend_all haskell-daemons htools
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- epatch "${PATCHES[@]}"
- has_version ">=sys-devel/automake-1.13" && epatch "${FILESDIR}/${PN}-2.9-automake-1.13.patch"
- [[ ${PV} == "9999" ]] && ./autogen.sh
- rm autotools/missing
- eautoreconf
-}
-
-src_configure () {
- econf --localstatedir=/var \
- --docdir=/usr/share/doc/${P} \
- --with-ssh-initscript=/etc/init.d/sshd \
- --with-export-dir=/var/lib/ganeti-storage/export \
- --with-os-search-path=/usr/share/ganeti/os \
- $(use_enable syslog) \
- $(usex kvm '--with-kvm-path=' '' '/usr/bin/qemu-kvm' '') \
- $(usex haskell-daemons "--enable-confd=haskell" '' '' '')
-}
-
-src_install () {
- emake V=1 DESTDIR="${D}" install || die "emake install failed"
- newinitd "${FILESDIR}"/ganeti-2.2.initd ganeti
- newconfd "${FILESDIR}"/ganeti.confd ganeti
- use kvm && newinitd "${FILESDIR}"/ganeti-kvm-poweroff.initd ganeti-kvm-poweroff
- use kvm && newconfd "${FILESDIR}"/ganeti-kvm-poweroff.confd ganeti-kvm-poweroff
- newbashcomp doc/examples/bash_completion ganeti
- dodoc INSTALL UPGRADE NEWS README doc/*.rst
- dohtml -r doc/html/*
- rm -rf "${D}"/usr/share/doc/ganeti
-
- docinto examples
- dodoc doc/examples/{ganeti.cron,gnt-config-backup} doc/examples/*.ocf
-
- docinto examples/hooks
- dodoc doc/examples/hooks/{ipsec,ethers}
-
- insinto /etc/cron.d
- newins doc/examples/ganeti.cron ${PN}
-
- insinto /etc/logrotate.d
- newins doc/examples/ganeti.logrotate ${PN}
-
- python_fix_shebang "${D}"/usr/sbin/ "${D}"/usr/"$(get_libdir)"/ganeti/ensure-dirs
-
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
- keepdir /var/lib/ganeti-storage/{export,file,shared}/
-
- python_fix_shebang "${ED}"
-}
-
-src_test () {
- emake check || die "emake check failed"
-}
diff --git a/app-emulation/ganeti/ganeti-2.10.1.ebuild b/app-emulation/ganeti/ganeti-2.10.1.ebuild
index 2dac5aacbbf1..71f68d897d82 100644
--- a/app-emulation/ganeti/ganeti-2.10.1.ebuild
+++ b/app-emulation/ganeti/ganeti-2.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.10.1.ebuild,v 1.1 2014/03/06 19:56:01 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti/ganeti-2.10.1.ebuild,v 1.2 2014/03/07 03:50:02 chutzpah Exp $
EAPI=5
PYTHON_COMPAT=(python2_{6,7})
@@ -11,6 +11,7 @@ inherit eutils confutils autotools bash-completion-r1 python-single-r1 versionat
MY_PV="${PV/_rc/~rc}"
#MY_PV="${PV/_beta/~beta}"
MY_P="${PN}-${MY_PV}"
+SERIES="$(get_version_component_range 1-2)"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.ganeti.org/ganeti.git"
@@ -24,7 +25,7 @@ if [[ ${PV} == "9999" ]] ; then
media-gfx/graphviz
media-fonts/urw-fonts"
else
- SRC_URI="http://downloads.ganeti.org/releases/$(get_version_component_range 1-2)/${P}.tar.gz"
+ SRC_URI="http://downloads.ganeti.org/releases/${SERIES}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -103,6 +104,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.9-disable-root-tests.patch"
"${FILESDIR}/${PN}-2.9-regex-builtin.patch"
"${FILESDIR}/${PN}-2.9-skip-cli-test.patch"
+ "${FILESDIR}/${PN}-2.10-rundir.patch"
)
pkg_setup () {
@@ -120,11 +122,13 @@ src_prepare() {
src_configure () {
econf --localstatedir=/var \
+ --sharedstatedir=/var \
+ --disable-symlinks \
--docdir=/usr/share/doc/${P} \
--with-ssh-initscript=/etc/init.d/sshd \
--with-export-dir=/var/lib/ganeti-storage/export \
--with-os-search-path=/usr/share/ganeti/os \
- $(use_enable syslog) \
+ $(use_enable syslog)
$(usex kvm '--with-kvm-path=' '' '/usr/bin/qemu-kvm' '') \
$(usex haskell-daemons "--enable-confd=haskell" '' '' '')
}
@@ -154,10 +158,13 @@ src_install () {
python_fix_shebang "${D}"/usr/sbin/ "${D}"/usr/"$(get_libdir)"/ganeti/ensure-dirs
- keepdir /var/{lib,log,run}/ganeti/
- keepdir /usr/share/ganeti/os/
+ keepdir /var/{lib,log}/ganeti/
+ keepdir /usr/share/ganeti/${SERIES}/os/
keepdir /var/lib/ganeti-storage/{export,file,shared}/
+ dosym ${SERIES} "/usr/share/ganeti/default"
+ dosym ${SERIES} "/usr/$(get_libdir)/ganeti/default"
+
python_fix_shebang "${ED}"
}