summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-06-15 19:51:55 +0000
committerPacho Ramos <pacho@gentoo.org>2012-06-15 19:51:55 +0000
commita63dc275a4aa644483eee50498d353e7d60104f6 (patch)
treed47c02aac5f39c6465940074bbca0357ade607e6 /app-emulation
parentAdd patch to build properly with parallel make; also build tests in parallel. (diff)
downloadgentoo-2-a63dc275a4aa644483eee50498d353e7d60104f6.tar.gz
gentoo-2-a63dc275a4aa644483eee50498d353e7d60104f6.tar.bz2
gentoo-2-a63dc275a4aa644483eee50498d353e7d60104f6.zip
Drop pulseaudio USE flag as looks like recent skype versions no longer fail when pulse 32 libs are present but pulseaudio not installed.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/ChangeLog9
-rw-r--r--app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20120520-r2.ebuild28
2 files changed, 36 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-soundlibs/ChangeLog b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
index c36e45954b6c..b055a159c26c 100644
--- a/app-emulation/emul-linux-x86-soundlibs/ChangeLog
+++ b/app-emulation/emul-linux-x86-soundlibs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/emul-linux-x86-soundlibs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.79 2012/06/03 13:30:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/ChangeLog,v 1.80 2012/06/15 19:51:55 pacho Exp $
+
+*emul-linux-x86-soundlibs-20120520-r2 (15 Jun 2012)
+
+ 15 Jun 2012; Pacho Ramos <pacho@gentoo.org>
+ +emul-linux-x86-soundlibs-20120520-r2.ebuild:
+ Drop pulseaudio USE flag as looks like recent skype versions no longer fail
+ when pulse 32 libs are present but pulseaudio not installed.
03 Jun 2012; Markos Chandras <hwoarang@gentoo.org>
+emul-linux-x86-soundlibs-20120520-r1.ebuild,
diff --git a/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20120520-r2.ebuild b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20120520-r2.ebuild
new file mode 100644
index 000000000000..d9cd36b660e1
--- /dev/null
+++ b/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20120520-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-soundlibs/emul-linux-x86-soundlibs-20120520-r2.ebuild,v 1.3 2012/06/15 19:51:55 pacho Exp $
+
+EAPI="4"
+
+inherit emul-linux-x86
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1 LGPL-2 as-is gsm public-domain"
+KEYWORDS="-* ~amd64"
+IUSE="alsa"
+
+RDEPEND="~app-emulation/emul-linux-x86-baselibs-${PV}
+ ~app-emulation/emul-linux-x86-medialibs-${PV}"
+
+QA_DT_HASH="usr/lib32/.*"
+
+src_prepare() {
+ _ALLOWED="${S}/etc/env.d"
+ use alsa && _ALLOWED="${_ALLOWED}|${S}/usr/bin/aoss"
+ ALLOWED="(${_ALLOWED})"
+
+ emul-linux-x86_src_prepare
+
+ if use alsa; then
+ mv -f "${S}"/usr/bin/aoss{,32} || die
+ fi
+}