summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2011-01-21 16:27:15 +0000
committerDoug Goldstein <cardoe@gentoo.org>2011-01-21 16:27:15 +0000
commited2025a35f5cfb531079bd642980ddef6d14af3a (patch)
tree2612b6ce422bad64fc7cb138860ef440c6394848 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-ed2025a35f5cfb531079bd642980ddef6d14af3a.tar.gz
gentoo-2-ed2025a35f5cfb531079bd642980ddef6d14af3a.tar.bz2
gentoo-2-ed2025a35f5cfb531079bd642980ddef6d14af3a.zip
Add a USE flag called 'virt-network' that pulls in the depends for NATed networks. This should make it easier for people to install and setup libvirt.
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog7
-rw-r--r--app-emulation/libvirt/libvirt-0.8.7.ebuild23
-rw-r--r--app-emulation/libvirt/metadata.xml6
3 files changed, 23 insertions, 13 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 1dcee9836089..9e805bd82593 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.86 2011/01/20 20:42:27 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.87 2011/01/21 16:27:15 cardoe Exp $
+
+ 21 Jan 2011; Doug Goldstein <cardoe@gentoo.org> libvirt-0.8.7.ebuild,
+ metadata.xml:
+ Add a USE flag called 'virt-network' that pulls in the depends for NATed
+ networks. This should make it easier for people to install and setup libvirt.
20 Jan 2011; Doug Goldstein <cardoe@gentoo.org> libvirt-0.8.7.ebuild:
Update elog message about optional depends for bug #351374
diff --git a/app-emulation/libvirt/libvirt-0.8.7.ebuild b/app-emulation/libvirt/libvirt-0.8.7.ebuild
index 35fa6c3b597b..267baf0037f0 100644
--- a/app-emulation/libvirt/libvirt-0.8.7.ebuild
+++ b/app-emulation/libvirt/libvirt-0.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.8.7.ebuild,v 1.3 2011/01/20 20:42:27 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.8.7.ebuild,v 1.4 2011/01/21 16:27:15 cardoe Exp $
#BACKPORTS=1
#AUTOTOOLIZE=yes
@@ -22,9 +22,9 @@ SRC_URI="http://libvirt.org/sources/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="avahi caps debug iscsi +libvirtd lvm +lxc macvtap +network nfs nls \
- numa openvz parted pcap phyp policykit python qemu sasl selinux
- uml virtualbox xen udev +json"
+IUSE="avahi caps debug iscsi +json +libvirtd lvm +lxc macvtap +network nfs \
+ nls numa openvz parted pcap phyp policykit python qemu sasl selinux udev \
+ uml virtualbox virt-network xen"
# IUSE=one : bug #293416 & bug #299011
RDEPEND="sys-libs/readline
@@ -39,6 +39,7 @@ RDEPEND="sys-libs/readline
avahi? ( >=net-dns/avahi-0.6[dbus] )
caps? ( sys-libs/libcap-ng )
iscsi? ( sys-block/open-iscsi )
+ json? ( dev-libs/yajl )
libvirtd? ( net-misc/bridge-utils )
lvm? ( >=sys-fs/lvm2-2.02.48-r2 )
macvtap? ( >=dev-libs/libnl-1.1 )
@@ -55,7 +56,10 @@ RDEPEND="sys-libs/readline
virtualbox? ( || ( app-emulation/virtualbox >=app-emulation/virtualbox-bin-2.2.0 ) )
xen? ( app-emulation/xen-tools app-emulation/xen )
udev? ( >=sys-fs/udev-145 >=x11-libs/libpciaccess-0.10.9 )
- json? ( dev-libs/yajl )"
+ virt-network? ( net-dns/dnsmasq
+ >=net-firewall/iptables-1.4.9
+ net-firewall/ebtables
+ sys-apps/iproute2 )"
# one? ( dev-libs/xmlrpc-c )
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -228,13 +232,8 @@ pkg_postinst() {
elog
elog "For the basic networking support (bridged and routed networks)"
elog "you don't need any extra software. For more complex network modes"
- elog "including but not limited to NATed network, you'll need the"
- elog "following packages":
- elog
- elog " net-dns/dnsmasq"
- elog " >=net-firewall/iptables-1.4.9"
- elog " net-firewall/ebtables"
- elog " sys-apps/iproute2"
+ elog "including but not limited to NATed network, you can enable the"
+ elog "'virt-network' USE flag."
elog
if has_version net-dns/dnsmasq; then
ewarn "If you have a DNS server setup on your machine, you will have"
diff --git a/app-emulation/libvirt/metadata.xml b/app-emulation/libvirt/metadata.xml
index e692aeeddb74..f1410825ceac 100644
--- a/app-emulation/libvirt/metadata.xml
+++ b/app-emulation/libvirt/metadata.xml
@@ -70,5 +70,11 @@
<flag name='json'>
Support QEmu 0.13 JSON-based interface, using <pkg>dev-libs/yajl</pkg>.
</flag>
+ <flag name='virt-network'>
+ To help people out, this flag includes the dependencies for NATed
+ network mode. Effectively any network setup that relies on libvirt
+ to setup and configure network interfaces on your host. This does not
+ include bridged or routed networks.
+ </flag>
</use>
</pkgmetadata>