summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-28 17:07:00 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-28 17:07:00 +0000
commitf3546057e84d874c65c040e37817ba6925f2ef10 (patch)
tree0a40f42c2c5c8c332331c34192fe3d762ca300ae /app-emulation
parentfix for keystone 2012.2.4 CVE-2013-2104 (diff)
downloadgentoo-2-f3546057e84d874c65c040e37817ba6925f2ef10.tar.gz
gentoo-2-f3546057e84d874c65c040e37817ba6925f2ef10.tar.bz2
gentoo-2-f3546057e84d874c65c040e37817ba6925f2ef10.zip
Bump to fix cgroup movement race and nbd based migrations on IPv6 enabled hosts.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog11
-rw-r--r--app-emulation/libvirt/files/libvirt-1.0.5.1-0001-cgroup-be-robust-against-cgroup-movement-races.patch94
-rw-r--r--app-emulation/libvirt/files/libvirt-1.0.5.1-0002-qemu-fix-NBD-migration-to-hosts-with-IPv6-enabled.patch42
-rw-r--r--app-emulation/libvirt/libvirt-1.0.5.1-r1.ebuild435
4 files changed, 581 insertions, 1 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index ee4db8421453..8db936a117a3 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.273 2013/05/28 15:25:57 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.274 2013/05/28 17:07:00 cardoe Exp $
+
+*libvirt-1.0.5.1-r1 (28 May 2013)
+
+ 28 May 2013; Doug Goldstein <cardoe@gentoo.org> +files/libvirt-1.0.5.1-0001-cg
+ roup-be-robust-against-cgroup-movement-races.patch, +files/libvirt-1.0.5.1-000
+ 2-qemu-fix-NBD-migration-to-hosts-with-IPv6-enabled.patch,
+ +libvirt-1.0.5.1-r1.ebuild:
+ Bump to fix cgroup movement race and nbd based migrations on IPv6 enabled
+ hosts.
28 May 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-1.0.5.1.ebuild:
Change USE flag default to qemu since that's what most people are using
diff --git a/app-emulation/libvirt/files/libvirt-1.0.5.1-0001-cgroup-be-robust-against-cgroup-movement-races.patch b/app-emulation/libvirt/files/libvirt-1.0.5.1-0001-cgroup-be-robust-against-cgroup-movement-races.patch
new file mode 100644
index 000000000000..fcae2530fec6
--- /dev/null
+++ b/app-emulation/libvirt/files/libvirt-1.0.5.1-0001-cgroup-be-robust-against-cgroup-movement-races.patch
@@ -0,0 +1,94 @@
+From b4541a2f3d7ed9e1522065195b4f31529228e493 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Mon, 20 May 2013 20:30:30 -0600
+Subject: [PATCH 1/2] cgroup: be robust against cgroup movement races
+
+https://bugzilla.redhat.com/show_bug.cgi?id=965169 documents a
+problem starting domains when cgroups are enabled; I was able
+to reliably reproduce the race about 5% of the time when I added
+hooks to domain startup by 3 seconds (as that seemed to be about
+the length of time that qemu created and then closed a temporary
+thread, probably related to aio handling of initially opening
+a disk image). The problem has existed since we introduced
+virCgroupMoveTask in commit 9102829 (v0.10.0).
+
+There are some inherent TOCTTOU races when moving tasks between
+kernel cgroups, precisely because threads can be created or
+completed in the window between when we read a thread id from the
+source and when we write to the destination. As the goal of
+virCgroupMoveTask is merely to move ALL tasks into the new
+cgroup, it is sufficient to iterate until no more threads are
+being created in the old group, and ignoring any threads that
+die before we can move them.
+
+It would be nicer to start the threads in the right cgroup to
+begin with, but by default, all child threads are created in
+the same cgroup as their parent, and we don't want vcpu child
+threads in the emulator cgroup, so I don't see any good way
+of avoiding the move. It would also be nice if the kernel were
+to implement something like rename() as a way to atomically move
+a group of threads from one cgroup to another, instead of forcing
+a window where we have to read and parse the source, then format
+and write back into the destination.
+
+* src/util/vircgroup.c (virCgroupAddTaskStrController): Ignore
+ESRCH, because a thread ended between read and write attempts.
+(virCgroupMoveTask): Loop until all threads have moved.
+
+Signed-off-by: Eric Blake <eblake@redhat.com>
+(cherry picked from commit 83e4c77547f5b721afad19a452f41c31daeee8c5)
+---
+ src/util/vircgroup.c | 28 ++++++++++++++++++++--------
+ 1 file changed, 20 insertions(+), 8 deletions(-)
+
+diff --git a/src/util/vircgroup.c b/src/util/vircgroup.c
+index b05fc45..92b185e 100644
+--- a/src/util/vircgroup.c
++++ b/src/util/vircgroup.c
+@@ -1037,7 +1037,11 @@ static int virCgroupAddTaskStrController(virCgroupPtr group,
+ goto cleanup;
+
+ rc = virCgroupAddTaskController(group, p, controller);
+- if (rc != 0)
++ /* A thread that exits between when we first read the source
++ * tasks and now is not fatal. */
++ if (rc == -ESRCH)
++ rc = 0;
++ else if (rc != 0)
+ goto cleanup;
+
+ next = strchr(cur, '\n');
+@@ -1074,15 +1078,23 @@ int virCgroupMoveTask(virCgroupPtr src_group, virCgroupPtr dest_group)
+ !dest_group->controllers[i].mountPoint)
+ continue;
+
+- rc = virCgroupGetValueStr(src_group, i, "tasks", &content);
+- if (rc != 0)
+- return rc;
++ /* New threads are created in the same group as their parent;
++ * but if a thread is created after we first read we aren't
++ * aware that it needs to move. Therefore, we must iterate
++ * until content is empty. */
++ while (1) {
++ rc = virCgroupGetValueStr(src_group, i, "tasks", &content);
++ if (rc != 0)
++ return rc;
++ if (!*content)
++ break;
+
+- rc = virCgroupAddTaskStrController(dest_group, content, i);
+- if (rc != 0)
+- goto cleanup;
++ rc = virCgroupAddTaskStrController(dest_group, content, i);
++ if (rc != 0)
++ goto cleanup;
+
+- VIR_FREE(content);
++ VIR_FREE(content);
++ }
+ }
+
+ cleanup:
+--
+1.8.1.5
+
diff --git a/app-emulation/libvirt/files/libvirt-1.0.5.1-0002-qemu-fix-NBD-migration-to-hosts-with-IPv6-enabled.patch b/app-emulation/libvirt/files/libvirt-1.0.5.1-0002-qemu-fix-NBD-migration-to-hosts-with-IPv6-enabled.patch
new file mode 100644
index 000000000000..09936eea6c76
--- /dev/null
+++ b/app-emulation/libvirt/files/libvirt-1.0.5.1-0002-qemu-fix-NBD-migration-to-hosts-with-IPv6-enabled.patch
@@ -0,0 +1,42 @@
+From 3accd7eb25f3646e15511af4cb0d09c3bf2ce143 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
+Date: Thu, 23 May 2013 15:51:05 +0200
+Subject: [PATCH 2/2] qemu: fix NBD migration to hosts with IPv6 enabled
+
+Since f03dcc5 we use [::] as the listening address both on qemu
+command line in -incoming and in nbd-server-start QMP command.
+However the latter requires just :: without the braces.
+(cherry picked from commit 2326006410a921bba38c0ce67a367cd1ea88cc33)
+---
+ src/qemu/qemu_migration.c | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/src/qemu/qemu_migration.c b/src/qemu/qemu_migration.c
+index 6ad1c30..adc967a 100644
+--- a/src/qemu/qemu_migration.c
++++ b/src/qemu/qemu_migration.c
+@@ -1114,6 +1114,12 @@ qemuMigrationStartNBDServer(virQEMUDriverPtr driver,
+ unsigned short port = 0;
+ char *diskAlias = NULL;
+ size_t i;
++ const char *host;
++
++ if (STREQ(listenAddr, "[::]"))
++ host = "::";
++ else
++ host = listenAddr;
+
+ for (i = 0; i < vm->def->ndisks; i++) {
+ virDomainDiskDefPtr disk = vm->def->disks[i];
+@@ -1135,7 +1141,7 @@ qemuMigrationStartNBDServer(virQEMUDriverPtr driver,
+
+ if (!port &&
+ ((virPortAllocatorAcquire(driver->remotePorts, &port) < 0) ||
+- (qemuMonitorNBDServerStart(priv->mon, listenAddr, port) < 0))) {
++ (qemuMonitorNBDServerStart(priv->mon, host, port) < 0))) {
+ qemuDomainObjExitMonitor(driver, vm);
+ goto cleanup;
+ }
+--
+1.8.1.5
+
diff --git a/app-emulation/libvirt/libvirt-1.0.5.1-r1.ebuild b/app-emulation/libvirt/libvirt-1.0.5.1-r1.ebuild
new file mode 100644
index 000000000000..721a8ecdf02b
--- /dev/null
+++ b/app-emulation/libvirt/libvirt-1.0.5.1-r1.ebuild
@@ -0,0 +1,435 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.1-r1.ebuild,v 1.1 2013/05/28 17:07:00 cardoe Exp $
+
+EAPI=5
+
+#BACKPORTS=9bf6bec4
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+PYTHON_DEPEND="python? 2:2.5"
+#RESTRICT_PYTHON_ABIS="3.*"
+#SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python user autotools linux-info systemd
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://libvirt.org/libvirt.git"
+ AUTOTOOLIZE=yes
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://libvirt.org/sources/stable_updates/${MY_P}.tar.gz
+ ftp://libvirt.org/libvirt/stable_updates/${MY_P}.tar.gz
+ ${BACKPORTS:+
+ http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="C toolkit to manipulate virtual machines"
+HOMEPAGE="http://www.libvirt.org/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="audit avahi +caps firewalld fuse iscsi +libvirtd lvm lxc +macvtap nfs \
+ nls numa openvz parted pcap phyp policykit python +qemu rbd sasl \
+ selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc \
+ systemd"
+REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
+ lxc? ( caps libvirtd )
+ openvz? ( libvirtd )
+ qemu? ( libvirtd )
+ uml? ( libvirtd )
+ vepa? ( macvtap )
+ virtualbox? ( libvirtd )
+ xen? ( libvirtd )
+ virt-network? ( libvirtd )
+ firewalld? ( virt-network )"
+
+# gettext.sh command is used by the libvirt command wrappers, and it's
+# non-optional, so put it into RDEPEND.
+# We can use both libnl:1.1 and libnl:3, but if you have both installed, the
+# package will use 3 by default. Since we don't have slot pinning in an API,
+# we must go with the most recent
+RDEPEND="sys-libs/readline
+ sys-libs/ncurses
+ >=net-misc/curl-7.18.0
+ dev-libs/libgcrypt
+ >=dev-libs/libxml2-2.7.6
+ dev-libs/libnl:3
+ >=net-libs/gnutls-1.0.25
+ net-libs/libssh2
+ sys-apps/dmidecode
+ >=sys-apps/util-linux-2.17
+ sys-devel/gettext
+ >=net-analyzer/netcat6-1.0-r2
+ app-misc/scrub
+ audit? ( sys-process/audit )
+ avahi? ( >=net-dns/avahi-0.6[dbus] )
+ caps? ( sys-libs/libcap-ng )
+ fuse? ( >=sys-fs/fuse-2.8.6 )
+ iscsi? ( sys-block/open-iscsi )
+ lxc? ( sys-power/pm-utils )
+ lvm? ( >=sys-fs/lvm2-2.02.48-r2 )
+ nfs? ( net-fs/nfs-utils )
+ numa? (
+ >sys-process/numactl-2.0.2
+ sys-process/numad
+ )
+ openvz? ( sys-kernel/openvz-sources )
+ parted? (
+ >=sys-block/parted-1.8[device-mapper]
+ sys-fs/lvm2
+ )
+ pcap? ( >=net-libs/libpcap-1.0.0 )
+ policykit? ( >=sys-auth/polkit-0.9 )
+ qemu? (
+ >=app-emulation/qemu-0.13.0
+ dev-libs/yajl
+ sys-power/pm-utils
+ )
+ rbd? ( sys-cluster/ceph )
+ sasl? ( dev-libs/cyrus-sasl )
+ selinux? ( >=sys-libs/libselinux-2.0.85 )
+ virtualbox? ( || ( app-emulation/virtualbox >=app-emulation/virtualbox-bin-2.2.0 ) )
+ xen? ( app-emulation/xen-tools app-emulation/xen )
+ udev? ( virtual/udev >=x11-libs/libpciaccess-0.10.9 )
+ virt-network? ( net-dns/dnsmasq
+ >=net-firewall/iptables-1.4.10
+ net-misc/radvd
+ net-firewall/ebtables
+ sys-apps/iproute2[-minimal]
+ firewalld? ( net-firewall/firewalld )
+ )
+ elibc_glibc? ( || ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 ) )"
+# one? ( dev-libs/xmlrpc-c )
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/xhtml1
+ dev-libs/libxslt
+ =dev-lang/python-2*"
+
+LXC_CONFIG_CHECK="
+ ~CGROUPS
+ ~CGROUP_FREEZER
+ ~CGROUP_DEVICE
+ ~CGROUP_CPUACCT
+ ~CGROUP_SCHED
+ ~CGROUP_PERF
+ ~BLK_CGROUP
+ ~NET_CLS_CGROUP
+ ~NETPRIO_CGROUP
+ ~CPUSETS
+ ~RESOURCE_COUNTERS
+ ~NAMESPACES
+ ~UTS_NS
+ ~IPC_NS
+ ~PID_NS
+ ~NET_NS
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~VETH
+ ~MACVLAN
+ ~POSIX_MQUEUE
+ ~!GRKERNSEC_CHROOT_MOUNT
+ ~!GRKERNSEC_CHROOT_DOUBLE
+ ~!GRKERNSEC_CHROOT_PIVOT
+ ~!GRKERNSEC_CHROOT_CHMOD
+ ~!GRKERNSEC_CHROOT_CAPS
+"
+
+VIRTNET_CONFIG_CHECK="
+ ~BRIDGE_NF_EBTABLES
+ ~BRIDGE_EBT_MARK_T
+ ~NETFILTER_ADVANCED
+ ~NETFILTER_XT_TARGET_CHECKSUM
+ ~NETFILTER_XT_CONNMARK
+ ~NETFILTER_XT_MARK
+"
+
+MACVTAP_CONFIG_CHECK="~MACVTAP"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
+ enewgroup qemu 77
+ enewuser qemu 77 -1 -1 qemu kvm
+
+ # Some people used the masked ebuild which was not adding the qemu
+ # user to the kvm group originally. This results in VMs failing to
+ # start for some users. bug #430808
+ egetent group kvm | grep -q qemu
+ if [[ $? -ne 0 ]]; then
+ gpasswd -a qemu kvm
+ fi
+
+ # Handle specific kernel versions for different features
+ kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
+ kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
+
+ CONFIG_CHECK=""
+ use fuse && CONFIG_CHECK+=" ~FUSE_FS"
+ use lxc && CONFIG_CHECK+="${LXC_CONFIG_CHECK}"
+ use macvtap && CONFIG_CHECK+="${MACVTAP}"
+ use virt-network && CONFIG_CHECK+="${VIRTNET_CONFIG_CHECK}"
+ if [[ -n ${CONFIG_CHECK} ]]; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ touch "${S}/.mailmap"
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ if [[ ${PV} = *9999* ]]; then
+
+ # git checkouts require bootstrapping to create the configure script.
+ # Additionally the submodules must be cloned to the right locations
+ # bug #377279
+ ./bootstrap || die "bootstrap failed"
+ (
+ git submodule status | sed 's/^[ +-]//;s/ .*//'
+ git hash-object bootstrap.conf
+ ) >.git-module-status
+ fi
+
+ epatch "${FILESDIR}"/${P}-0001*.patch
+ epatch "${FILESDIR}"/${P}-0002*.patch
+
+ epatch_user
+
+ [[ -n ${AUTOTOOLIZE} ]] && eautoreconf
+
+ # Tweak the init script
+ local avahi_init=
+ local iscsi_init=
+ local rbd_init=
+ local firewalld_init=
+ cp "${FILESDIR}/libvirtd.init-r11" "${S}/libvirtd.init"
+ use avahi && avahi_init='avahi-daemon'
+ use iscsi && iscsi_init='iscsid'
+ use rbd && rbd_init='ceph'
+ use firewalld && firewalld_init='need firewalld'
+
+ sed -e "s/USE_FLAG_FIREWALLD/${firewalld_init}/" -i "${S}/libvirtd.init"
+ sed -e "s/USE_FLAG_AVAHI/${avahi_init}/" -i "${S}/libvirtd.init"
+ sed -e "s/USE_FLAG_ISCSI/${iscsi_init}/" -i "${S}/libvirtd.init"
+ sed -e "s/USE_FLAG_RBD/${rbd_init}/" -i "${S}/libvirtd.init"
+}
+
+src_configure() {
+ local myconf=""
+
+ ## enable/disable daemon, otherwise client only utils
+ myconf="${myconf} $(use_with libvirtd)"
+
+ ## enable/disable the daemon using avahi to find VMs
+ myconf="${myconf} $(use_with avahi)"
+
+ ## hypervisors on the local host
+ myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
+ myconf+=" --without-xenapi"
+ if use xen && has_version ">=app-emulation/xen-tools-4.2.0"; then
+ myconf+=" --with-libxl"
+ else
+ myconf+=" --without-libxl"
+ fi
+ myconf="${myconf} $(use_with openvz)"
+ myconf="${myconf} $(use_with lxc)"
+ if use virtualbox && has_version app-emulation/virtualbox-ose; then
+ myconf="${myconf} --with-vbox=/usr/lib/virtualbox-ose/"
+ else
+ myconf="${myconf} $(use_with virtualbox vbox)"
+ fi
+ myconf="${myconf} $(use_with uml)"
+ myconf="${myconf} $(use_with qemu)"
+ myconf="${myconf} $(use_with qemu yajl)" # Use QMP over HMP
+ myconf="${myconf} $(use_with phyp)"
+ myconf="${myconf} --with-esx"
+ myconf="${myconf} --with-vmware"
+
+ ## additional host drivers
+ myconf="${myconf} $(use_with virt-network network)"
+ myconf="${myconf} --with-storage-fs"
+ myconf="${myconf} $(use_with lvm storage-lvm)"
+ myconf="${myconf} $(use_with iscsi storage-iscsi)"
+ myconf="${myconf} $(use_with parted storage-disk)"
+ myconf="${myconf} $(use_with lvm storage-mpath)"
+ myconf="${myconf} $(use_with rbd storage-rbd)"
+ myconf="${myconf} $(use_with numa numactl)"
+ myconf="${myconf} $(use_with numa numad)"
+ myconf="${myconf} $(use_with selinux)"
+ myconf="${myconf} $(use_with fuse)"
+
+ # udev for device support details
+ myconf="${myconf} $(use_with udev)"
+
+ # linux capability support so we don't need privileged accounts
+ myconf="${myconf} $(use_with caps capng)"
+
+ ## auth stuff
+ myconf="${myconf} $(use_with policykit polkit)"
+ myconf="${myconf} $(use_with sasl)"
+
+ # network bits
+ myconf="${myconf} $(use_with macvtap)"
+ myconf="${myconf} $(use_with pcap libpcap)"
+ myconf="${myconf} $(use_with vepa virtualport)"
+ myconf="${myconf} $(use_with firewalld)"
+
+ ## other
+ myconf="${myconf} $(use_enable nls)"
+ myconf="${myconf} $(use_with python)"
+
+ # user privilege bits fir qemu/kvm
+ if use caps; then
+ myconf="${myconf} --with-qemu-user=qemu"
+ myconf="${myconf} --with-qemu-group=qemu"
+ else
+ myconf="${myconf} --with-qemu-user=root"
+ myconf="${myconf} --with-qemu-group=root"
+ fi
+
+ # audit support
+ myconf="${myconf} $(use_with audit)"
+
+ ## stuff we don't yet support
+ myconf="${myconf} --without-netcf"
+
+ # we use udev over hal
+ myconf="${myconf} --without-hal"
+
+ # locking support
+ myconf="${myconf} --without-sanlock"
+
+ # systemd unit files
+ use systemd && myconf="${myconf} --with-init-script=systemd"
+
+ # this is a nasty trick to work around the problem in bug
+ # #275073. The reason why we don't solve this properly is that
+ # it'll require us to rebuild autotools (and we don't really want
+ # to do that right now). The proper solution has been sent
+ # upstream and should hopefully land in 0.7.7, in the mean time,
+ # mime the same functionality with this.
+ case ${CHOST} in
+ *cygwin* | *mingw* )
+ ;;
+ *)
+ ac_cv_prog_WINDRES=no
+ ;;
+ esac
+
+ econf \
+ ${myconf} \
+ --disable-static \
+ --docdir=/usr/share/doc/${PF} \
+ --with-remote \
+ --localstatedir=/var
+
+ if [[ ${PV} = *9999* ]]; then
+ # Restore gnulib's config.sub and config.guess
+ # bug #377279
+ (cd .gnulib && git reset --hard > /dev/null)
+ fi
+}
+
+src_test() {
+ # Explicitly allow parallel build of tests
+ export VIR_TEST_DEBUG=1
+ HOME="${T}" emake check || die "tests failed"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ HTML_DIR=/usr/share/doc/${PF}/html \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/examples \
+ SYSTEMD_UNIT_DIR="$(systemd_get_unitdir)" \
+ || die "emake install failed"
+
+ find "${D}" -name '*.la' -delete || die
+
+ use libvirtd || return 0
+ # From here, only libvirtd-related instructions, be warned!
+
+ newinitd "${S}/libvirtd.init" libvirtd || die
+ newconfd "${FILESDIR}/libvirtd.confd-r4" libvirtd || die
+
+ keepdir /var/lib/libvirt/images
+}
+
+pkg_preinst() {
+ # we only ever want to generate this once
+ if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
+ rm -rf "${D}"/etc/libvirt/qemu/networks/default.xml
+ fi
+
+ # We really don't want to use or support old PolicyKit cause it
+ # screws with the new polkit integration
+ if has_version sys-auth/policykit; then
+ rm -rf "${D}"/usr/share/PolicyKit/policy/org.libvirt.unix.policy
+ fi
+
+ # Only sysctl files ending in .conf work
+ mv "${D}"/usr/lib/sysctl.d/libvirtd.conf "${D}"/etc/sysctl.d/libvirtd.conf
+}
+
+pkg_postinst() {
+ use python && python_mod_optimize libvirt.py
+
+ if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
+ touch "${ROOT}"/etc/libvirt/qemu/networks/default.xml
+ fi
+
+ # support for dropped privileges
+ if use qemu; then
+ fperms 0750 "${EROOT}/var/lib/libvirt/qemu"
+ fperms 0750 "${EROOT}/var/cache/libvirt/qemu"
+ fi
+
+ if use caps && use qemu; then
+ fowners -R qemu:qemu "${EROOT}/var/lib/libvirt/qemu"
+ fowners -R qemu:qemu "${EROOT}/var/cache/libvirt/qemu"
+ elif use qemu; then
+ fowners -R root:root "${EROOT}/var/lib/libvirt/qemu"
+ fowners -R root:root "${EROOT}/var/cache/libvirt/qemu"
+ fi
+
+ if ! use policykit; then
+ elog "To allow normal users to connect to libvirtd you must change the"
+ elog "unix sock group and/or perms in /etc/libvirt/libvirtd.conf"
+ fi
+
+ use libvirtd || return 0
+ # From here, only libvirtd-related instructions, be warned!
+
+ elog
+ elog "For the basic networking support (bridged and routed networks)"
+ elog "you don't need any extra software. For more complex network modes"
+ elog "including but not limited to NATed network, you can enable the"
+ elog "'virt-network' USE flag."
+ elog
+ if has_version net-dns/dnsmasq; then
+ ewarn "If you have a DNS server setup on your machine, you will have"
+ ewarn "to configure /etc/dnsmasq.conf to enable the following settings: "
+ ewarn " bind-interfaces"
+ ewarn " interface or except-interface"
+ ewarn
+ ewarn "Otherwise you might have issues with your existing DNS server."
+ fi
+
+ if use caps && use qemu; then
+ elog "libvirt will now start qemu/kvm VMs with non-root privileges."
+ elog "Ensure any resources your VMs use are accessible by qemu:qemu"
+ fi
+}
+
+pkg_postrm() {
+ use python && python_mod_cleanup libvirt.py
+}