summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2014-08-31 00:37:43 +0000
committerMike Auty <ikelos@gentoo.org>2014-08-31 00:37:43 +0000
commit4e14cb360ea20bccc992553ce9195fdeecefbb67 (patch)
tree6933be58737d7f7dec38d4f8a5b6e98a1e309118 /app-forensics/foremost
parentmore correcting of deps (diff)
downloadgentoo-2-4e14cb360ea20bccc992553ce9195fdeecefbb67.tar.gz
gentoo-2-4e14cb360ea20bccc992553ce9195fdeecefbb67.tar.bz2
gentoo-2-4e14cb360ea20bccc992553ce9195fdeecefbb67.zip
Add in patch for -Werror=format-security warning (fixes bug 521038).
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 6C20157A)
Diffstat (limited to 'app-forensics/foremost')
-rw-r--r--app-forensics/foremost/ChangeLog10
-rw-r--r--app-forensics/foremost/files/foremost-1.5.7-format-security.patch22
-rw-r--r--app-forensics/foremost/foremost-1.5.7-r2.ebuild36
3 files changed, 66 insertions, 2 deletions
diff --git a/app-forensics/foremost/ChangeLog b/app-forensics/foremost/ChangeLog
index 9115134fe2f5..3ef3264fa288 100644
--- a/app-forensics/foremost/ChangeLog
+++ b/app-forensics/foremost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/foremost
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/ChangeLog,v 1.26 2012/01/09 19:02:59 ranger Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/ChangeLog,v 1.27 2014/08/31 00:37:43 ikelos Exp $
+
+*foremost-1.5.7-r2 (31 Aug 2014)
+
+ 31 Aug 2014; Mike Auty <ikelos@gentoo.org> +foremost-1.5.7-r2.ebuild,
+ +files/foremost-1.5.7-format-security.patch:
+ Add in patch for -Werror=format-security warning (fixes bug 521038).
09 Jan 2012; Brent Baude <ranger@gentoo.org> foremost-1.5.7-r1.ebuild:
Marking foremost-1.5.7-r1 ppc for bug 391467
diff --git a/app-forensics/foremost/files/foremost-1.5.7-format-security.patch b/app-forensics/foremost/files/foremost-1.5.7-format-security.patch
new file mode 100644
index 000000000000..32d1a4d3c7f6
--- /dev/null
+++ b/app-forensics/foremost/files/foremost-1.5.7-format-security.patch
@@ -0,0 +1,22 @@
+diff --git a/extract.c b/extract.c
+index 30bdf54..9639117 100755
+--- a/extract.c
++++ b/extract.c
+@@ -2110,7 +2110,6 @@ unsigned char *extract_exe(f_state *s, u_int64_t c_offset, unsigned char *founda
+ int i = 0;
+ time_t compile_time = 0;
+ struct tm *ret_time;
+- char comment[32];
+ char ascii_time[32];
+
+ if (buflen < 100)
+@@ -2145,8 +2144,7 @@ unsigned char *extract_exe(f_state *s, u_int64_t c_offset, unsigned char *founda
+ ret_time->tm_sec);
+ chop(ascii_time);
+
+- sprintf(comment, ascii_time);
+- strcat(needle->comment, comment);
++ strcat(needle->comment, ascii_time);
+ exe_char = htos(&foundat[22], FOREMOST_LITTLE_ENDIAN);
+ if (exe_char & 0x2000)
+ {
diff --git a/app-forensics/foremost/foremost-1.5.7-r2.ebuild b/app-forensics/foremost/foremost-1.5.7-r2.ebuild
new file mode 100644
index 000000000000..4a07188845e1
--- /dev/null
+++ b/app-forensics/foremost/foremost-1.5.7-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.7-r2.ebuild,v 1.1 2014/08/31 00:37:43 ikelos Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A console program to recover files based on their headers and footers"
+HOMEPAGE="http://foremost.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+# starting to hate sf.net ...
+SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+LICENSE="public-domain"
+SLOT="0"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.4-config-location.patch"
+ epatch "${FILESDIR}/${PN}-1.5.7-format-security.patch"
+}
+
+src_compile() {
+ emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ CONF=/etc
+}
+
+src_install() {
+ dobin foremost
+ doman foremost.8.gz
+ insinto /etc
+ doins foremost.conf
+ dodoc README CHANGES
+}