summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 00:36:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 00:36:59 +0000
commitcf141588a6b941125b8f439b6243a0432a638c1e (patch)
treedc57bdffe4c871d437c48c391e52b97fcf6063a0 /app-forensics/rdd/rdd-2.0.7.ebuild
parentInitial commit (diff)
downloadgentoo-2-cf141588a6b941125b8f439b6243a0432a638c1e.tar.gz
gentoo-2-cf141588a6b941125b8f439b6243a0432a638c1e.tar.bz2
gentoo-2-cf141588a6b941125b8f439b6243a0432a638c1e.zip
Initial import. Fixes #181189. Ebuild by RB <aoz.syn@gmail.com> based on work by Pieter de Rijk.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/rdd/rdd-2.0.7.ebuild')
-rw-r--r--app-forensics/rdd/rdd-2.0.7.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-forensics/rdd/rdd-2.0.7.ebuild b/app-forensics/rdd/rdd-2.0.7.ebuild
new file mode 100644
index 000000000000..05e3aadeccd1
--- /dev/null
+++ b/app-forensics/rdd/rdd-2.0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/rdd-2.0.7.ebuild,v 1.1 2009/03/01 00:36:59 patrick Exp $
+
+inherit autotools
+
+DESCRIPTION="Rdd is a forensic copy program"
+HOMEPAGE="http://www.sf.net/projects/rdd"
+SRC_URI="mirror://sourceforge/rdd/rdd-2.0.7.tar.gz"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="debug rawio gtk"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="gtk? ( >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2 )"
+
+RDEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use gtk || sed -i 's/AM_PATH_GTK_2_0//' configure.ac
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug tracing)\
+ $(use_enable gtk gui)\
+ $(use_enable rawio raw-device)
+ emake
+}
+
+src_install() {
+ # emake install has a sandbox violation in src/Makefile
+ dobin src/rdd-copy
+ dobin src/rdd-verify
+ dobin src/rddi.py
+ doman src/*.1
+ dodoc doc/*.txt
+ dosym rdd-copy /usr/bin/rdd
+ dosym rddi.py /usr/bin/rddi
+}