summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-13 18:04:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-13 18:04:52 +0000
commitf1f3f64f0c33c86529bd10e75110f40914abb84d (patch)
tree5d098ca12e82319ce5f80e34ee514172aaacba4c /app-forensics/zzuf/zzuf-0.12.ebuild
parentVersion bump. (diff)
downloadgentoo-2-f1f3f64f0c33c86529bd10e75110f40914abb84d.tar.gz
gentoo-2-f1f3f64f0c33c86529bd10e75110f40914abb84d.tar.bz2
gentoo-2-f1f3f64f0c33c86529bd10e75110f40914abb84d.zip
Version bump, fix tests being built unconditionally (bug #226355), add src_test for the testsuite, which doesn't work with sandbox.
(Portage version: 2.1.5.5)
Diffstat (limited to 'app-forensics/zzuf/zzuf-0.12.ebuild')
-rw-r--r--app-forensics/zzuf/zzuf-0.12.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-forensics/zzuf/zzuf-0.12.ebuild b/app-forensics/zzuf/zzuf-0.12.ebuild
new file mode 100644
index 000000000000..5065968a45da
--- /dev/null
+++ b/app-forensics/zzuf/zzuf-0.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.12.ebuild,v 1.1 2008/06/13 18:04:52 flameeyes Exp $
+
+inherit autotools
+
+DESCRIPTION="Transparent application input fuzzer"
+HOMEPAGE="http://libcaca.zoy.org/wiki/zzuf/"
+SRC_URI="mirro://gentoo/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
+ || die "unable to fix the configure.ac"
+ sed -i -e 's:noinst_:check_:' "${S}"/test/Makefile.am \
+ || die "unable to fix unconditional test building"
+
+ eautoreconf
+}
+
+src_compile() {
+ # Don't build the static library, as the library is only used for
+ # preloading, so there is no reason to build it statically, unless
+ # you want to use zzuf with a static-linked executable, which I'm
+ # not even sure would be a good idea.
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+# This could be removed in next versions if my patches will be applied
+# by Sam. -- Diego 'Flameeyes'
+src_test() {
+ if hasq sandbox ${FEATURES}; then
+ ewarn "zzuf tests don't work correctly when sandbox is enabled,"
+ ewarn "skipping tests. If you want to run the testsuite, please"
+ ewarn "disable sandbox for this build."
+ return
+ fi
+
+ cd "${S}"/test
+ emake check || die "Unable to build tools needed for testsuite"
+
+ ./testsuite.sh || die "testsuite failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ find "${D}" -name '*.la' -delete
+}