summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-04 08:11:50 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-04 08:11:50 +0000
commitba6922a2d7ca9f9989ae2a368b01c6eb9094001f (patch)
treea8bd9cb994359c1adac7b783610f88dd0c836345 /app-forensics
parentAlways enable libavresample: strictly speaking enabling or disabling it chang... (diff)
downloadgentoo-2-ba6922a2d7ca9f9989ae2a368b01c6eb9094001f.tar.gz
gentoo-2-ba6922a2d7ca9f9989ae2a368b01c6eb9094001f.tar.bz2
gentoo-2-ba6922a2d7ca9f9989ae2a368b01c6eb9094001f.zip
Bump
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rdd/ChangeLog10
-rw-r--r--app-forensics/rdd/rdd-3.0.4.ebuild50
2 files changed, 57 insertions, 3 deletions
diff --git a/app-forensics/rdd/ChangeLog b/app-forensics/rdd/ChangeLog
index b203341fd642..5bcdced66ce0 100644
--- a/app-forensics/rdd/ChangeLog
+++ b/app-forensics/rdd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/rdd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/ChangeLog,v 1.3 2011/03/27 10:35:16 nirbheek Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/ChangeLog,v 1.4 2013/04/04 08:11:50 patrick Exp $
+
+*rdd-3.0.4 (04 Apr 2013)
+
+ 04 Apr 2013; Patrick Lauer <patrick@gentoo.org> +rdd-3.0.4.ebuild:
+ Bump
27 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org> rdd-2.0.7.ebuild:
Fix slot-deps on gnome libs
@@ -14,4 +19,3 @@
+rdd-2.0.7.ebuild:
Initial import. Fixes #181189. Ebuild by RB <aoz.syn@gmail.com> based on
work by Pieter de Rijk.
-
diff --git a/app-forensics/rdd/rdd-3.0.4.ebuild b/app-forensics/rdd/rdd-3.0.4.ebuild
new file mode 100644
index 000000000000..34a2f352a0e0
--- /dev/null
+++ b/app-forensics/rdd/rdd-3.0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rdd/rdd-3.0.4.ebuild,v 1.1 2013/04/04 08:11:50 patrick Exp $
+
+EAPI="5"
+
+inherit autotools
+
+# no worky
+RESTRICT="test"
+
+DESCRIPTION="Rdd is a forensic copy program"
+HOMEPAGE="http://www.sf.net/projects/rdd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="debug"
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="app-forensics/libewf
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's/AM_PATH_GTK_2_0//' configure.ac || die
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug tracing)
+}
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ # emake install has a sandbox violation in src/Makefile
+ dobin src/rdd-copy
+ dobin src/rdd-verify
+ dobin src/rddi.py
+ doman src/*.1
+ dohtml doxygen-doc/html/*
+ dosym rdd-copy /usr/bin/rdd
+ dosym rddi.py /usr/bin/rddi
+}
+