summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-05-08 16:16:12 +0000
committerSamuli Suominen <drac@gentoo.org>2007-05-08 16:16:12 +0000
commitd4e8dc0c8340670521776c4e76564ed559399519 (patch)
tree2a8147bfe3bcbd3676ddb6ee1b04ce1998fb442f /app-i18n/bidiv/bidiv-1.5.ebuild
parentNew ebuild, imported from my overlay. (diff)
downloadgentoo-2-d4e8dc0c8340670521776c4e76564ed559399519.tar.gz
gentoo-2-d4e8dc0c8340670521776c4e76564ed559399519.tar.bz2
gentoo-2-d4e8dc0c8340670521776c4e76564ed559399519.zip
Version bump for bug 177244. Change herd from middle-east to cjk.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-i18n/bidiv/bidiv-1.5.ebuild')
-rw-r--r--app-i18n/bidiv/bidiv-1.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-i18n/bidiv/bidiv-1.5.ebuild b/app-i18n/bidiv/bidiv-1.5.ebuild
new file mode 100644
index 000000000000..257ee7d6c363
--- /dev/null
+++ b/app-i18n/bidiv/bidiv-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/bidiv/bidiv-1.5.ebuild,v 1.1 2007/05/08 16:16:12 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A BiDirectional Text Viewer"
+HOMEPAGE="http://www.ivrix.org.il"
+SRC_URI="http://ftp.ivrix.org.il/pub/ivrix/src/cmdline/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${PN}
+
+DEPEND="dev-libs/fribidi"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin bidiv
+ dodoc README WHATSNEW
+ doman bidiv.1
+}