summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-01-22 06:32:35 +0000
committerMamoru Komachi <usata@gentoo.org>2004-01-22 06:32:35 +0000
commit0d1aa97a5a996073aa58ef8a2b5408a184ef6edd (patch)
tree2dedd71d35017b8244527e8e476500d7d2302bb9 /app-i18n/jmcce/jmcce-1.4_rc2.ebuild
parenthppa stable (diff)
downloadgentoo-2-0d1aa97a5a996073aa58ef8a2b5408a184ef6edd.tar.gz
gentoo-2-0d1aa97a5a996073aa58ef8a2b5408a184ef6edd.tar.bz2
gentoo-2-0d1aa97a5a996073aa58ef8a2b5408a184ef6edd.zip
Fixed a bug related to gcc 3.x. Closing bug #38117
Diffstat (limited to 'app-i18n/jmcce/jmcce-1.4_rc2.ebuild')
-rw-r--r--app-i18n/jmcce/jmcce-1.4_rc2.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/app-i18n/jmcce/jmcce-1.4_rc2.ebuild b/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
index 94efcc3aa02b..2a6698faa3c3 100644
--- a/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
+++ b/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/jmcce-1.4_rc2.ebuild,v 1.3 2003/09/06 22:19:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/jmcce-1.4_rc2.ebuild,v 1.4 2004/01/22 06:32:25 usata Exp $
+
+inherit gcc
+
+MY_P=${P/_rc/RC}
+S=${WORKDIR}/${MY_P}
-MY_PV=${PV/_rc/RC}
-S=${WORKDIR}/${PN}-${MY_PV}
DESCRIPTION="A Chinese Console supporting BIG5, GB and Japanese input."
HOMEPAGE="http://jmcce.slat.org"
-SRC_URI="http://zope.slat.org/Project/Jmcce/DOWNLOAD/${PN}-${MY_PV}.tar.gz"
+SRC_URI="http://zope.slat.org/Project/Jmcce/DOWNLOAD/${MY_P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
@@ -18,22 +21,28 @@ DEPEND=">=media-libs/svgalib-1.4.3
MAKEOPTS="${MAKEOPTS} -j1"
-src_compile() {
+src_unpack() {
+
+ unpack ${A}
cd ${S}
+ if [ `gcc-version` = "3.3" ] ; then
+ epatch ${FILESDIR}/${P}-gcc3-gentoo.diff
+ fi
+}
- ./genconf.sh
- econf --sysconfdir=/etc/jmcce
+src_compile() {
+
+ ./genconf.sh || die
+ econf --sysconfdir=/etc/jmcce || die "econf failed"
emake || die "make failed"
}
src_install() {
+
dodir /etc/jmcce
make DESTDIR=${D} install || die "install failed"
- dodir /usr/share/doc
- mv ${D}/usr/share/doc/jmcce-1.4RC2 ${D}/usr/share/doc/${PF}
+ mv ${D}/usr/share/doc/{${MY_P},${PF}}
doman doc/jmcce.1
}
-
-