summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-24 14:49:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-24 14:49:28 +0000
commit974f5252b23398c232c390093f1c94d55aff1583 (patch)
tree49ff8a830ae318dfa32764d2292357024cb175ac /app-i18n/scim-pinyin
parentSparc stable --- Bug #260088 which see for brief comments. (diff)
downloadgentoo-2-974f5252b23398c232c390093f1c94d55aff1583.tar.gz
gentoo-2-974f5252b23398c232c390093f1c94d55aff1583.tar.bz2
gentoo-2-974f5252b23398c232c390093f1c94d55aff1583.zip
-m
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim-pinyin')
-rw-r--r--app-i18n/scim-pinyin/ChangeLog11
-rw-r--r--app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch62
-rw-r--r--app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild (renamed from app-i18n/scim-pinyin/scim-pinyin-0.5.91-r1.ebuild)12
-rw-r--r--app-i18n/scim-pinyin/scim-pinyin-0.5.91.ebuild30
4 files changed, 78 insertions, 37 deletions
diff --git a/app-i18n/scim-pinyin/ChangeLog b/app-i18n/scim-pinyin/ChangeLog
index 7daae94548a5..eaa1936297f5 100644
--- a/app-i18n/scim-pinyin/ChangeLog
+++ b/app-i18n/scim-pinyin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/scim-pinyin
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-pinyin/ChangeLog,v 1.31 2008/12/02 23:30:24 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-pinyin/ChangeLog,v 1.32 2009/02/24 14:49:28 matsuu Exp $
+
+*scim-pinyin-0.5.91-r3 (24 Feb 2009)
+
+ 24 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +files/scim-pinyin-0.5.91-gbk.patch, -scim-pinyin-0.5.91.ebuild,
+ -scim-pinyin-0.5.91-r1.ebuild, +scim-pinyin-0.5.91-r3.ebuild:
+ Fixed locale issue, bug #259384. Fixed DEPEND. Removed old revision.
02 Dec 2008; Brent Baude <ranger@gentoo.org> scim-pinyin-0.5.91-r2.ebuild:
stable ppc64, bug 245187
diff --git a/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch
new file mode 100644
index 000000000000..bc6a228fb0cc
--- /dev/null
+++ b/app-i18n/scim-pinyin/files/scim-pinyin-0.5.91-gbk.patch
@@ -0,0 +1,62 @@
+diff -Nru scim-pinyin-0.5.91.orig/src/scim_pinyin_imengine.cpp scim-pinyin-0.5.91/src/scim_pinyin_imengine.cpp
+--- scim-pinyin-0.5.91.orig/src/scim_pinyin_imengine.cpp 2005-08-06 23:31:08.000000000 +0800
++++ scim-pinyin-0.5.91/src/scim_pinyin_imengine.cpp 2009-02-18 00:06:34.000000000 +0800
+@@ -706,8 +706,12 @@
+ m_sys_phrase_lib = m_pinyin_global->get_sys_phrase_lib ();
+ m_user_phrase_lib = m_pinyin_global->get_user_phrase_lib ();
+ }
+-
+- if (encoding == "GBK" || encoding == "GB2312") {
++
++ if (encoding == "GBK") {
++ m_simplified = true;
++ m_traditional = true;
++ m_chinese_iconv.set_encoding ("GBK");
++ } else if (encoding == "GB2312") {
+ m_simplified = true;
+ m_traditional = false;
+ m_chinese_iconv.set_encoding ("GB2312");
+@@ -930,10 +934,39 @@
+
+ m_iconv.set_encoding (encoding);
+
+- if (encoding == "GBK" || encoding == "GB2312") {
+- m_simplified = true;
+- m_traditional = false;
+- m_chinese_iconv.set_encoding ("GB2312");
++ if (encoding == "GBK") {
++ if (m_simplified == false) {
++ if(m_traditional == true){
++ ; //Big5. Big5togbk is not implemented. Set to next available.
++ m_simplified = true;
++ m_chinese_iconv.set_encoding ("GBK");
++ }else{ // nochinese mode. Should not happen.
++ m_forward = true;
++ m_chinese_iconv.set_encoding ("");
++ }
++ }else{
++ if( m_traditional == false) //GB2312
++ m_chinese_iconv.set_encoding("GB2312");
++ else m_chinese_iconv.set_encoding ("GBK"); //ALL
++ }
++ } else if (encoding == "GB2312") {
++ if ( m_simplified == false ) {
++ if(m_traditional == true) {
++ ; //partly map big5 to gb2312 is not done. Set to next.
++ m_forward = true;
++ m_chinese_iconv.set_encoding ("");
++ }else{//Should not happen.
++ m_forward = true;
++ m_chinese_iconv.set_encoding("");
++ }
++ }else{
++ if (m_traditional == true) { //Should not happen.
++ m_forward = true;
++ m_chinese_iconv.set_encoding ("");
++ }else{
++ m_chinese_iconv.set_encoding ("GB2312");
++ }
++ }
+ } else if (encoding == "BIG5" || encoding == "BIG5-HKSCS") {
+ m_simplified = false;
+ m_traditional = true;
diff --git a/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r1.ebuild b/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild
index 560758f267e3..880655a29318 100644
--- a/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r1.ebuild
+++ b/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r1.ebuild,v 1.13 2007/07/22 09:25:03 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-pinyin/scim-pinyin-0.5.91-r3.ebuild,v 1.1 2009/02/24 14:49:28 matsuu Exp $
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
@@ -14,11 +14,11 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
IUSE="kde nls"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="x11-libs/libXt
|| ( >=app-i18n/scim-1.1 >=app-i18n/scim-cvs-1.1 )
- kde? ( app-i18n/skim )
+ kde? ( >=app-i18n/skim-1.2 )
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
@@ -30,6 +30,8 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-fixconfigure.patch"
epatch "${FILESDIR}/${PN}-qt335.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-gbk.patch"
AT_M4DIR=m4 AT_NO_RECURSIVE=yes eautoreconf
}
@@ -47,5 +49,5 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHROS NEWS README ChangeLog
+ dodoc AUTHORS NEWS README ChangeLog
}
diff --git a/app-i18n/scim-pinyin/scim-pinyin-0.5.91.ebuild b/app-i18n/scim-pinyin/scim-pinyin-0.5.91.ebuild
deleted file mode 100644
index 8da586ac9278..000000000000
--- a/app-i18n/scim-pinyin/scim-pinyin-0.5.91.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-pinyin/scim-pinyin-0.5.91.ebuild,v 1.10 2007/07/22 09:25:03 calchan Exp $
-
-inherit kde-functions gnome2
-
-DESCRIPTION="Smart Common Input Method (SCIM) Smart Pinyin Input Method"
-HOMEPAGE="http://www.scim-im.org/"
-SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
-
-IUSE=""
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 ~sparc x86"
-
-RDEPEND="x11-libs/libXt
- || ( >=app-i18n/scim-1.1 >=app-i18n/scim-cvs-1.1 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-SCROLLKEEPER_UPDATE="0"
-G2CONF="--disable-static --without-arts"
-DOCS="AUTHORS NEWS README ChangeLog"
-USE_DESTDIR=1
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-qt335.patch"
-}