summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-03-04 10:48:09 +0000
committerNaohiro Aota <naota@gentoo.org>2013-03-04 10:48:09 +0000
commitdb31c08d78da42987fabd50d185ba5fc067ba355 (patch)
tree503fb9eb24580c52555bc1cded62cf79f7dc3377 /app-i18n/scim-tables
parentMark arm stable. (diff)
downloadgentoo-2-db31c08d78da42987fabd50d185ba5fc067ba355.tar.gz
gentoo-2-db31c08d78da42987fabd50d185ba5fc067ba355.tar.bz2
gentoo-2-db31c08d78da42987fabd50d185ba5fc067ba355.zip
Version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/scim-tables')
-rw-r--r--app-i18n/scim-tables/ChangeLog9
-rw-r--r--app-i18n/scim-tables/scim-tables-0.5.12.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/app-i18n/scim-tables/ChangeLog b/app-i18n/scim-tables/ChangeLog
index 842bc11becb3..d22383254946 100644
--- a/app-i18n/scim-tables/ChangeLog
+++ b/app-i18n/scim-tables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-tables
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/ChangeLog,v 1.68 2012/08/14 13:51:17 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/ChangeLog,v 1.69 2013/03/04 10:48:09 naota Exp $
+
+*scim-tables-0.5.12 (04 Mar 2013)
+
+ 04 Mar 2013; Naohiro Aota <naota@gentoo.org> +scim-tables-0.5.12.ebuild:
+ Version bump
*scim-tables-0.5.11 (14 Aug 2012)
diff --git a/app-i18n/scim-tables/scim-tables-0.5.12.ebuild b/app-i18n/scim-tables/scim-tables-0.5.12.ebuild
new file mode 100644
index 000000000000..19f71a8b5419
--- /dev/null
+++ b/app-i18n/scim-tables/scim-tables-0.5.12.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tables/scim-tables-0.5.12.ebuild,v 1.1 2013/03/04 10:48:09 naota Exp $
+
+inherit autotools base eutils
+
+DESCRIPTION="Smart Common Input Method (SCIM) Generic Table Input Method Server"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+LANGS="am ar bn gu hi ja kn ko ml ne pa ru ta te th uk vi zh"
+for i in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${i}"
+done
+
+RDEPEND=">=app-i18n/scim-1.4.7-r2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.5.8+gcc-4.3.patch" )
+
+pkg_setup() {
+ elog "Not all languages are going to be compiled."
+ elog "Please set LINGUAS to your preferred language(s)."
+ elog "Supported LINGUAS values are:"
+ elog "${LANGS}"
+}
+
+src_unpack() {
+ base_src_unpack
+
+ strip-linguas ${LANGS}
+ local use_languages="additional ${LINGUAS}"
+ elog "Languages being compiled are: ${use_languages}"
+
+ cd "${S}"
+ sed -i -e "/^SUBDIRS/s/.*/SUBDIRS = ${use_languages}/g" \
+ tables/Makefile.{am,in} || die "sed ${m} failed"
+
+ AT_NO_RECURSIVE=yes AT_M4DIR=${S}/m4 eautoreconf
+}
+
+src_compile() {
+ econf \
+ --disable-skim-support \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking \
+ --without-arts || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README ChangeLog AUTHORS
+}