summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-10-02 02:12:59 +0000
committerNaohiro Aota <naota@gentoo.org>2012-10-02 02:12:59 +0000
commit42b33e717a661f528cdbe24d03125999a6265b98 (patch)
tree267a4f47d6adcef73333e885b28c28fa4b15a9f3 /app-i18n/scim-wijesekera
parentRestrict python 3.3 based on testing by Arfrever. (diff)
downloadgentoo-2-42b33e717a661f528cdbe24d03125999a6265b98.tar.gz
gentoo-2-42b33e717a661f528cdbe24d03125999a6265b98.tar.bz2
gentoo-2-42b33e717a661f528cdbe24d03125999a6265b98.zip
Force scim not to use gtk3.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim-wijesekera')
-rw-r--r--app-i18n/scim-wijesekera/ChangeLog7
-rw-r--r--app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild10
-rw-r--r--app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild10
3 files changed, 15 insertions, 12 deletions
diff --git a/app-i18n/scim-wijesekera/ChangeLog b/app-i18n/scim-wijesekera/ChangeLog
index 136f65802da4..39fa8a149cb6 100644
--- a/app-i18n/scim-wijesekera/ChangeLog
+++ b/app-i18n/scim-wijesekera/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/scim-wijesekera
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/ChangeLog,v 1.4 2012/05/03 19:24:30 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/ChangeLog,v 1.5 2012/10/02 02:12:59 naota Exp $
+
+ 02 Oct 2012; <naota@gentoo.org> scim-wijesekera-0.3.3-r1.ebuild,
+ scim-wijesekera-0.3.3.ebuild:
+ Force scim not to use gtk3.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> scim-wijesekera-0.3.3.ebuild,
scim-wijesekera-0.3.3-r1.ebuild:
@@ -22,4 +26,3 @@
02 May 2008; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+scim-wijesekera-0.3.3.ebuild:
Initial import, bug #217558.
-
diff --git a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
index f1dced6b1d83..c2a314ec75cc 100644
--- a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
+++ b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild,v 1.2 2012/05/03 19:24:30 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild,v 1.3 2012/10/02 02:12:59 naota Exp $
+
+EAPI=2
inherit autotools eutils
@@ -13,13 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=app-i18n/scim-0.99.8"
+RDEPEND=">=app-i18n/scim-0.99.8[-gtk3]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}/${P}-gcc43.patch"
eautoreconf
}
diff --git a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild
index c85e74d92368..443b64cce700 100644
--- a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild
+++ b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild,v 1.3 2012/05/03 19:24:30 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3.ebuild,v 1.4 2012/10/02 02:12:59 naota Exp $
+
+EAPI=2
inherit autotools
@@ -13,13 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=app-i18n/scim-0.99.8"
+RDEPEND=">=app-i18n/scim-0.99.8[-gtk3]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
eautoreconf
}