summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-08 17:57:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-08 17:57:59 +0000
commit13caa1662b479c4f540822729112fa6d2ad318d3 (patch)
tree219c237d34a164466de9d06ed3c312ed95270612 /app-i18n
parent*** empty log message *** (diff)
downloadgentoo-2-13caa1662b479c4f540822729112fa6d2ad318d3.tar.gz
gentoo-2-13caa1662b479c4f540822729112fa6d2ad318d3.tar.bz2
gentoo-2-13caa1662b479c4f540822729112fa6d2ad318d3.zip
*** empty log message ***
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/aspell-de/aspell-de-20001109.ebuild41
-rw-r--r--app-i18n/aspell-de/files/digest-aspell-de-200011091
-rw-r--r--app-i18n/ispell-de/files/digest-ispell-de-200011091
-rw-r--r--app-i18n/ispell-de/ispell-de-20001109.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/app-i18n/aspell-de/aspell-de-20001109.ebuild b/app-i18n/aspell-de/aspell-de-20001109.ebuild
new file mode 100644
index 000000000000..50658043f73b
--- /dev/null
+++ b/app-i18n/aspell-de/aspell-de-20001109.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/aspell-de/aspell-de-20001109.ebuild,v 1.1 2001/02/08 17:55:02 achim Exp $
+
+P=igerman98-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="A german dictionary for ispell"
+SRC_URI="http://www.suse.de/~bjacke/igerman98/dict/${P}.tar.bz2"
+HOMEPAGE="http://www.suse.de/~bjacke/igerman98/"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:^ASPELL.*:ASPELL = aspell --data-dir=./aspell:" \
+ Makefile.orig > Makefile
+ ln -s /usr/share/aspell/iso8859-1.dat aspell
+}
+
+src_compile() {
+
+ try make aspell
+
+}
+
+src_install () {
+
+ dodir /usr/share/pspell
+ echo "/usr/lib/aspell/german" > ${D}/usr/share/pspell/de-aspell.pwli
+
+ insinto /usr/share/aspell
+ doins aspell/german*.dat
+ insinto /usr/lib/aspell
+ doins german
+
+ dodoc Documentation/*
+
+}
+
diff --git a/app-i18n/aspell-de/files/digest-aspell-de-20001109 b/app-i18n/aspell-de/files/digest-aspell-de-20001109
new file mode 100644
index 000000000000..7ca102bad451
--- /dev/null
+++ b/app-i18n/aspell-de/files/digest-aspell-de-20001109
@@ -0,0 +1 @@
+MD5 ec06d69a4b045b738788fd3359de37ee igerman98-20001109.tar.bz2
diff --git a/app-i18n/ispell-de/files/digest-ispell-de-20001109 b/app-i18n/ispell-de/files/digest-ispell-de-20001109
new file mode 100644
index 000000000000..7ca102bad451
--- /dev/null
+++ b/app-i18n/ispell-de/files/digest-ispell-de-20001109
@@ -0,0 +1 @@
+MD5 ec06d69a4b045b738788fd3359de37ee igerman98-20001109.tar.bz2
diff --git a/app-i18n/ispell-de/ispell-de-20001109.ebuild b/app-i18n/ispell-de/ispell-de-20001109.ebuild
new file mode 100644
index 000000000000..bed5a38c3808
--- /dev/null
+++ b/app-i18n/ispell-de/ispell-de-20001109.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ispell-de/ispell-de-20001109.ebuild,v 1.1 2001/02/08 17:55:02 achim Exp $
+
+P=igerman98-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="A german dictionary for ispell"
+SRC_URI="http://www.suse.de/~bjacke/igerman98/dict/${P}.tar.bz2"
+HOMEPAGE="http://www.suse.de/~bjacke/igerman98/"
+
+
+src_compile() {
+
+ try make
+
+}
+
+src_install () {
+
+ insinto /usr/lib/ispell
+ doins german.aff german.hash
+
+ dodoc Documentation/*
+
+}
+