summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-25 17:10:17 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-25 17:10:17 +0000
commit25d4634dba9ef3121d71c4460e6971683464fcbc (patch)
tree81f53088b2f1c3f68a230bb751ac35ce02ad78ed /app-i18n
parentFix bug #257963 and #260247 (diff)
downloadgentoo-2-25d4634dba9ef3121d71c4460e6971683464fcbc.tar.gz
gentoo-2-25d4634dba9ef3121d71c4460e6971683464fcbc.tar.bz2
gentoo-2-25d4634dba9ef3121d71c4460e6971683464fcbc.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-table/ChangeLog8
-rw-r--r--app-i18n/ibus-table/ibus-table-1.1.0.20090220.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/app-i18n/ibus-table/ChangeLog b/app-i18n/ibus-table/ChangeLog
index 6c5fbd915cbf..c31586ae2d64 100644
--- a/app-i18n/ibus-table/ChangeLog
+++ b/app-i18n/ibus-table/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-table
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.6 2009/02/05 16:05:32 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ChangeLog,v 1.7 2009/02/25 17:10:17 matsuu Exp $
+
+*ibus-table-1.1.0.20090220 (25 Feb 2009)
+
+ 25 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-table-1.1.0.20090220.ebuild:
+ Version bumped.
05 Feb 2009; MATSUU Takuto <matsuu@gentoo.org>
-ibus-table-0.1.1.20081115.ebuild, ibus-table-0.1.2.20090104.ebuild:
diff --git a/app-i18n/ibus-table/ibus-table-1.1.0.20090220.ebuild b/app-i18n/ibus-table/ibus-table-1.1.0.20090220.ebuild
new file mode 100644
index 000000000000..012b1151f029
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.1.0.20090220.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-table/ibus-table-1.1.0.20090220.ebuild,v 1.1 2009/02/25 17:10:17 matsuu Exp $
+
+EAPI="2"
+inherit eutils python
+
+DESCRIPTION="The Table Engine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal nls"
+
+RDEPEND=">=app-i18n/ibus-1.1
+ >=dev-lang/python-2.5[sqlite]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable !minimal additional) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}