summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 15:39:31 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 15:39:31 +0000
commit32d5ae75ce6062a5a8b25792c472e462b5074472 (patch)
treed939344ebbd61f6dce75c2d6c43d9377346ff861 /app-i18n
parentadded support for econf/emake, check the changelog (diff)
downloadgentoo-2-32d5ae75ce6062a5a8b25792c472e462b5074472.tar.gz
gentoo-2-32d5ae75ce6062a5a8b25792c472e462b5074472.tar.bz2
gentoo-2-32d5ae75ce6062a5a8b25792c472e462b5074472.zip
need eutils for epatch
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/canna/canna-3.5_beta2-r2.ebuild22
-rw-r--r--app-i18n/canna/canna-3.6-r1.ebuild22
-rw-r--r--app-i18n/canna/canna-3.6.ebuild22
-rw-r--r--app-i18n/canna/canna-3.6_p3-r1.ebuild15
-rw-r--r--app-i18n/canna/canna-3.6_p3-r2.ebuild15
-rw-r--r--app-i18n/canna/canna-3.6_p3.ebuild16
-rw-r--r--app-i18n/multiskkserv/multiskkserv-20020201.ebuild11
-rw-r--r--app-i18n/scim/scim-0.4.1.ebuild11
-rw-r--r--app-i18n/scim/scim-0.5.1.ebuild10
-rw-r--r--app-i18n/skkserv/skkserv-9.6-r1.ebuild26
-rw-r--r--app-i18n/skkserv/skkserv-9.6-r2.ebuild24
-rw-r--r--app-i18n/skkserv/skkserv-9.6.ebuild26
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4-r1.ebuild15
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4-r2.ebuild14
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4.ebuild24
15 files changed, 128 insertions, 145 deletions
diff --git a/app-i18n/canna/canna-3.5_beta2-r2.ebuild b/app-i18n/canna/canna-3.5_beta2-r2.ebuild
index 1e239bdbbf4d..db84d09f92d1 100644
--- a/app-i18n/canna/canna-3.5_beta2-r2.ebuild
+++ b/app-i18n/canna/canna-3.5_beta2-r2.ebuild
@@ -1,34 +1,31 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.5_beta2-r2.ebuild,v 1.4 2003/02/13 08:00:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.5_beta2-r2.ebuild,v 1.5 2003/08/05 15:39:29 vapier Exp $
-KEYWORDS="x86"
+inherit eutils
DESCRIPTION="A client-server based Kana-Kanji conversion system"
HOMEPAGE="http://www.nec.co.jp/canna/"
-LICENSE="as-is"
-
-S="${WORKDIR}/Canna35b2"
-
SRC_URI="ftp://ftp.tokyonet.ad.jp/pub/misc/Canna/Canna35/Canna35b2.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+
RDEPEND="virtual/glibc"
-DEPEND="${RDEPEND}"
-SLOT=0
+S="${WORKDIR}/Canna35b2"
src_unpack() {
-
# unpack the archive
unpack ${A}
# patch Canna.conf to ensure that files are installed into image dir
cd Canna35b2
- patch -p0 < ${FILESDIR}/${PF}/gentoo.diff || die
+ epatch ${FILESDIR}/${PF}/gentoo.diff
}
src_compile() {
-
# create a Makefile from Canna.conf
xmkmf || die "xmkmf failed"
make Makefile || die "Makefile creation failed"
@@ -37,8 +34,7 @@ src_compile() {
make canna || die "Canna build failed"
}
-src_install () {
-
+src_install() {
# install libs, executables, dictionaries
make DESTDIR=${D} install || die "installation failed"
diff --git a/app-i18n/canna/canna-3.6-r1.ebuild b/app-i18n/canna/canna-3.6-r1.ebuild
index d7d96184b7a0..54ae9b48f3e4 100644
--- a/app-i18n/canna/canna-3.6-r1.ebuild
+++ b/app-i18n/canna/canna-3.6-r1.ebuild
@@ -1,36 +1,37 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6-r1.ebuild,v 1.7 2003/02/13 08:00:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6-r1.ebuild,v 1.8 2003/08/05 15:39:29 vapier Exp $
+
+inherit eutils
MY_P="Canna36p1"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
HOMEPAGE="http://canna.sourceforge.jp/"
-KEYWORDS="x86 ~ppc sparc ~alpha"
+SRC_URI="http://downloads.sourceforge.jp/canna/1722/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-IUSE=""
-SRC_URI="http://downloads.sourceforge.jp/canna/1722/${MY_P}.tar.gz"
+KEYWORDS="x86 ~ppc sparc ~alpha"
+
DEPEND="virtual/glibc"
-src_unpack() {
+S="${WORKDIR}/${MY_P}"
+src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
}
src_compile() {
-
xmkmf || die
make Makefiles || die
# make includes
make canna || die
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
@@ -38,4 +39,3 @@ src_install () {
insinto /etc/conf.d ; newins ${FILESDIR}/canna.confd canna || die
touch ${D}/var/log/canna/.keep || die
}
-
diff --git a/app-i18n/canna/canna-3.6.ebuild b/app-i18n/canna/canna-3.6.ebuild
index f456068e1a48..0cbc45bf545b 100644
--- a/app-i18n/canna/canna-3.6.ebuild
+++ b/app-i18n/canna/canna-3.6.ebuild
@@ -1,40 +1,40 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6.ebuild,v 1.6 2003/02/13 08:00:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6.ebuild,v 1.7 2003/08/05 15:39:29 vapier Exp $
+
+inherit eutils
MY_P="Canna36"
-S=${WORKDIR}/${MY_P}
DESCRIPTION="A client-server based Kana-Kanji conversion system"
HOMEPAGE="http://canna.sourceforge.jp/"
-KEYWORDS="x86 ~ppc sparc ~alpha"
+SRC_URI="http://downloads.sourceforge.jp/canna/1425/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-IUSE=""
-SRC_URI="http://downloads.sourceforge.jp/canna/1425/${MY_P}.tar.gz"
+KEYWORDS="x86 ~ppc sparc ~alpha"
+
DEPEND="virtual/glibc"
-src_unpack() {
+S=${WORKDIR}/${MY_P}
+src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
}
src_compile() {
-
xmkmf || die
make Makefiles || die
# make includes
make canna || die
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
exeinto /etc/init.d ; newexe ${FILESDIR}/canna.initd canna || die
insinto /etc/conf.d ; newins ${FILESDIR}/canna.confd canna || die
}
-
diff --git a/app-i18n/canna/canna-3.6_p3-r1.ebuild b/app-i18n/canna/canna-3.6_p3-r1.ebuild
index 889c9d4a2e8e..f4a85e2e7aa5 100644
--- a/app-i18n/canna/canna-3.6_p3-r1.ebuild
+++ b/app-i18n/canna/canna-3.6_p3-r1.ebuild
@@ -1,22 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3-r1.ebuild,v 1.2 2003/05/19 22:11:54 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3-r1.ebuild,v 1.3 2003/08/05 15:39:29 vapier Exp $
+
+inherit eutils
MY_P="Canna36p3"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
HOMEPAGE="http://canna.sourceforge.jp/"
-KEYWORDS="x86 ppc sparc alpha"
+SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-IUSE=""
-SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+KEYWORDS="x86 ppc sparc alpha"
DEPEND="virtual/glibc
x11-base/xfree"
RDEPEND="virtual/glibc"
+S="${WORKDIR}/${MY_P}"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -30,7 +33,7 @@ src_compile() {
make canna || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
diff --git a/app-i18n/canna/canna-3.6_p3-r2.ebuild b/app-i18n/canna/canna-3.6_p3-r2.ebuild
index d52ad47acf7b..8f0523128596 100644
--- a/app-i18n/canna/canna-3.6_p3-r2.ebuild
+++ b/app-i18n/canna/canna-3.6_p3-r2.ebuild
@@ -1,23 +1,26 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3-r2.ebuild,v 1.3 2003/06/10 13:25:27 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3-r2.ebuild,v 1.4 2003/08/05 15:39:29 vapier Exp $
+
+inherit eutils
MY_P="Canna36p3"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
HOMEPAGE="http://canna.sourceforge.jp/"
-KEYWORDS="x86 ppc sparc alpha"
+SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-IUSE=""
-SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+KEYWORDS="x86 ppc sparc alpha"
DEPEND="virtual/glibc
x11-base/xfree
>=sys-apps/sed-4"
RDEPEND="virtual/glibc"
+S="${WORKDIR}/${MY_P}"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -32,7 +35,7 @@ src_compile() {
make canna || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodir /usr/share/man/man8 /usr/share/man/ja/man8
diff --git a/app-i18n/canna/canna-3.6_p3.ebuild b/app-i18n/canna/canna-3.6_p3.ebuild
index 88460a4b62e5..ebdef3ced311 100644
--- a/app-i18n/canna/canna-3.6_p3.ebuild
+++ b/app-i18n/canna/canna-3.6_p3.ebuild
@@ -1,22 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3.ebuild,v 1.2 2003/06/29 22:12:03 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p3.ebuild,v 1.3 2003/08/05 15:39:29 vapier Exp $
+
+inherit eutils
MY_P="Canna36p3"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
HOMEPAGE="http://canna.sourceforge.jp/"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
+SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-IUSE=""
-SRC_URI="http://downloads.sourceforge.jp/canna/2181/${MY_P}.tar.gz"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
DEPEND="virtual/glibc
x11-base/xfree"
RDEPEND="virtual/glibc"
+S="${WORKDIR}/${MY_P}"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -30,7 +33,7 @@ src_compile() {
make canna || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
make DESTDIR=${D} install.man || die
dodoc CHANGES.jp ChangeLog INSTALL* README* WHATIS*
@@ -38,4 +41,3 @@ src_install () {
insinto /etc/conf.d ; newins ${FILESDIR}/canna.confd canna || die
touch ${D}/var/log/canna/.keep || die
}
-
diff --git a/app-i18n/multiskkserv/multiskkserv-20020201.ebuild b/app-i18n/multiskkserv/multiskkserv-20020201.ebuild
index 3a0508cb763a..d38715544c8e 100644
--- a/app-i18n/multiskkserv/multiskkserv-20020201.ebuild
+++ b/app-i18n/multiskkserv/multiskkserv-20020201.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/multiskkserv/multiskkserv-20020201.ebuild,v 1.2 2003/08/05 09:39:07 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/multiskkserv/multiskkserv-20020201.ebuild,v 1.3 2003/08/05 15:39:29 vapier Exp $
-IUSE=""
+inherit eutils
CDB_PV=0.75
CDB_PN=cdb
@@ -21,16 +21,12 @@ DEPEND="virtual/glibc
app-i18n/skk-jisyo-cdb"
PROVIDE="virtual/skkserv"
-S=${WORKDIR}/${P}
-
pkg_setup() {
-
einfo "If you want to add some extra SKK dictionaries,"
einfo "please emerge app-i18n/skk-jisyo-extra first."
}
src_unpack() {
-
unpack ${A}
cd ${WORKDIR}/${CDB_P}
@@ -40,7 +36,6 @@ src_unpack() {
}
src_compile() {
-
cd ${WORKDIR}/${CDB_P}
make || die
cd -
@@ -57,7 +52,6 @@ src_compile() {
}
src_install() {
-
einstall || die
insinto /etc/conf.d
@@ -70,7 +64,6 @@ src_install() {
}
pkg_postinst() {
-
einfo "By default, multiskkserv will look up only SKK-JISYO.L."
einfo "If you want to use more dictionaries,"
einfo "edit /etc/conf.d/multiskkserv manually."
diff --git a/app-i18n/scim/scim-0.4.1.ebuild b/app-i18n/scim/scim-0.4.1.ebuild
index 5b8f4c998d27..bfbc1f7c68c7 100644
--- a/app-i18n/scim/scim-0.4.1.ebuild
+++ b/app-i18n/scim/scim-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-0.4.1.ebuild,v 1.4 2003/07/07 10:59:40 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-0.4.1.ebuild,v 1.5 2003/08/05 15:39:31 vapier Exp $
inherit gnome2
@@ -21,19 +21,14 @@ RDEPEND="virtual/x11
>=dev-libs/atk-1
>=x11-libs/pango-1
>=dev-libs/glib-2"
-
-PDEPEND=">=app-i18n/scim-tables-0.2.1"
-
DEPEND="${RDEPEND}
dev-lang/perl"
-
-
-S=${WORKDIR}/${P}
+PDEPEND=">=app-i18n/scim-tables-0.2.1"
src_compile() {
local myconf
use gnome || myconf="--disable-config-gconf"
- econf ${myconf}
+ econf ${myconf} || die
emake || "make failed"
}
diff --git a/app-i18n/scim/scim-0.5.1.ebuild b/app-i18n/scim/scim-0.5.1.ebuild
index 791821743127..d1137d3ac5f1 100644
--- a/app-i18n/scim/scim-0.5.1.ebuild
+++ b/app-i18n/scim/scim-0.5.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-0.5.1.ebuild,v 1.1 2003/07/07 10:59:40 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-0.5.1.ebuild,v 1.2 2003/08/05 15:39:31 vapier Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="Smart Common Input Method (SCIM) is a Input Method (IM) development platform"
HOMEPAGE="http://www.turbolinux.com.cn/~suzhe/scim/"
@@ -22,11 +22,9 @@ RDEPEND="virtual/x11
>=dev-libs/atk-1
>=x11-libs/pango-1
>=dev-libs/glib-2"
-
-PDEPEND=">=app-i18n/scim-tables-0.2.2"
-
DEPEND="${RDEPEND}
dev-lang/perl"
+PDEPEND=">=app-i18n/scim-tables-0.2.2"
ELTCONF="--reverse-deps"
G2CONF="${G2CONF} `use_enable gnome config-gconf`"
@@ -48,5 +46,3 @@ src_install() {
dodoc README AUTHORS ChangeLog docs/developers docs/scim.cfg
dohtml -r docs/html/*
}
-
-
diff --git a/app-i18n/skkserv/skkserv-9.6-r1.ebuild b/app-i18n/skkserv/skkserv-9.6-r1.ebuild
index fc8411a535aa..f1c8df363867 100644
--- a/app-i18n/skkserv/skkserv-9.6-r1.ebuild
+++ b/app-i18n/skkserv/skkserv-9.6-r1.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkserv/skkserv-9.6-r1.ebuild,v 1.2 2003/05/17 10:53:49 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkserv/skkserv-9.6-r1.ebuild,v 1.3 2003/08/05 15:39:31 vapier Exp $
-S="${WORKDIR}/skk-${PV}mu"
MY_P="skk${PV}mu"
+DESCRIPTION="Dictionary server for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/"
+SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/museum/${MY_P}.tar.gz"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc ~sparc ~alpha"
-DESCRIPTION="Dictionary server for the SKK Japanese-input software"
-SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/museum/${MY_P}.tar.gz"
-HOMEPAGE="http://openlab.ring.gr.jp/skk/"
-IUSE=""
+
DEPEND="virtual/glibc
>=app-i18n/skk-jisyo-200210"
-
PROVIDE="virtual/skkserv"
+S="${WORKDIR}/skk-${PV}mu"
+
src_compile() {
./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --libexecdir=/usr/sbin || die "./configure failed"
+ --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/sbin \
+ || die "./configure failed"
cd skkserv
-
emake || die
}
-src_install () {
-
+src_install() {
cd skkserv
dosbin skkserv
diff --git a/app-i18n/skkserv/skkserv-9.6-r2.ebuild b/app-i18n/skkserv/skkserv-9.6-r2.ebuild
index 8f1540720beb..5b5c756b94d8 100644
--- a/app-i18n/skkserv/skkserv-9.6-r2.ebuild
+++ b/app-i18n/skkserv/skkserv-9.6-r2.ebuild
@@ -1,21 +1,25 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkserv/skkserv-9.6-r2.ebuild,v 1.2 2003/08/01 16:32:40 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkserv/skkserv-9.6-r2.ebuild,v 1.3 2003/08/05 15:39:31 vapier Exp $
+
+inherit eutils
-S="${WORKDIR}/skk-${PV}mu"
MY_P="skk${PV}mu"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DESCRIPTION="Dictionary server for the SKK Japanese-input software"
-SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/museum/${MY_P}.tar.gz"
HOMEPAGE="http://openlab.ring.gr.jp/skk/"
-IUSE=""
+SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/museum/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND="virtual/glibc
>=app-i18n/skk-jisyo-200210"
-
PROVIDE="virtual/skkserv"
+S="${WORKDIR}/skk-${PV}mu"
+
src_unpack(){
unpack ${A}
cd ${S}/skkserv
@@ -25,12 +29,10 @@ src_unpack(){
src_compile() {
econf --libexecdir=/usr/sbin || die "econf failed"
cd skkserv
-
emake || die
}
-src_install () {
-
+src_install() {
cd skkserv
dosbin skkserv
diff --git a/app-i18n/skkserv/skkserv-9.6.ebuild b/app-i18n/skkserv/skkserv-9.6.ebuild
index eecbd4641ef1..b363fe73a2cf 100644
--- a/app-i18n/skkserv/skkserv-9.6.ebuild
+++ b/app-i18n/skkserv/skkserv-9.6.ebuild
@@ -1,31 +1,33 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkserv/skkserv-9.6.ebuild,v 1.5 2003/02/13 08:48:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skkserv/skkserv-9.6.ebuild,v 1.6 2003/08/05 15:39:31 vapier Exp $
-S="${WORKDIR}/skk-${PV}mu"
MY_P="skk${PV}mu"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DESCRIPTION="Dictionary server for the SKK Japanese-input software"
SRC_URI="http://openlab.ring.gr.jp/skk/maintrunk/museum/${MY_P}.tar.gz"
HOMEPAGE="http://openlab.ring.gr.jp/skk/"
-IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
DEPEND="virtual/glibc
>=app-i18n/skk-jisyo-200210"
+S="${WORKDIR}/skk-${PV}mu"
+
src_compile() {
./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --libexecdir=/usr/sbin || die "./configure failed"
+ --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/sbin \
+ || die "./configure failed"
cd skkserv
-
emake || die
}
-src_install () {
-
+src_install() {
cd skkserv
dosbin skkserv
diff --git a/app-i18n/xsim/xsim-0.3.9.4-r1.ebuild b/app-i18n/xsim/xsim-0.3.9.4-r1.ebuild
index 4e3e6ac9a5c8..3ce782335706 100644
--- a/app-i18n/xsim/xsim-0.3.9.4-r1.ebuild
+++ b/app-i18n/xsim/xsim-0.3.9.4-r1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r1.ebuild,v 1.3 2003/06/29 22:12:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r1.ebuild,v 1.4 2003/08/05 15:39:31 vapier Exp $
+inherit eutils
[ -n "`use kde`" ] && inherit kde
DESCRIPTION="A simple and fast GB and BIG5 Chinese XIM server."
@@ -26,11 +27,9 @@ src_unpack() {
cd ${S}
einfo "Patching ./configure to respect CFLAGS .."
sed -i -e "s/\(CFLAGS.*\)-O2/\1${CFLAGS}/" configure
-
}
src_compile() {
-
local myconf
myconf="${myconf} --with-bdb-includes=/usr/include/db3 --with-bdb-libs=/usr/lib"
@@ -42,12 +41,12 @@ src_compile() {
emake xsim_etcp=/etc || die "make failed"
}
-src_install () {
+src_install() {
einstall xsim_datp=${D}/usr/lib/xsim/dat \
- xsim_libp=${D}/usr/lib/xsim/plugins \
- xsim_binp=${D}/usr/bin \
- xsim_etcp=${D}/etc \
- install-data install || die "install failed"
+ xsim_libp=${D}/usr/lib/xsim/plugins \
+ xsim_binp=${D}/usr/bin \
+ xsim_etcp=${D}/etc \
+ install-data install || die "install failed"
sed -i -e "s#DICT_LOCAL\(.*\)/usr/dat#DICT_LOCAL\1/usr/lib/xsim/dat#" \
-e "s#PLUGIN_LOCAL\(.*\)/usr/plugins#PLUGIN_LOCAL\1/usr/lib/xsim/plugins#" \
diff --git a/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild b/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild
index d15ddc825fac..cea94e9fd4ee 100644
--- a/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild
+++ b/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild,v 1.1 2003/06/27 09:44:58 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r2.ebuild,v 1.2 2003/08/05 15:39:31 vapier Exp $
[ -n "`use kde`" ] && inherit kde
@@ -24,11 +24,9 @@ src_unpack() {
cd ${S}
einfo "Patching ./configure to respect CFLAGS .."
sed -i -e "s/\(CFLAGS.*\)-O2/\1${CFLAGS}/" configure
-
}
src_compile() {
-
local myconf
use kde \
@@ -38,12 +36,12 @@ src_compile() {
emake xsim_etcp=/etc || die "make failed"
}
-src_install () {
+src_install() {
einstall xsim_datp=${D}/usr/lib/xsim/dat \
- xsim_libp=${D}/usr/lib/xsim/plugins \
- xsim_binp=${D}/usr/bin \
- xsim_etcp=${D}/etc \
- install-data install || die "install failed"
+ xsim_libp=${D}/usr/lib/xsim/plugins \
+ xsim_binp=${D}/usr/bin \
+ xsim_etcp=${D}/etc \
+ install-data install || die "install failed"
sed -i -e "s#DICT_LOCAL\(.*\)/usr/dat#DICT_LOCAL\1/usr/lib/xsim/dat#" \
-e "s#PLUGIN_LOCAL\(.*\)/usr/plugins#PLUGIN_LOCAL\1/usr/lib/xsim/plugins#" \
diff --git a/app-i18n/xsim/xsim-0.3.9.4.ebuild b/app-i18n/xsim/xsim-0.3.9.4.ebuild
index c1031feed4ee..44f35d4c1290 100644
--- a/app-i18n/xsim/xsim-0.3.9.4.ebuild
+++ b/app-i18n/xsim/xsim-0.3.9.4.ebuild
@@ -1,22 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4.ebuild,v 1.3 2003/06/29 22:12:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4.ebuild,v 1.4 2003/08/05 15:39:31 vapier Exp $
-KEYWORDS="x86"
DESCRIPTION="A simple and fast GBK Chinese XIM server."
HOMEPAGE="http://developer.berlios.de/projects/xsim/"
SRC_URI="http://download.berlios.de/xsim/${P}.tar.gz"
LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
DEPEND="virtual/glibc
>=sys-libs/db-3.0.0"
-IUSE=""
-
-SLOT="0"
src_compile() {
-
cd ${S}
for file in `find . -iname Makefile.in`
do
@@ -25,9 +22,9 @@ src_compile() {
done
./configure \
- --prefix=/usr/lib/xsim \
- --mandir=/usr/share/man \
- || die
+ --prefix=/usr/lib/xsim \
+ --mandir=/usr/share/man \
+ || die
for file in `find . -iname Makefile`
do
@@ -40,14 +37,11 @@ src_compile() {
make || die
}
-src_install () {
- make DESTDIR=${D} \
- install || die
- make DESTDIR=${D} \
- install-data || die
+src_install() {
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-data || die
dodir /usr/bin
dosym /usr/lib/xsim/bin/xsim /usr/bin/xsim
# install docs
dodoc ChangeLog COPYING INSTALL README* TODO
}
-