summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-11-07 07:07:25 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-11-07 07:07:25 +0000
commit3f19b229f16a004683a3f6dd0fccb88f8d0fcbca (patch)
tree2a2a854450bf501f1020ab418342cbb71e1e5b05 /app-i18n
parentFixed japanese patch, bug #290103. (diff)
downloadgentoo-2-3f19b229f16a004683a3f6dd0fccb88f8d0fcbca.tar.gz
gentoo-2-3f19b229f16a004683a3f6dd0fccb88f8d0fcbca.tar.bz2
gentoo-2-3f19b229f16a004683a3f6dd0fccb88f8d0fcbca.zip
Version bumped. Removed xft USE flag, Fixed --as-need issue, bug #276302.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx/ChangeLog11
-rw-r--r--app-i18n/fcitx/fcitx-3.6.2.ebuild57
2 files changed, 65 insertions, 3 deletions
diff --git a/app-i18n/fcitx/ChangeLog b/app-i18n/fcitx/ChangeLog
index 61415bc4fcc7..832b5be1b00d 100644
--- a/app-i18n/fcitx/ChangeLog
+++ b/app-i18n/fcitx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/fcitx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.26 2009/09/16 17:36:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/ChangeLog,v 1.27 2009/11/07 07:07:25 matsuu Exp $
+
+*fcitx-3.6.2 (07 Nov 2009)
+
+ 07 Nov 2009; MATSUU Takuto <matsuu@gentoo.org> +fcitx-3.6.2.ebuild:
+ Version bumped. Removed xft USE flag. Fixed --as-need issue, bug #276302.
*fcitx-3.6.1 (16 Sep 2009)
@@ -25,7 +30,7 @@
fcitx-3.4.2.ebuild, fcitx-3.5_pre070703.ebuild, +fcitx-3.5.ebuild:
Version bumped. Fxied HOMEPAGE and SRC_URI, bug #196078.
- 07 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ 07 Jun 2008; Diego Petten嘆 <flameeyes@gentoo.org>
+files/fcitx-3.5_pre070703-asneeded.patch, fcitx-3.5_pre070703.ebuild:
Add patch to fix building with --as-needed, closes bug #225211. Thanks to
Hong Hao for reporting.
@@ -50,7 +55,7 @@
+fcitx-3.5_pre070403.ebuild:
Version bumped, bug #168303.
- 05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> fcitx-3.1.1.ebuild,
+ 05 Jan 2007; Diego Petten嘆 <flameeyes@gentoo.org> fcitx-3.1.1.ebuild,
fcitx-3.2.1.ebuild, fcitx-3.4.ebuild:
Convert to use elog.
diff --git a/app-i18n/fcitx/fcitx-3.6.2.ebuild b/app-i18n/fcitx/fcitx-3.6.2.ebuild
new file mode 100644
index 000000000000..61e8d5740305
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-3.6.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx/fcitx-3.6.2.ebuild,v 1.1 2009/11/07 07:07:25 matsuu Exp $
+
+EAPI=2
+
+inherit flag-o-matic
+
+DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
+HOMEPAGE="http://www.fcitx.org/"
+SRC_URI="http://www.fcitx.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ append-ldflags $(no-as-needed)
+
+ # --disable-xft doesn't work
+ # econf $(use_enable xft) || die
+ econf || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO || die
+
+ rm -rf "${D}"/usr/share/fcitx/doc/ || die
+ dodoc doc/pinyin.txt doc/cjkvinput.txt || die
+ dohtml doc/wb_fh.htm || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You should export the following variables to use fcitx"
+ elog " export XMODIFIERS=\"@im=fcitx\""
+ elog " export XIM=fcitx"
+ elog " export XIM_PROGRAM=fcitx"
+ elog
+ elog "If you want to use WuBi ,ErBi or something else."
+ elog " mkdir -p ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/wbx.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/erbi.mb ~/.fcitx"
+ elog " cp /usr/share/fcitx/data/tables.conf ~/.fcitx"
+ elog
+}