summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-03-08 04:37:28 +0000
committerPeter Johanson <latexer@gentoo.org>2004-03-08 04:37:28 +0000
commite96ddfe1f75575008594c11f36e8e9f87466241f (patch)
tree403c491c325bc39521c135a2eda413d2a1e955f6 /app-laptop/thinkpad/thinkpad-4.1.ebuild
parentChanged mips back to ~mips in KEYWORDS. (diff)
downloadgentoo-2-e96ddfe1f75575008594c11f36e8e9f87466241f.tar.gz
gentoo-2-e96ddfe1f75575008594c11f36e8e9f87466241f.tar.bz2
gentoo-2-e96ddfe1f75575008594c11f36e8e9f87466241f.zip
Moved to app-laptop from sys-apps
Diffstat (limited to 'app-laptop/thinkpad/thinkpad-4.1.ebuild')
-rw-r--r--app-laptop/thinkpad/thinkpad-4.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-laptop/thinkpad/thinkpad-4.1.ebuild b/app-laptop/thinkpad/thinkpad-4.1.ebuild
new file mode 100644
index 000000000000..a8dd5dc08119
--- /dev/null
+++ b/app-laptop/thinkpad/thinkpad-4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-4.1.ebuild,v 1.1 2004/03/08 04:37:27 latexer Exp $
+
+#transform P to match tarball versioning
+MYPV=${PV/_beta/beta}
+MYP="${PN}_${MYPV}"
+DESCRIPTION="Thinkpad system control kernel modules"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
+KEYWORDS="x86 amd64 -ppc -mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+
+ # These instructions come from the webpage and make it compile
+ # on Linux 2.4
+ mkdir 2.5
+ mv drivers include 2.5
+ ln -s 2.4/drivers drivers
+ ln -s 2.4/include include
+}
+
+src_compile() {
+ check_KV
+ emake DIR_MOD_VER=/lib/modules/${KV} || die "Make failed"
+}
+
+src_install() {
+ dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
+ dodir /lib/modules/${KV}/thinkpad
+ cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
+ ${D}/lib/modules/${KV}/thinkpad
+ dodir /etc/modules.d
+ sed 's/%KV%/'${KV}'/g' ${FILESDIR}/thinkpad > ${D}/etc/modules.d/thinkpad
+ (cat /etc/devfsd.conf; echo; echo '# Thinkpad config';
+ echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664') \
+ > ${D}/etc/devfsd.conf
+}
+
+pkg_postinst() {
+ /usr/sbin/update-modules || return 0
+}
+
+pkg_prerm() {
+ /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
+}