summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-11-24 16:03:03 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-11-24 16:03:03 +0000
commit1755dc8d75cf8afc7e9561b7b3d614571207949e (patch)
tree16964c3446c1545452068682d789dc959b183fdb /app-laptop
parentversion bump (#68206) (Manifest recommit) (diff)
downloadgentoo-2-1755dc8d75cf8afc7e9561b7b3d614571207949e.tar.gz
gentoo-2-1755dc8d75cf8afc7e9561b7b3d614571207949e.tar.bz2
gentoo-2-1755dc8d75cf8afc7e9561b7b3d614571207949e.zip
Initial import of app-laptop/smcinit, version 0.4, an app to initialize a SMC-IRCC based IrDA subsystem on laptops where the bios does not handle that automatically
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/smcinit/ChangeLog8
-rw-r--r--app-laptop/smcinit/Manifest4
-rw-r--r--app-laptop/smcinit/files/digest-smcinit-0.41
-rw-r--r--app-laptop/smcinit/files/smcinit.conf7
-rwxr-xr-xapp-laptop/smcinit/files/smcinit.initscript33
-rw-r--r--app-laptop/smcinit/metadata.xml9
-rw-r--r--app-laptop/smcinit/smcinit-0.4.ebuild44
7 files changed, 106 insertions, 0 deletions
diff --git a/app-laptop/smcinit/ChangeLog b/app-laptop/smcinit/ChangeLog
new file mode 100644
index 000000000000..fc935a8adbeb
--- /dev/null
+++ b/app-laptop/smcinit/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-laptop/smcinit
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/ChangeLog,v 1.1 2004/11/24 16:03:03 s4t4n Exp $
+
+*smcinit-0.4 (24 Nov 2004)
+
+ 24 Nov 2004; Michele Noberasco <s4t4n@gentoo.org> smcinit-0.4.ebuild:
+ Initial import. Closes #39746.
diff --git a/app-laptop/smcinit/Manifest b/app-laptop/smcinit/Manifest
new file mode 100644
index 000000000000..2f40feb6be6e
--- /dev/null
+++ b/app-laptop/smcinit/Manifest
@@ -0,0 +1,4 @@
+MD5 253d4744d605fef7020673ef6fbc39e1 smcinit-0.4.ebuild 1049
+MD5 3254e176790847fc2528b4713e625a82 files/smcinit.conf 192
+MD5 6f2bd91d9c66df88ad391ad1ca4639b9 files/smcinit.initscript 589
+MD5 1072e90faa308622db9c695519cf5e9e files/digest-smcinit-0.4 64
diff --git a/app-laptop/smcinit/files/digest-smcinit-0.4 b/app-laptop/smcinit/files/digest-smcinit-0.4
new file mode 100644
index 000000000000..9f224b041d86
--- /dev/null
+++ b/app-laptop/smcinit/files/digest-smcinit-0.4
@@ -0,0 +1 @@
+MD5 a1f1107d6bfd3a6f75c8da268e1c809e smcinit-0.4-1.tar.gz 32343
diff --git a/app-laptop/smcinit/files/smcinit.conf b/app-laptop/smcinit/files/smcinit.conf
new file mode 100644
index 000000000000..154f2d6d2857
--- /dev/null
+++ b/app-laptop/smcinit/files/smcinit.conf
@@ -0,0 +1,7 @@
+# Which SMC-IRCC initializer should we run?
+#SMCEXE=smcinit
+#SMCEXE=tosh1800-smcinit
+#SMCEXE=tosh2450-smcinit
+
+# What kernel module the initializer should be applied to?
+#SMCMODULE=smsc-ircc2
diff --git a/app-laptop/smcinit/files/smcinit.initscript b/app-laptop/smcinit/files/smcinit.initscript
new file mode 100755
index 000000000000..694a7379cb2c
--- /dev/null
+++ b/app-laptop/smcinit/files/smcinit.initscript
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/files/smcinit.initscript,v 1.1 2004/11/24 16:03:03 s4t4n Exp $
+
+depend() {
+ before irda
+}
+
+checkconfig() {
+ if [ -z "$SMCEXE" ] || [ -z "$SMCMODULE" ] ; then
+ eerror "You need to setup SMCEXE and SMCMODULE in /etc/conf.d/smcinit first"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Running ${SMCEXE}"
+ /usr/sbin/${SMCEXE}
+ eend ${?} || return 1
+
+ ebegin "Loading ${SMCMODULE}"
+ modprobe ${SMCMODULE}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Unloading ${SMCMODULE}"
+ modprobe -r ${SMCMODULE}
+ eend ${?}
+}
diff --git a/app-laptop/smcinit/metadata.xml b/app-laptop/smcinit/metadata.xml
new file mode 100644
index 000000000000..f54702d73489
--- /dev/null
+++ b/app-laptop/smcinit/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile</herd>
+<maintainer>
+ <email>s4t4n@gentoo.org</email>
+ <name>Michele Noberasco</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-laptop/smcinit/smcinit-0.4.ebuild b/app-laptop/smcinit/smcinit-0.4.ebuild
new file mode 100644
index 000000000000..162d5dddc132
--- /dev/null
+++ b/app-laptop/smcinit/smcinit-0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/smcinit/smcinit-0.4.ebuild,v 1.1 2004/11/24 16:03:03 s4t4n Exp $
+
+IUSE=""
+
+MY_PV="0.4-1"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A set of utilities to initialize a SMC-IRCC based IrDA subsystem on laptops where the BIOS does not handle it"
+HOMEPAGE="http://irda.sourceforge.net/smcinit/"
+SRC_URI="mirror://sourceforge/irda/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/pciutils-2.1.11-r1"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile()
+{
+ econf || die "Configuration failed"
+ emake CFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install()
+{
+ # First goes the software...
+ einstall PREFIX="${D}/usr" || die "Installation failed"
+
+ # ...then documentation...
+ dodoc AUTHORS CHANGELOG.Peri ChangeLog INSTALL README README.Peri README.Rob README.Tom
+ dohtml RobMiller-irda.html
+
+ # ...after that an init script...
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PN}.initscript ${PN}
+
+ # ...and finally its config file
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PN}.conf ${PN}
+}