summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-01-06 13:56:49 +0000
committerPacho Ramos <pacho@gentoo.org>2014-01-06 13:56:49 +0000
commite783e4475d25bb61ecf7297b969024618766bd2c (patch)
tree90213459776512e2824148a7fbea1dc47742b5bb /app-laptop
parentAdd ~x86-fbsd #496740 (diff)
downloadgentoo-2-e783e4475d25bb61ecf7297b969024618766bd2c.tar.gz
gentoo-2-e783e4475d25bb61ecf7297b969024618766bd2c.tar.bz2
gentoo-2-e783e4475d25bb61ecf7297b969024618766bd2c.zip
Add unit file for i8kmon (#497178)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/i8kutils/ChangeLog10
-rw-r--r--app-laptop/i8kutils/files/i8kmon.service9
-rw-r--r--app-laptop/i8kutils/i8kutils-1.33-r1.ebuild55
3 files changed, 72 insertions, 2 deletions
diff --git a/app-laptop/i8kutils/ChangeLog b/app-laptop/i8kutils/ChangeLog
index a98c0412365e..d23d0c0f7caf 100644
--- a/app-laptop/i8kutils/ChangeLog
+++ b/app-laptop/i8kutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/i8kutils
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/ChangeLog,v 1.22 2012/08/22 13:42:00 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/ChangeLog,v 1.23 2014/01/06 13:56:49 pacho Exp $
+
+*i8kutils-1.33-r1 (06 Jan 2014)
+
+ 06 Jan 2014; Pacho Ramos <pacho@gentoo.org> +files/i8kmon.service,
+ +i8kutils-1.33-r1.ebuild:
+ Add unit file for i8kmon (#497178)
22 Aug 2012; Michael Palimaka <kensington@gentoo.org> -files/i8k.init,
-i8kutils-1.25-r1.ebuild, -i8kutils-1.25.ebuild:
diff --git a/app-laptop/i8kutils/files/i8kmon.service b/app-laptop/i8kutils/files/i8kmon.service
new file mode 100644
index 000000000000..3b80f46334af
--- /dev/null
+++ b/app-laptop/i8kutils/files/i8kmon.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Dell laptop thermal monitoring
+ConditionPathExists=/proc/i8k
+
+[Service]
+ExecStart=/usr/bin/i8kmon -d
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-laptop/i8kutils/i8kutils-1.33-r1.ebuild b/app-laptop/i8kutils/i8kutils-1.33-r1.ebuild
new file mode 100644
index 000000000000..3bbbe638d7cb
--- /dev/null
+++ b/app-laptop/i8kutils/i8kutils-1.33-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/i8kutils/i8kutils-1.33-r1.ebuild,v 1.1 2014/01/06 13:56:49 pacho Exp $
+
+EAPI=4
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="Dell Inspiron and Latitude utilities"
+HOMEPAGE="http://packages.debian.org/sid/i8kutils"
+SRC_URI="mirror://debian/pool/main/i/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="examples tk"
+
+DEPEND="tk? ( dev-lang/tk )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.i8kutils )
+
+src_prepare() {
+ sed \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e 's: -g : $(LDFLAGS) :g' \
+ -i Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin i8kbuttons i8kctl
+ doman i8kbuttons.1 i8kctl.1
+ dosym /usr/bin/i8kctl /usr/bin/i8kfan
+
+ use examples && dodoc -r examples
+
+ newinitd "${FILESDIR}"/i8k.init-r1 i8k
+ newconfd "${FILESDIR}"/i8k.conf i8k
+
+ if use tk; then
+ dobin i8kmon
+ doman i8kmon.1
+ dodoc i8kmon.conf
+ systemd_dounit "${FILESDIR}"/i8kmon.service
+ else
+ cat >> "${ED}"/etc/conf.d/i8k <<- EOF
+ # i8kmon disabled because the package was installed without USE=tk
+ NOMON=1
+ EOF
+ fi
+
+}