summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-27 18:00:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-27 18:00:13 +0000
commitdb44eb79e5ff67e7d5f66bd0d17e669d5c2a7cb0 (patch)
tree9fd7eb1db7f4149c360dcb31574fe9a4e1bb72e2 /app-leechcraft/lc-liznoo
parentold (diff)
downloadgentoo-2-db44eb79e5ff67e7d5f66bd0d17e669d5c2a7cb0.tar.gz
gentoo-2-db44eb79e5ff67e7d5f66bd0d17e669d5c2a7cb0.tar.bz2
gentoo-2-db44eb79e5ff67e7d5f66bd0d17e669d5c2a7cb0.zip
Sort out UPower hibernate and suspend status.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-leechcraft/lc-liznoo')
-rw-r--r--app-leechcraft/lc-liznoo/ChangeLog6
-rw-r--r--app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild13
-rw-r--r--app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild15
-rw-r--r--app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild13
4 files changed, 36 insertions, 11 deletions
diff --git a/app-leechcraft/lc-liznoo/ChangeLog b/app-leechcraft/lc-liznoo/ChangeLog
index 78f447b03e45..ea47651bde10 100644
--- a/app-leechcraft/lc-liznoo/ChangeLog
+++ b/app-leechcraft/lc-liznoo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-leechcraft/lc-liznoo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/ChangeLog,v 1.14 2014/06/01 10:36:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/ChangeLog,v 1.15 2014/07/27 18:00:13 ssuominen Exp $
+
+ 27 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> lc-liznoo-0.6.60.ebuild,
+ lc-liznoo-0.6.65.ebuild, lc-liznoo-9999.ebuild:
+ Sort out UPower hibernate and suspend status.
01 Jun 2014; Pacho Ramos <pacho@gentoo.org> lc-liznoo-0.6.60.ebuild:
0.6.60 looks to also be compatible
diff --git a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild
index cfb22a8f53c0..10f402a4bf0c 100644
--- a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild
+++ b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild,v 1.4 2014/06/01 10:36:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.60.ebuild,v 1.5 2014/07/27 18:00:13 ssuominen Exp $
EAPI="4"
@@ -13,8 +13,15 @@ KEYWORDS="amd64 x86"
IUSE="debug"
DEPEND="~app-leechcraft/lc-core-${PV}
- || ( sys-power/upower sys-power/upower-pm-utils )
x11-libs/qwt:6
dev-qt/qtdbus:4
virtual/leechcraft-trayarea"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )"
+
+pkg_postinst() {
+ if has_version '>=sys-power/upower-0.99'; then
+ ewarn "If you need hibernate and suspend support, you need to downgrade"
+ ewarn "sys-power/upower to 0.9.23 or switch to sys-power/upower-pm-utils"
+ fi
+}
diff --git a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild
index ad0b25967502..c0cc8625a100 100644
--- a/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild
+++ b/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild,v 1.2 2014/05/31 18:48:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-0.6.65.ebuild,v 1.3 2014/07/27 18:00:13 ssuominen Exp $
EAPI="4"
@@ -9,12 +9,19 @@ inherit leechcraft
DESCRIPTION="UPower-based power manager for LeechCraft"
SLOT="0"
-KEYWORDS=" ~amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
DEPEND="~app-leechcraft/lc-core-${PV}
- || ( sys-power/upower sys-power/upower-pm-utils )
x11-libs/qwt:6
dev-qt/qtdbus:4
virtual/leechcraft-trayarea"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )"
+
+pkg_postinst() {
+ if has_version '>=sys-power/upower-0.99'; then
+ ewarn "If you need hibernate and suspend support, you need to downgrade"
+ ewarn "sys-power/upower to 0.9.23 or switch to sys-power/upower-pm-utils"
+ fi
+}
diff --git a/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild b/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
index 0cfb26ca8810..83f3be45c813 100644
--- a/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
+++ b/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild,v 1.3 2014/05/31 20:41:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-liznoo/lc-liznoo-9999.ebuild,v 1.4 2014/07/27 18:00:13 ssuominen Exp $
EAPI="4"
@@ -13,8 +13,15 @@ KEYWORDS=""
IUSE="debug"
DEPEND="~app-leechcraft/lc-core-${PV}
- || ( sys-power/upower sys-power/upower-pm-utils )
x11-libs/qwt:6
dev-qt/qtdbus:4
virtual/leechcraft-trayarea"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )"
+
+pkg_postinst() {
+ if has_version '>=sys-power/upower-0.99'; then
+ ewarn "If you need hibernate and suspend support, you need to downgrade"
+ ewarn "sys-power/upower to 0.9.23 or switch to sys-power/upower-pm-utils"
+ fi
+}