summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-08-03 18:57:35 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-08-03 18:57:35 +0000
commitef44dcde48b637e25cd0c76428bbc5ea34fc46cf (patch)
treea5e4077e97a8e8f7b719561b0b5b3b0293180317 /app-leechcraft/lc-monocle
parentBump LeechCraft to 0.6.70, thanks to 0xd34df00d. (diff)
downloadgentoo-2-ef44dcde48b637e25cd0c76428bbc5ea34fc46cf.tar.gz
gentoo-2-ef44dcde48b637e25cd0c76428bbc5ea34fc46cf.tar.bz2
gentoo-2-ef44dcde48b637e25cd0c76428bbc5ea34fc46cf.zip
Bump LeechCraft to 0.6.70, thanks to 0xd34df00d.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/ChangeLog7
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-0.6.70.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-leechcraft/lc-monocle/ChangeLog b/app-leechcraft/lc-monocle/ChangeLog
index 0efa757200f7..ae7331f76ffb 100644
--- a/app-leechcraft/lc-monocle/ChangeLog
+++ b/app-leechcraft/lc-monocle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-monocle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.14 2014/07/05 12:29:17 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/ChangeLog,v 1.15 2014/08/03 18:57:35 maksbotan Exp $
+
+*lc-monocle-0.6.70 (03 Aug 2014)
+
+ 03 Aug 2014; Maxim Koltsov <maksbotan@gentoo.org> +lc-monocle-0.6.70.ebuild:
+ Bump LeechCraft to 0.6.70, thanks to 0xd34df00d.
05 Jul 2014; Maxim Koltsov <maksbotan@gentoo.org> lc-monocle-9999.ebuild,
metadata.xml:
diff --git a/app-leechcraft/lc-monocle/lc-monocle-0.6.70.ebuild b/app-leechcraft/lc-monocle/lc-monocle-0.6.70.ebuild
new file mode 100644
index 000000000000..6b871b0f0a14
--- /dev/null
+++ b/app-leechcraft/lc-monocle/lc-monocle-0.6.70.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-monocle/lc-monocle-0.6.70.ebuild,v 1.1 2014/08/03 18:57:35 maksbotan Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Monocle, the modular document viewer for LeechCraft"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
+
+REQUIRED_USE="postscript? ( pdf )"
+
+CDEPEND="~app-leechcraft/lc-core-${PV}
+ pdf? ( app-text/poppler[qt4] )
+ djvu? ( app-text/djvu )"
+
+RDEPEND="${CDEPEND}
+ postscript? ( app-text/ghostscript-gpl )"
+
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable djvu MONOCLE_SEEN)
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_enable fb2 MONOCLE_FXB)
+ $(cmake-utils_use_enable mobi MONOCLE_DIK)
+ $(cmake-utils_use_enable pdf MONOCLE_PDF)
+ $(cmake-utils_use_enable postscript MONOCLE_POSTRUS)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}"/out/html/*
+} \ No newline at end of file