summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-12-22 18:58:31 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-12-22 18:58:31 +0000
commit27c408dc9cac01d2430583237a9a89302ce81b28 (patch)
treeddf4a38d2b39b259fa056294567ce77048f9c867 /app-misc/aldo/aldo-0.0.11.ebuild
parentKeyworded ~sparc wrt #114326 (diff)
downloadgentoo-2-27c408dc9cac01d2430583237a9a89302ce81b28.tar.gz
gentoo-2-27c408dc9cac01d2430583237a9a89302ce81b28.tar.bz2
gentoo-2-27c408dc9cac01d2430583237a9a89302ce81b28.zip
Patch to allow 0.0.11 to compile with gcc-3.4. Fixes bug 116223, thanks to Jan Hrabe <hrabe at maildot magalien dot com>. 0.7.0 version bump.
(Portage version: 2.1_pre1)
Diffstat (limited to 'app-misc/aldo/aldo-0.0.11.ebuild')
-rw-r--r--app-misc/aldo/aldo-0.0.11.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/app-misc/aldo/aldo-0.0.11.ebuild b/app-misc/aldo/aldo-0.0.11.ebuild
index c25b38bb386d..a47ba3d897f8 100644
--- a/app-misc/aldo/aldo-0.0.11.ebuild
+++ b/app-misc/aldo/aldo-0.0.11.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/aldo/aldo-0.0.11.ebuild,v 1.7 2005/01/01 14:50:30 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/aldo/aldo-0.0.11.ebuild,v 1.8 2005/12/22 18:58:31 vanquirius Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="a morse tutor"
HOMEPAGE="http://aldo.sourceforge.net/"
@@ -13,7 +15,16 @@ IUSE=""
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ # compile with gcc 3.4, bug 116223
+ epatch "${FILESDIR}"/${P}-iostream.diff
+}
+
src_compile() {
+ # use our compiler
+ export CXX="$(tc-getCXX)"
+
make libs || die
make aldo || die
}