summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-21 13:57:12 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-21 13:57:12 +0000
commit109b94973726ab443e788d353ec76b887bca225a (patch)
tree009bffd6c43c2c6e6a6a8870bc877b080088fc37 /app-misc/cdargs
parentamd64 stable wrt bug #551814 (diff)
downloadgentoo-2-109b94973726ab443e788d353ec76b887bca225a.tar.gz
gentoo-2-109b94973726ab443e788d353ec76b887bca225a.tar.bz2
gentoo-2-109b94973726ab443e788d353ec76b887bca225a.zip
Import fedora patch for format-security, bug #521078; make it compile with ncurses[tinfo]
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'app-misc/cdargs')
-rw-r--r--app-misc/cdargs/ChangeLog12
-rw-r--r--app-misc/cdargs/cdargs-1.35-r2.ebuild71
-rw-r--r--app-misc/cdargs/files/cdargs-1.35-format_security.patch100
-rw-r--r--app-misc/cdargs/files/cdargs-1.35-tinfo.patch20
4 files changed, 200 insertions, 3 deletions
diff --git a/app-misc/cdargs/ChangeLog b/app-misc/cdargs/ChangeLog
index 3fd888fc6cd9..e3b47e064852 100644
--- a/app-misc/cdargs/ChangeLog
+++ b/app-misc/cdargs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/cdargs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdargs/ChangeLog,v 1.20 2011/01/05 14:53:03 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdargs/ChangeLog,v 1.21 2015/06/21 13:57:11 jlec Exp $
+
+*cdargs-1.35-r2 (21 Jun 2015)
+
+ 21 Jun 2015; Justin Lecher <jlec@gentoo.org> +cdargs-1.35-r2.ebuild,
+ +files/cdargs-1.35-format_security.patch, +files/cdargs-1.35-tinfo.patch:
+ Import fedora patch for format-security, bug #521078; make it compile with
+ ncurses[tinfo]
05 Jan 2011; Justin Lecher <jlec@gentoo.org> cdargs-1.35-r1.ebuild:
Corrected HOMEPAGE, #350561, thanks Martin Walch digging that out
@@ -79,4 +86,3 @@
07 Jan 2005; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+cdargs-1.31.ebuild:
Initial commit - bug 76736. Thanks to Stefan Kamphausen.
-
diff --git a/app-misc/cdargs/cdargs-1.35-r2.ebuild b/app-misc/cdargs/cdargs-1.35-r2.ebuild
new file mode 100644
index 000000000000..30a6537af7f1
--- /dev/null
+++ b/app-misc/cdargs/cdargs-1.35-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdargs/cdargs-1.35-r2.ebuild,v 1.1 2015/06/21 13:57:11 jlec Exp $
+
+EAPI=5
+
+inherit autotools elisp-common eutils
+
+DESCRIPTION="Bookmarks and browser for the shell builtin cd command"
+HOMEPAGE="http://www.skamphausen.de/cgi-bin/ska/CDargs"
+SRC_URI="http://www.skamphausen.de/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="emacs"
+
+DEPEND="
+ sys-libs/ncurses
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format_security.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ )
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile contrib/cdargs.el
+}
+
+src_install() {
+ default
+
+ cd "${S}/contrib" || die
+ insinto /usr/share/cdargs
+ doins cdargs-bash.sh cdargs-tcsh.csh
+ if use emacs ; then
+ elisp-install ${PN} cdargs.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ echo
+ elog "Add the following line to your ~/.bashrc to enable cdargs helper"
+ elog "functions/aliases in your environment:"
+ elog "[ -f /usr/share/cdargs/cdargs-bash.sh ] && \\ "
+ elog " source /usr/share/cdargs/cdargs-bash.sh"
+ elog
+ elog "Users of tcshell will find cdargs-tcsh.csh there with a reduced"
+ elog "feature set. See INSTALL file in the documentation directory for"
+ elog "more information."
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-misc/cdargs/files/cdargs-1.35-format_security.patch b/app-misc/cdargs/files/cdargs-1.35-format_security.patch
new file mode 100644
index 000000000000..978a8e92c088
--- /dev/null
+++ b/app-misc/cdargs/files/cdargs-1.35-format_security.patch
@@ -0,0 +1,100 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
+<head>
+<title>cdargs.git - cdargs</title>
+<meta name='generator' content='cgit v0.10.2'/>
+<meta name='robots' content='index, nofollow'/>
+<link rel='stylesheet' type='text/css' href='/cgit-data/cgit.css'/>
+<link rel='shortcut icon' href='/favicon.ico'/>
+<link rel='alternate' title='Atom feed' href='http://pkgs.fedoraproject.org/cgit/cdargs.git/atom/cdargs-1.35_format_security.patch?h=master' type='application/atom+xml'/>
+</head>
+<body>
+<script src="https://apps.fedoraproject.org/fedmenu/js/jquery-1.11.2.min.js"></script>
+<script src="https://apps.fedoraproject.org/fedmenu/js/fedmenu.js"></script>
+
+<script>
+ var base = 'https://apps.fedoraproject.org/';
+ var tokens = window.location.href.split('/');
+ var repo = null;
+ if (tokens.length > 4 && tokens[4] != '') {
+ repo = tokens[4].split('.')[0];
+ }
+ fedmenu({
+ 'url': base + 'js/data.js',
+ 'mimeType': 'application/javascript',
+ 'position': 'bottom-right',
+ 'package': repo,
+ });
+</script>
+<div id='cgit'><table id='header'>
+<tr>
+<td class='logo' rowspan='2'><a href='/cgit/'><img src='/cgit-data/cgit.png' alt='cgit logo'/></a></td>
+<td class='main'><a href='/cgit/'>index</a> : <a title='cdargs.git' href='/cgit/cdargs.git/'>cdargs.git</a></td><td class='form'><form method='get' action=''>
+<select name='h' onchange='this.form.submit();'>
+<option value='f10'>f10</option>
+<option value='f11'>f11</option>
+<option value='f12'>f12</option>
+<option value='f13'>f13</option>
+<option value='f14'>f14</option>
+<option value='f15'>f15</option>
+<option value='f16'>f16</option>
+<option value='f17'>f17</option>
+<option value='f18'>f18</option>
+<option value='f19'>f19</option>
+<option value='f20'>f20</option>
+<option value='f21'>f21</option>
+<option value='f22'>f22</option>
+<option value='f7'>f7</option>
+<option value='f8'>f8</option>
+<option value='f9'>f9</option>
+<option value='master' selected='selected'>master</option>
+</select> <input type='submit' name='' value='switch'/></form></td></tr>
+<tr><td class='sub'>cdargs</td><td class='sub right'>Jesse Keating</td></tr></table>
+<table class='tabs'><tr><td>
+<a href='/cgit/cdargs.git/'>summary</a><a href='/cgit/cdargs.git/refs/'>refs</a><a href='/cgit/cdargs.git/log/cdargs-1.35_format_security.patch'>log</a><a class='active' href='/cgit/cdargs.git/tree/cdargs-1.35_format_security.patch'>tree</a><a href='/cgit/cdargs.git/commit/cdargs-1.35_format_security.patch'>commit</a><a href='/cgit/cdargs.git/diff/cdargs-1.35_format_security.patch'>diff</a><a href='/cgit/cdargs.git/stats/cdargs-1.35_format_security.patch'>stats</a></td><td class='form'><form class='right' method='get' action='/cgit/cdargs.git/log/cdargs-1.35_format_security.patch'>
+<select name='qt'>
+<option value='grep'>log msg</option>
+<option value='author'>author</option>
+<option value='committer'>committer</option>
+<option value='range'>range</option>
+</select>
+<input class='txt' type='text' size='10' name='q' value=''/>
+<input type='submit' value='search'/>
+</form>
+</td></tr></table>
+<div class='path'>path: <a href='/cgit/cdargs.git/tree/'>root</a>/<a href='/cgit/cdargs.git/tree/cdargs-1.35_format_security.patch'>cdargs-1.35_format_security.patch</a></div><div class='content'>blob: 3ddc550e607e9f908b891c7e3626ee256484607e (<a href='/cgit/cdargs.git/plain/cdargs-1.35_format_security.patch'>plain</a>)
+<table summary='blob content' class='blob'>
+<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
+<a id='n2' href='#n2'>2</a>
+<a id='n3' href='#n3'>3</a>
+<a id='n4' href='#n4'>4</a>
+<a id='n5' href='#n5'>5</a>
+<a id='n6' href='#n6'>6</a>
+<a id='n7' href='#n7'>7</a>
+<a id='n8' href='#n8'>8</a>
+<a id='n9' href='#n9'>9</a>
+<a id='n10' href='#n10'>10</a>
+<a id='n11' href='#n11'>11</a>
+<a id='n12' href='#n12'>12</a>
+<a id='n13' href='#n13'>13</a>
+</pre></td>
+<td class='lines'><pre><code>diff --git a/src/cdargs.cc b/src/cdargs.cc
+index e505e4e..1fdfeb8 100644
+--- a/src/cdargs.cc
++++ b/src/cdargs.cc
+@@ -1301,7 +1301,7 @@ void helpscreen(void) {
+
+ void fatal_exit(char* msg) {
+ endwin();
+- fprintf(stderr, msg);
++ fprintf(stderr, "%s", msg);
+ exit(1);
+ }
+
+</code></pre></td></tr></table>
+</div> <!-- class=content -->
+<div class='footer'>generated by cgit v0.10.2 at 2015-06-21 13:46:50 (GMT)</div>
+</div> <!-- id=cgit -->
+</body>
+</html>
diff --git a/app-misc/cdargs/files/cdargs-1.35-tinfo.patch b/app-misc/cdargs/files/cdargs-1.35-tinfo.patch
new file mode 100644
index 000000000000..d85a3b9b685c
--- /dev/null
+++ b/app-misc/cdargs/files/cdargs-1.35-tinfo.patch
@@ -0,0 +1,20 @@
+ configure.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.in b/configure.in
+index a21d664..263929e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -8,10 +8,11 @@ dnl if test "$has_curses" = "false" ; then
+ dnl AC_MSG_ERROR([Fatal error: couldn't find ncurses/curses.])
+ dnl fi
+
++PKG_CHECK_MODULES([NCURSES], [ncurses],[CURSES_LIB=${NCURSES_LIBS}],[
+ MP_WITH_CURSES
+ if test "x$CURSES_LIB" = "x" ; then
+ AC_MSG_ERROR([Fatal error: couldn't find ncurses/curses.])
+-fi
++fi])
+ AC_SUBST(CURSES_LIB)
+
+ AC_OUTPUT(Makefile contrib/Makefile doc/Makefile src/Makefile m4/Makefile cdargs.spec)