summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-01-02 12:41:34 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-01-02 12:41:34 +0000
commit20554ca82983324913106e01f5bc0903d7e09995 (patch)
tree485ad3e66a2ef182c871078dd582d07af627c028 /app-misc/crunch
parentalpha stable wrt bug #492090 (diff)
downloadgentoo-2-20554ca82983324913106e01f5bc0903d7e09995.tar.gz
gentoo-2-20554ca82983324913106e01f5bc0903d7e09995.tar.bz2
gentoo-2-20554ca82983324913106e01f5bc0903d7e09995.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-misc/crunch')
-rw-r--r--app-misc/crunch/ChangeLog9
-rw-r--r--app-misc/crunch/crunch-3.5.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/app-misc/crunch/ChangeLog b/app-misc/crunch/ChangeLog
index c9e635491fe8..3e0792b612fd 100644
--- a/app-misc/crunch/ChangeLog
+++ b/app-misc/crunch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/crunch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/ChangeLog,v 1.1 2013/11/24 12:39:18 pinkbyte Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/ChangeLog,v 1.2 2014/01/02 12:41:34 pinkbyte Exp $
+
+*crunch-3.5 (02 Jan 2014)
+
+ 02 Jan 2014; Sergey Popov <pinkbyte@gentoo.org> +crunch-3.5.ebuild:
+ Version bump
*crunch-3.4 (24 Nov 2013)
diff --git a/app-misc/crunch/crunch-3.5.ebuild b/app-misc/crunch/crunch-3.5.ebuild
new file mode 100644
index 000000000000..60c08a51c302
--- /dev/null
+++ b/app-misc/crunch/crunch-3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/crunch/crunch-3.5.ebuild,v 1.1 2014/01/02 12:41:34 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}