summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-24 04:30:55 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-24 04:30:55 +0000
commit2bbf17a2881e47d905ead19302d42f25d4ae5183 (patch)
tree544abb4c960a6795ef0458582e9f656efd76ffa3 /app-misc/evemu/evemu-2.0.0.ebuild
parentRemove obsolete lafilefixer messages (diff)
downloadgentoo-2-2bbf17a2881e47d905ead19302d42f25d4ae5183.tar.gz
gentoo-2-2bbf17a2881e47d905ead19302d42f25d4ae5183.tar.bz2
gentoo-2-2bbf17a2881e47d905ead19302d42f25d4ae5183.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/evemu/evemu-2.0.0.ebuild')
-rw-r--r--app-misc/evemu/evemu-2.0.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/evemu/evemu-2.0.0.ebuild b/app-misc/evemu/evemu-2.0.0.ebuild
new file mode 100644
index 000000000000..7727a07c70f0
--- /dev/null
+++ b/app-misc/evemu/evemu-2.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/evemu/evemu-2.0.0.ebuild,v 1.1 2014/06/24 04:30:55 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils python-single-r1
+
+DESCRIPTION="Tools and bindings for kernel input event device emulation, data capture, and replay"
+HOMEPAGE="http://www.freedesktop.org/wiki/Evemu/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/libevdev-0.5"
+DEPEND="app-arch/xz-utils
+ ${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.0-install-man.patch )
+
+src_prepare() {
+ if ! use python ; then
+ sed '/SUBDIRS/s/python//' -i Makefile.am || die
+ fi
+ autotools-utils_src_prepare
+}
+
+src_test() {
+ if use python ; then
+ if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
+ ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
+ else
+ emake check
+ fi
+ fi
+}