summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-22 11:10:12 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-22 11:10:12 +0000
commita14697bf88ebd0569a660def8e2be2df3b853e78 (patch)
tree458b0e4cd95a7a5e81f7fa4ac79e2ebe9e36c5a1 /app-misc/evemu
parentAdd unit file (#492502 by Joerg Neikes) (diff)
downloadgentoo-2-a14697bf88ebd0569a660def8e2be2df3b853e78.tar.gz
gentoo-2-a14697bf88ebd0569a660def8e2be2df3b853e78.tar.bz2
gentoo-2-a14697bf88ebd0569a660def8e2be2df3b853e78.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/evemu')
-rw-r--r--app-misc/evemu/ChangeLog7
-rw-r--r--app-misc/evemu/evemu-1.2.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/app-misc/evemu/ChangeLog b/app-misc/evemu/ChangeLog
index cca707c17083..ae8dae97fdd9 100644
--- a/app-misc/evemu/ChangeLog
+++ b/app-misc/evemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/evemu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/evemu/ChangeLog,v 1.2 2013/05/29 08:55:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/evemu/ChangeLog,v 1.3 2013/12/22 11:10:12 radhermit Exp $
+
+*evemu-1.2.0 (22 Dec 2013)
+
+ 22 Dec 2013; Tim Harder <radhermit@gentoo.org> +evemu-1.2.0.ebuild:
+ Version bump.
29 May 2013; Tim Harder <radhermit@gentoo.org> evemu-1.1.0.ebuild:
Add REQUIRED_USE for python-single-r1.
diff --git a/app-misc/evemu/evemu-1.2.0.ebuild b/app-misc/evemu/evemu-1.2.0.ebuild
new file mode 100644
index 000000000000..3a4a676607a3
--- /dev/null
+++ b/app-misc/evemu/evemu-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/evemu/evemu-1.2.0.ebuild,v 1.1 2013/12/22 11:10:12 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils python-single-r1
+
+DESCRIPTION="Tools and bindings for kernel input event device emulation, data capture, and replay"
+HOMEPAGE="http://www.freedesktop.org/wiki/Evemu/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="app-arch/xz-utils
+ ${RDEPEND}"
+
+src_prepare() {
+ if ! use python ; then
+ sed '/SUBDIRS/s/python//' -i Makefile.am || die
+ autotools-utils_src_prepare
+ fi
+}
+
+src_test() {
+ if use python ; then
+ if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
+ ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
+ else
+ emake check
+ fi
+ fi
+}