summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-05-02 21:02:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-05-02 21:02:38 +0000
commit28cb671aa51c2e5fbb0737e460312f3ae9aa5ace (patch)
treeb4b97554f48269177e8193fb16446957cc60f378 /app-misc/gnote/gnote-0.7.4.ebuild
parentRevision bump by Nathan Phillip Brink, who's the new proxied maintainer for t... (diff)
downloadgentoo-2-28cb671aa51c2e5fbb0737e460312f3ae9aa5ace.tar.gz
gentoo-2-28cb671aa51c2e5fbb0737e460312f3ae9aa5ace.tar.bz2
gentoo-2-28cb671aa51c2e5fbb0737e460312f3ae9aa5ace.zip
Version bump. Minor feature changes. Fix crashers and bugs, updated translations.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/gnote/gnote-0.7.4.ebuild')
-rw-r--r--app-misc/gnote/gnote-0.7.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/gnote/gnote-0.7.4.ebuild b/app-misc/gnote/gnote-0.7.4.ebuild
new file mode 100644
index 000000000000..bed04030d2e0
--- /dev/null
+++ b/app-misc/gnote/gnote-0.7.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.7.4.ebuild,v 1.1 2011/05/02 21:02:38 eva Exp $
+
+EAPI="3"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="applet debug" # dbus
+
+RDEPEND=">=x11-libs/gtk+-2.20:2
+ >=dev-cpp/glibmm-2.18:2
+ >=dev-cpp/gtkmm-2.12:2.4
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=gnome-base/gconf-2:2
+ >=dev-libs/libpcre-7.8:3[cxx]
+ >=app-text/gtkspell-2.0.9
+ >=dev-libs/boost-1.34
+ sys-libs/e2fsprogs-libs
+ applet? (
+ >=gnome-base/gnome-panel-2
+ <gnome-base/gnome-panel-2.91
+ >=dev-cpp/libpanelappletmm-2.26:2.6 )"
+# Build with dbus is currently not implemented
+# dbus? ( >=dev-libs/dbus-glib-0.70 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils
+ app-text/docbook-xml-dtd:4.1.2"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-dbus
+ --disable-static
+ $(use_enable applet)
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not set idiotic defines in a released tarball, bug #311979
+ sed 's/-DG.*_DISABLE_DEPRECATED//g' -i libtomboy/Makefile.am \
+ libtomboy/Makefile.in || die "sed failed"
+}