summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-27 09:03:31 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-27 09:03:31 +0000
commit92bd8ae1b80fc48a6b3bab2343d25242be64fefd (patch)
tree6f4a42a0afea571534131c25f4be3fa5326cef0d /app-misc/grc/grc-1.3-r1.ebuild
parentFix several issues with dev-haskell/gtk2hs-0.10.1, see changelog for details. (diff)
downloadgentoo-2-92bd8ae1b80fc48a6b3bab2343d25242be64fefd.tar.gz
gentoo-2-92bd8ae1b80fc48a6b3bab2343d25242be64fefd.tar.bz2
gentoo-2-92bd8ae1b80fc48a6b3bab2343d25242be64fefd.zip
Fix for new Python situation, #311525
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/grc/grc-1.3-r1.ebuild')
-rw-r--r--app-misc/grc/grc-1.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/grc/grc-1.3-r1.ebuild b/app-misc/grc/grc-1.3-r1.ebuild
new file mode 100644
index 000000000000..80ca79947884
--- /dev/null
+++ b/app-misc/grc/grc-1.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/grc/grc-1.3-r1.ebuild,v 1.1 2010/03/27 09:03:31 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit eutils python
+
+DESCRIPTION="Generic Colouriser is yet another colouriser for beautifying your logfiles or output of commands"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/grc.html"
+SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ cp -rf "${S}"{,.orig}
+ epatch "${FILESDIR}"/1.0.6-support-more-files.patch
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ insinto /usr/share/grc
+ doins conf.* "${FILESDIR}"/conf.* || die "share files"
+ insinto /etc
+ doins grc.conf || die "conf"
+ dobin grc grcat || die "dobin"
+ dodoc README INSTALL TODO CHANGES CREDITS || die
+ doman grc.1 grcat.1 || die
+}