summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-16 08:59:18 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-16 08:59:18 +0000
commit559256ebdddd0f156f4605fc2867443a93be6db6 (patch)
tree42ebf29645ba204cb8e5d459b856cabcab5274e5 /app-misc/hivex/hivex-1.3.6-r1.ebuild
parentCleanup. (diff)
downloadgentoo-2-559256ebdddd0f156f4605fc2867443a93be6db6.tar.gz
gentoo-2-559256ebdddd0f156f4605fc2867443a93be6db6.tar.bz2
gentoo-2-559256ebdddd0f156f4605fc2867443a93be6db6.zip
New revision, fixes bugs #433467 and #430168. Thanks to slepnoga
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/hivex/hivex-1.3.6-r1.ebuild')
-rw-r--r--app-misc/hivex/hivex-1.3.6-r1.ebuild104
1 files changed, 104 insertions, 0 deletions
diff --git a/app-misc/hivex/hivex-1.3.6-r1.ebuild b/app-misc/hivex/hivex-1.3.6-r1.ebuild
new file mode 100644
index 000000000000..0fbac038d33a
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.6-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.6-r1.ebuild,v 1.1 2012/09/16 08:59:18 pinkbyte Exp $
+
+EAPI=4
+
+WANT_AUTOMAKE="1.11"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+AUTOTOOLS_AUTORECONF=1
+
+USE_RUBY="ruby18"
+RUBY_OPTIONAL=yes
+PYTHON_DEPEND="python? 2:2.6"
+
+inherit autotools-utils eutils perl-app python
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline perl python test static-libs ruby"
+
+RDEPEND="virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ ruby? ( dev-ruby/rake )
+ "
+PATCHES=("${FILESDIR}"/"${PVR}"/disable_automagic_cumulative_patch.patch )
+
+DOCS=(README)
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ python_need_rebuild
+ fi
+ if use perl; then
+ perl-module_pkg_setup
+ fi
+}
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-app_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+src_test() {
+ if use perl;then
+ pushd perl
+ perl-app_src_install
+ popd
+ fi
+
+ autotools-utils_src_compile check
+}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ fixlocalpod
+ fi
+}