summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-11-06 08:13:35 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-11-06 08:13:35 +0000
commit3b7007405baea75cd299ee8e104904b310739423 (patch)
treee150f5c1dbe4a5d782deb9b3f62bf0b633dc64c3 /app-misc/hivex
parentAdd missing dev-vcs/bzr depend which is required for running awn-settings. (diff)
downloadgentoo-2-3b7007405baea75cd299ee8e104904b310739423.tar.gz
gentoo-2-3b7007405baea75cd299ee8e104904b310739423.tar.bz2
gentoo-2-3b7007405baea75cd299ee8e104904b310739423.zip
Add patch for python tests and make python_need_rebuild use-conditional. Bug #389691
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/hivex')
-rw-r--r--app-misc/hivex/ChangeLog7
-rw-r--r--app-misc/hivex/files/python-test-fix-1.3.2.patch11
-rw-r--r--app-misc/hivex/hivex-1.3.2.ebuild11
3 files changed, 24 insertions, 5 deletions
diff --git a/app-misc/hivex/ChangeLog b/app-misc/hivex/ChangeLog
index 9e37745b12a4..b30e0ef4ac44 100644
--- a/app-misc/hivex/ChangeLog
+++ b/app-misc/hivex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/hivex
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.7 2011/11/06 07:44:20 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/ChangeLog,v 1.8 2011/11/06 08:13:35 maksbotan Exp $
+
+ 06 Nov 2011; Maxim Koltsov <maksbotan@gentoo.org> hivex-1.3.2.ebuild,
+ +files/python-test-fix-1.3.2.patch:
+ Add patch for python tests and make python_need_rebuild use-conditional. Bug
+ #389691
06 Nov 2011; Maxim Koltsov <maksbotan@gentoo.org> hivex-1.3.2.ebuild:
Fix ebuild syntax, bug #389691.
diff --git a/app-misc/hivex/files/python-test-fix-1.3.2.patch b/app-misc/hivex/files/python-test-fix-1.3.2.patch
new file mode 100644
index 000000000000..0b31e216e048
--- /dev/null
+++ b/app-misc/hivex/files/python-test-fix-1.3.2.patch
@@ -0,0 +1,11 @@
+--- python/run-python-tests.in 2011-08-11 22:40:25.000000000 +0400
++++ python/run-python-tests.in 2011-11-06 11:52:14.064248069 +0400
+@@ -19,7 +19,7 @@
+ set -e
+ shopt -s nullglob
+
+-for f in $(srcdir)t/*.py; do
++for f in ${srcdir}t/*.py; do
+ basename "$f"
+ @PYTHON@ "$f"
+ done
diff --git a/app-misc/hivex/hivex-1.3.2.ebuild b/app-misc/hivex/hivex-1.3.2.ebuild
index 7986d1d129a6..a3b212b84200 100644
--- a/app-misc/hivex/hivex-1.3.2.ebuild
+++ b/app-misc/hivex/hivex-1.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2.ebuild,v 1.2 2011/11/06 07:44:20 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.2.ebuild,v 1.3 2011/11/06 08:13:35 maksbotan Exp $
EAPI=4
@@ -36,12 +36,15 @@ DEPEND="${RDEPEND}
dev-perl/Test-Pod-Coverage ) )
ruby? ( dev-ruby/rake )
"
-PATCHES=("${FILESDIR}"/autoconf_fix-${PV}.patch)
+PATCHES=("${FILESDIR}"/autoconf_fix-${PV}.patch
+"${FILESDIR}"/python-test-fix-${PV}.patch)
DOCS=(README)
pkg_config() {
- python_set_active_version 2
- python_need_rebuild
+ if use python; then
+ python_set_active_version 2
+ python_need_rebuild
+ fi
}
src_prepare() {