summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-25 17:20:02 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-25 17:20:02 +0000
commit39ea082f805aadb68b8ed62571f833b97c79dd60 (patch)
treebbda3458bf22d54feeacdc2c440c9ee82ab522cc /app-misc/jpilot
parentrepoman'd (diff)
downloadgentoo-2-39ea082f805aadb68b8ed62571f833b97c79dd60.tar.gz
gentoo-2-39ea082f805aadb68b8ed62571f833b97c79dd60.tar.bz2
gentoo-2-39ea082f805aadb68b8ed62571f833b97c79dd60.zip
repoman'd
Diffstat (limited to 'app-misc/jpilot')
-rw-r--r--app-misc/jpilot/jpilot-0.99.2-r1.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/app-misc/jpilot/jpilot-0.99.2-r1.ebuild b/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
index 9e68d1bbdde4..387de14be777 100644
--- a/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
+++ b/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.2-r1.ebuild,v 1.4 2002/07/22 17:02:52 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.2-r1.ebuild,v 1.5 2002/07/25 17:20:01 seemant Exp $
SYNCMAL="0.71"
MALSYNC="2.0.7"
S=${WORKDIR}/${P}
DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
SRC_URI="http://jpilot.org/${P}.tar.gz
-http://www.tomw.org/malsync/malsync_${MALSYNC}.src.tar.gz
-http://jasonday.home.att.net/code/syncmal/jpilot-syncmal_${SYNCMAL}.tar.gz"
+ http://www.tomw.org/malsync/malsync_${MALSYNC}.src.tar.gz
+ http://jasonday.home.att.net/code/syncmal/jpilot-syncmal_${SYNCMAL}.tar.gz"
HOMEPAGE="http://jpilot.org/"
# In order to use the malsync plugin you'll need to refer to the homepage
@@ -30,12 +30,9 @@ src_unpack() {
}
src_compile() {
+ use nls || NLS_OPTION="--disable-nls"
- if [ -z "`use nls`" ] ; then
- NLS_OPTION="--disable-nls"
- fi
-
- ./configure --prefix=/usr --host=${CHOST} ${NLS_OPTION} || die
+ econf ${NLS_OPTION} || die
# make sure we use $CFLAGS
mv Makefile Makefile.old
@@ -45,12 +42,11 @@ src_compile() {
# build malsync plugin
cd ${S}/jpilot-syncmal_${SYNCMAL}
- ./configure --prefix=/usr --host=${CHOST} || die
+ econf || die
emake || die
}
src_install() {
-
# work around for broken Makefile
dodir /usr/bin
@@ -67,6 +63,4 @@ src_install() {
newdoc jpilot-syncmal_${SYNCMAL}/README README.jpilot-syncmal
dodoc jpilot-syncmal_${SYNCMAL}/malsync/Doc/README_AvantGo
dodoc jpilot-syncmal_${SYNCMAL}/malsync/Doc/README_malsync
-
}
-