summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-17 23:06:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-17 23:06:32 +0000
commitdc5f34117b2dc0d564ffade0aaffafe6da15b456 (patch)
treeb42076fcff9ac65f945ab7458cea9d121277584c /app-misc/ledit
parentRevbump to include dragon-segfault.patch (bug #300312). (diff)
downloadgentoo-2-dc5f34117b2dc0d564ffade0aaffafe6da15b456.tar.gz
gentoo-2-dc5f34117b2dc0d564ffade0aaffafe6da15b456.tar.bz2
gentoo-2-dc5f34117b2dc0d564ffade0aaffafe6da15b456.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/ledit')
-rw-r--r--app-misc/ledit/ChangeLog9
-rw-r--r--app-misc/ledit/ledit-2.02.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-misc/ledit/ChangeLog b/app-misc/ledit/ChangeLog
index 756337710632..8e35a19d30a0 100644
--- a/app-misc/ledit/ChangeLog
+++ b/app-misc/ledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/ledit
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.29 2008/09/25 12:10:30 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ChangeLog,v 1.30 2010/11/17 23:06:32 aballier Exp $
+
+*ledit-2.02 (17 Nov 2010)
+
+ 17 Nov 2010; Alexis Ballier <aballier@gentoo.org> +ledit-2.02.ebuild:
+ version bump
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> ledit-2.01.ebuild:
keyword ~x86-fbsd
diff --git a/app-misc/ledit/ledit-2.02.ebuild b/app-misc/ledit/ledit-2.02.ebuild
new file mode 100644
index 000000000000..1c2d21db37fa
--- /dev/null
+++ b/app-misc/ledit/ledit-2.02.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.02.ebuild,v 1.1 2010/11/17 23:06:32 aballier Exp $
+
+EAPI=2
+inherit eutils
+
+RESTRICT="installsources"
+IUSE="+ocamlopt"
+
+DESCRIPTION="A line editor to be used with interactive commands."
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+DEPEND=">=dev-lang/ocaml-3.09[ocamlopt?]
+ dev-ml/camlp5"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 ledit.opt || die "make failed"
+ else
+ # If using bytecode we dont want to strip the binary as it would remove the
+ # bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ newbin ledit.opt ledit || die
+ else
+ newbin ledit.out ledit || die
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}