summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-10-14 10:16:47 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-10-14 10:16:47 +0000
commit7cc1898938ca0fed434b3fe7dc6ed5e7e9b8b260 (patch)
tree8fc924da88a59763315b675bdf10a68294926b94 /app-misc/lirc
parentinitial import (diff)
downloadgentoo-2-7cc1898938ca0fed434b3fe7dc6ed5e7e9b8b260.tar.gz
gentoo-2-7cc1898938ca0fed434b3fe7dc6ed5e7e9b8b260.tar.bz2
gentoo-2-7cc1898938ca0fed434b3fe7dc6ed5e7e9b8b260.zip
Fixed some sed code, Bug 195786. Fixed remotewonderplus patch.
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-misc/lirc')
-rw-r--r--app-misc/lirc/ChangeLog6
-rw-r--r--app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch26
-rw-r--r--app-misc/lirc/lirc-0.8.3_pre1.ebuild16
3 files changed, 40 insertions, 8 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index 0d1bde0d0317..d48ba447e839 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/lirc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.155 2007/10/13 18:14:33 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.156 2007/10/14 10:16:47 zzam Exp $
+
+ 14 Oct 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/lirc-0.8.3_pre1-remotewonderplus.patch, lirc-0.8.3_pre1.ebuild:
+ Fixed some sed code, Bug 195786. Fixed remotewonderplus patch.
*lirc-0.8.3_pre1 (13 Oct 2007)
diff --git a/app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch b/app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch
new file mode 100644
index 000000000000..66527bcc5709
--- /dev/null
+++ b/app-misc/lirc/files/lirc-0.8.3_pre1-remotewonderplus.patch
@@ -0,0 +1,26 @@
+--- lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.c.orig 2005-10-29 08:18:53.000000000 -0600
++++ lirc-0.8.0/drivers/lirc_atiusb/lirc_atiusb.c 2006-04-01 14:31:05.000000000 -0700
+@@ -147,8 +147,9 @@
+ /* init strings */
+ #define USB_OUTLEN 7
+
+-static char init1[] = {0x01, 0x00, 0x20, 0x14};
+-static char init2[] = {0x01, 0x00, 0x20, 0x14, 0x20, 0x20, 0x20};
++static char init1[] = {0x80, 0x05, 0x1b, 0x15, 0x14, 0x20, 0x24, 0x15};
++static char init2[] = {0x83, 0x03};
++static char init3[] = {0x84, 0xd7, 0x020};
+
+ struct in_endpt {
+ /* inner link in list of endpoints for the remote specified by ir */
+@@ -1034,8 +1034,9 @@
+ usb_sndintpipe(ir->usbdev, oep->ep->bEndpointAddress), oep->buf,
+ USB_OUTLEN, usb_remote_send, oep, oep->ep->bInterval);
+
+- send_packet(oep, 0x8004, init1);
+- send_packet(oep, 0x8007, init2);
++ send_packet(oep, 0x8007, init1);
++ send_packet(oep, 0x8002, init2);
++ send_packet(oep, 0x8003, init3);
+ }
+ }
+
diff --git a/app-misc/lirc/lirc-0.8.3_pre1.ebuild b/app-misc/lirc/lirc-0.8.3_pre1.ebuild
index b550d424c071..63e90c9cf9d5 100644
--- a/app-misc/lirc/lirc-0.8.3_pre1.ebuild
+++ b/app-misc/lirc/lirc-0.8.3_pre1.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.3_pre1.ebuild,v 1.1 2007/10/13 18:14:33 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.8.3_pre1.ebuild,v 1.2 2007/10/14 10:16:47 zzam Exp $
inherit eutils linux-mod flag-o-matic autotools
DESCRIPTION="decode and send infra-red signals of many commonly used remote controls"
HOMEPAGE="http://www.lirc.org/"
+MY_P=${PN}-${PV/_/}
+
if [[ "${PV/_pre/}" = "${PV}" ]]; then
- SRC_URI="mirror://sourceforge/lirc/${P/_/}.tar.bz2"
+ SRC_URI="mirror://sourceforge/lirc/${MY_P}.tar.bz2"
else
- SRC_URI="http://lirc.sourceforge.net/software/snapshots/${P/_/}.tar.bz2"
+ SRC_URI="http://lirc.sourceforge.net/software/snapshots/${MY_P}.tar.bz2"
fi
LICENSE="GPL-2"
@@ -18,7 +20,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug doc X hardware-carrier transmitter"
-S="${WORKDIR}/${P/_pre/pre}"
+S="${WORKDIR}/${MY_P}"
RDEPEND="
X? (
@@ -232,7 +234,7 @@ src_unpack() {
# Apply patches needed for some special device-types
use lirc_devices_imon_pad2keys && epatch "${FILESDIR}"/${PN}-0.8.1-imon-pad2keys.patch
- use lirc_devices_remote_wonder_plus && epatch "${FILESDIR}"/lirc-remotewonderplus.patch
+ use lirc_devices_remote_wonder_plus && epatch "${FILESDIR}"/lirc-0.8.3_pre1-remotewonderplus.patch
# remove parallel driver on SMP systems
if linux_chkconfig_present SMP ; then
@@ -240,10 +242,10 @@ src_unpack() {
fi
# respect CFLAGS
- sed -i -e 's:CFLAGS="-O2:CFLAGS=""\n#CFLAGS="-O2:' configure.in
+ sed -i -e 's:CFLAGS="-O2:CFLAGS=""\n#CFLAGS="-O2:' configure.ac
# setting default device-node
- sed -i -e '/#define LIRC_DRIVER_DEVICE/d' acconfig.h
+ sed -i -e '/#define LIRC_DRIVER_DEVICE/d' configure.ac acconfig.h
echo "#define LIRC_DRIVER_DEVICE \"${LIRC_DRIVER_DEVICE}\"" >> acconfig.h
eautoreconf