summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2004-08-02 08:19:15 +0000
committerHeinrich Wendel <lanius@gentoo.org>2004-08-02 08:19:15 +0000
commit5e2b8e26fd671f2224408308f8b92960a2692f72 (patch)
treef3ea2652e76b6df4ab3edf66f9125328ed3ccbba /app-misc/mc
parentadd patch to avoid crash on Save Display Settings, bug #58063 (Manifest recom... (diff)
downloadgentoo-2-5e2b8e26fd671f2224408308f8b92960a2692f72.tar.gz
gentoo-2-5e2b8e26fd671f2224408308f8b92960a2692f72.tar.bz2
gentoo-2-5e2b8e26fd671f2224408308f8b92960a2692f72.zip
add support for th @ character in ftp, bug #58330
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog6
-rw-r--r--app-misc/mc/Manifest3
-rw-r--r--app-misc/mc/files/digest-mc-4.6.0-r92
-rw-r--r--app-misc/mc/files/mc-4.6.0-ftp.patch11
-rw-r--r--app-misc/mc/mc-4.6.0-r9.ebuild99
5 files changed, 121 insertions, 0 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 3639134163f6..1da911339dec 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/mc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+*mc-4.6.0-r9 (02 Aug 2004)
+
+ 02 Aug 2004; Heinrich Wendel <lanius@gentoo.org> mc-4.6.0-r9.ebuild,
+ files/mc-4.6.0-ftp.patch:
+ add support for th @ character in ftp, bug #58330
+
*mc-4.6.0-r8 (24 May 2004)
24 May 2004; Heinrich Wendel <lanius@gentoo.org> :
diff --git a/app-misc/mc/Manifest b/app-misc/mc/Manifest
index 6d3f97f0b0dc..6037703c915e 100644
--- a/app-misc/mc/Manifest
+++ b/app-misc/mc/Manifest
@@ -1,5 +1,6 @@
MD5 f79a9b6d20e503ceb2011fabdf31cf30 mc-4.5.55-r7.ebuild 1869
MD5 e7db7f553193b22c5476e2edd47e8bce mc-4.6.0-r7.ebuild 2668
+MD5 8bb171db14b517b2796448d515438fe4 mc-4.6.0-r9.ebuild 2605
MD5 380e402de37ee9afa92ee152393acb93 mc-4.6.0-r8.ebuild 2570
MD5 2da24dc8518d1d3914a1bc8ef192db38 ChangeLog 7478
MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
@@ -14,3 +15,5 @@ MD5 2a6c3ed30597eadaa19a6dbdd3ce168d files/mc-4.6.0-cpan-2003-1023.patch 475
MD5 042fefdf0b2c229a62b4e18200099389 files/digest-mc-4.6.0-r5 214
MD5 042fefdf0b2c229a62b4e18200099389 files/digest-mc-4.6.0-r7 214
MD5 d576baf06c64df107664f4724b7632a2 files/digest-mc-4.6.0-r8 139
+MD5 d576baf06c64df107664f4724b7632a2 files/digest-mc-4.6.0-r9 139
+MD5 99fd5760d0ddfc08292de6a62b573e73 files/mc-4.6.0-ftp.patch 285
diff --git a/app-misc/mc/files/digest-mc-4.6.0-r9 b/app-misc/mc/files/digest-mc-4.6.0-r9
new file mode 100644
index 000000000000..c66b6aee0770
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.0-r9
@@ -0,0 +1,2 @@
+MD5 70804dc9e2049e24f294ff7090a82a12 mc-4.6.0.tar.gz 3727676
+MD5 f5053361d1936b3e4187857daf0cc6cb mc-4.6.0-sambalib-3.0.0.patch.bz2 399920
diff --git a/app-misc/mc/files/mc-4.6.0-ftp.patch b/app-misc/mc/files/mc-4.6.0-ftp.patch
new file mode 100644
index 000000000000..ff24b01ded60
--- /dev/null
+++ b/app-misc/mc/files/mc-4.6.0-ftp.patch
@@ -0,0 +1,11 @@
+--- vfs/utilvfs.c 2002-12-15 13:38:18.000000000 -0600
++++ vfs/utilvfs.c 2004-07-25 14:36:26.000000000 -0500
+@@ -87,7 +87,7 @@
+ }
+
+ /* search for any possible user */
+- at = strchr (pcopy, '@');
++ at = strrchr (pcopy, '@');
+
+ /* We have a username */
+ if (at) {
diff --git a/app-misc/mc/mc-4.6.0-r9.ebuild b/app-misc/mc/mc-4.6.0-r9.ebuild
new file mode 100644
index 000000000000..54ec67998cba
--- /dev/null
+++ b/app-misc/mc/mc-4.6.0-r9.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r9.ebuild,v 1.1 2004/08/02 08:19:15 lanius Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz
+ http://www.spock.mga.com.pl/public/gentoo/${P}-sambalib-3.0.0.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64"
+IUSE="gpm nls samba ncurses X slang"
+
+DEPEND=">=sys-fs/e2fsprogs-1.19
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ >=sys-libs/pam-0.72
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ samba? ( >=net-fs/samba-3.0.0 )
+ X? ( virtual/x11 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ epatch ${DISTDIR}/${P}-sambalib-3.0.0.patch.bz2
+
+ epatch ${FILESDIR}/${P}-find.patch
+ epatch ${FILESDIR}/${P}-cpan-2003-1023.patch
+ epatch ${FILESDIR}/${P}-can-2004-0226-0231-0232.patch.bz2
+ epatch ${FILESDIR}/${P}-vfs.patch
+ epatch ${FILESDIR}/${P}-ftp.patch
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=""
+
+ if ! use slang && ! use ncurses ; then
+ myconf="${myconf} --with-screen=mcslang"
+ elif use ncurses && ! use slang ; then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ myconf="${myconf} `use_with gpm gpm-mouse`"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} `use_with X x`"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba
+ --with-codepagedir=/var/lib/samba/codepages --with-privatedir=/etc/samba/private" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-gnu-ld \
+ --with-ext2undel \
+ --with-edit \
+ --enable-charset \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ cat ${FILESDIR}/chdir-4.6.0.gentoo >>\
+ ${S}/lib/mc-wrapper.sh
+
+ einstall || die
+
+ # install cons.saver setuid, to actually work
+ chmod u+s ${D}/usr/lib/mc/cons.saver
+
+ dodoc ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+
+ insinto /usr/share/mc
+ doins ${FILESDIR}/mc.gentoo
+}
+
+pkg_postinst() {
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "allow mc to chdir to its latest working dir at exit"
+ einfo ""
+ einfo "# Midnight Commander chdir enhancement"
+ einfo "if [ -f /usr/share/mc/mc.gentoo ]; then"
+ einfo " . /usr/share/mc/mc.gentoo"
+ einfo "fi"
+}