summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-04-08 18:41:06 +0000
committerAlex Alexander <wired@gentoo.org>2010-04-08 18:41:06 +0000
commit7c40b76af05192d18d9c40e73f8699feb85ba22f (patch)
tree4b1f6b5b400cc07a882cdf24fe64c4d6ee1054fa /app-misc/mc
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-7c40b76af05192d18d9c40e73f8699feb85ba22f.tar.gz
gentoo-2-7c40b76af05192d18d9c40e73f8699feb85ba22f.tar.bz2
gentoo-2-7c40b76af05192d18d9c40e73f8699feb85ba22f.zip
[app-misc/mc] fixed bug 313859
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog9
-rw-r--r--app-misc/mc/files/mc-4.7_mcedit_fix.patch15
-rw-r--r--app-misc/mc/mc-4.7.0.4-r1.ebuild67
-rw-r--r--app-misc/mc/mc-4.7.1-r1.ebuild67
4 files changed, 157 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 9e77b75d19b1..8099c984e4c1 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.195 2010/04/02 15:13:33 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.196 2010/04/08 18:41:06 wired Exp $
+
+*mc-4.7.1-r1 (08 Apr 2010)
+*mc-4.7.0.4-r1 (08 Apr 2010)
+
+ 08 Apr 2010; Alex Alexander <wired@gentoo.org> +mc-4.7.0.4-r1.ebuild,
+ +mc-4.7.1-r1.ebuild, +files/mc-4.7_mcedit_fix.patch:
+ fixed bug 313859
*mc-4.7.0.4 (02 Apr 2010)
diff --git a/app-misc/mc/files/mc-4.7_mcedit_fix.patch b/app-misc/mc/files/mc-4.7_mcedit_fix.patch
new file mode 100644
index 000000000000..c574bea0dbfe
--- /dev/null
+++ b/app-misc/mc/files/mc-4.7_mcedit_fix.patch
@@ -0,0 +1,15 @@
+Index: src/execute.c
+===================================================================
+--- a/src/execute.c
++++ b/src/execute.c
+@@ -305,6 +305,8 @@
+ #endif /* HAVE_SUBSHELL_SUPPORT */
+
+- update_panels (UP_OPTIMIZE, UP_KEEPSEL);
+- update_xterm_title_path ();
++ if ((view_one_file == NULL) && (edit_one_file == NULL)) {
++ update_panels (UP_OPTIMIZE, UP_KEEPSEL);
++ update_xterm_title_path ();
++ }
+ repaint_screen ();
+ }
diff --git a/app-misc/mc/mc-4.7.0.4-r1.ebuild b/app-misc/mc/mc-4.7.0.4-r1.ebuild
new file mode 100644
index 000000000000..718ca2643a99
--- /dev/null
+++ b/app-misc/mc/mc-4.7.0.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0.4-r1.ebuild,v 1.1 2010/04/08 18:41:06 wired Exp $
+
+EAPI=3
+
+inherit base
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="http://www.midnight-commander.org"
+SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm nls samba slang X"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-4.7_mcedit_fix.patch" )
+
+src_configure() {
+ local myscreen=ncurses
+ use slang && myscreen=slang
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --enable-vfs \
+ $(use_enable kernel_linux vfs-undelfs) \
+ --enable-charset \
+ $(use_with X x) \
+ $(use_with samba) \
+ --with-configdir="${EPREFIX}"/etc/samba \
+ --with-codepagedir="${EPREFIX}"/var/lib/samba/codepages \
+ $(use_with gpm gpm-mouse) \
+ --with-screen=${myscreen} \
+ $(use_with edit)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}
diff --git a/app-misc/mc/mc-4.7.1-r1.ebuild b/app-misc/mc/mc-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..ff748f440eba
--- /dev/null
+++ b/app-misc/mc/mc-4.7.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.1-r1.ebuild,v 1.1 2010/04/08 18:41:06 wired Exp $
+
+EAPI=3
+
+inherit base
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="http://www.midnight-commander.org"
+SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm nls samba slang X"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${PN}-4.7_mcedit_fix.patch" )
+
+src_configure() {
+ local myscreen=ncurses
+ use slang && myscreen=slang
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --enable-vfs \
+ $(use_enable kernel_linux vfs-undelfs) \
+ --enable-charset \
+ $(use_with X x) \
+ $(use_with samba) \
+ --with-configdir="${EPREFIX}"/etc/samba \
+ --with-codepagedir="${EPREFIX}"/var/lib/samba/codepages \
+ $(use_with gpm gpm-mouse) \
+ --with-screen=${myscreen} \
+ $(use_with edit)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}