summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-11-22 00:10:44 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-11-22 00:10:44 +0000
commit61bb0637d60537ee1130178fd89ef7e80b11ee72 (patch)
tree9ae52d5d4bfa26c671b31a20ba80fc475ec19ba8 /app-misc/nut/files
parentUpdate to Linux 2.6.27.7 (diff)
downloadgentoo-2-61bb0637d60537ee1130178fd89ef7e80b11ee72.tar.gz
gentoo-2-61bb0637d60537ee1130178fd89ef7e80b11ee72.tar.bz2
gentoo-2-61bb0637d60537ee1130178fd89ef7e80b11ee72.zip
Version bump, use EAPI 2, honor LDFLAGS, fix --as-needed (bug #246904).
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'app-misc/nut/files')
-rw-r--r--app-misc/nut/files/nut-14.1-build-fixes.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-misc/nut/files/nut-14.1-build-fixes.patch b/app-misc/nut/files/nut-14.1-build-fixes.patch
new file mode 100644
index 000000000000..fba49df6b3af
--- /dev/null
+++ b/app-misc/nut/files/nut-14.1-build-fixes.patch
@@ -0,0 +1,14 @@
+* Use $(CC) instead of gcc.
+* Honor LDFLAGS.
+* Put -l flags at the end so it doesn't break --as-needed linker flag (bug #246904)
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@
+ CFLAGS= -O3 -s -Wall -DNUTDIR=\".nutdb\" -DFOODDIR=\"/usr/local/lib/nut\" -ansi -pedantic
+
+ nut: $(objects)
+- gcc ${CFLAGS} -lm -o nut $(objects)
++ $(CC) ${CFLAGS} -o nut $(LDFLAGS) $(objects) -lm
+
+ deps:
+ makedepend *.c