summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-18 19:25:31 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-18 19:25:31 +0000
commitb34920edb0882dcbc709cf75a0a090f21015f71b (patch)
treefad1ee15b1d25c74dc59cb1445686c99ae41bd99 /app-misc/screen
parentVersion bump. (diff)
downloadgentoo-2-b34920edb0882dcbc709cf75a0a090f21015f71b.tar.gz
gentoo-2-b34920edb0882dcbc709cf75a0a090f21015f71b.tar.bz2
gentoo-2-b34920edb0882dcbc709cf75a0a090f21015f71b.zip
Old.
(Portage version: 2.2.0_alpha69/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/screen')
-rw-r--r--app-misc/screen/ChangeLog7
-rw-r--r--app-misc/screen/files/4.0.3-extend-d_termname-ng.patch111
-rw-r--r--app-misc/screen/files/4.0.3-extend-d_termname.patch29
-rw-r--r--app-misc/screen/screen-4.0.3.ebuild158
4 files changed, 6 insertions, 299 deletions
diff --git a/app-misc/screen/ChangeLog b/app-misc/screen/ChangeLog
index b6dc54fcb010..18974c0ead53 100644
--- a/app-misc/screen/ChangeLog
+++ b/app-misc/screen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/screen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/ChangeLog,v 1.162 2011/07/15 14:31:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/ChangeLog,v 1.163 2011/10/18 19:25:31 jer Exp $
+
+ 18 Oct 2011; Jeroen Roovers <jer@gentoo.org>
+ -files/4.0.3-extend-d_termname.patch,
+ -files/4.0.3-extend-d_termname-ng.patch, -screen-4.0.3.ebuild:
+ ^
15 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> screen-4.0.3-r4.ebuild:
ppc64 stable wrt #361823
diff --git a/app-misc/screen/files/4.0.3-extend-d_termname-ng.patch b/app-misc/screen/files/4.0.3-extend-d_termname-ng.patch
deleted file mode 100644
index 497cb8f2f912..000000000000
--- a/app-misc/screen/files/4.0.3-extend-d_termname-ng.patch
+++ /dev/null
@@ -1,111 +0,0 @@
-diff --git a/display.h b/display.h
-index ef99954..563fcd0 100644
---- a/display.h
-+++ b/display.h
-@@ -22,6 +22,16 @@
- * $Id: 4.0.3-extend-d_termname-ng.patch,v 1.1 2010/11/17 16:42:00 jlec Exp $ FAU
- */
-
-+#include <limits.h>
-+
-+#ifndef NAME_MAX
-+# ifndef MAXNAMELEN
-+# define NAME_MAX 255
-+# else
-+# define NAME_MAX MAXNAMELEN
-+# endif
-+#endif
-+
- #ifdef MAPKEYS
-
- #define KMAP_KEYS (T_OCAPS-T_CAPS)
-@@ -85,7 +95,7 @@ struct display
- struct win *d_other; /* pointer to other window */
- int d_nonblock; /* -1 don't block if obufmax reached */
- /* >0: block after nonblock secs */
-- char d_termname[20 + 1]; /* $TERM */
-+ char d_termname[NAME_MAX + 1]; /* $TERM */
- char *d_tentry; /* buffer for tgetstr */
- char d_tcinited; /* termcap inited flag */
- int d_width, d_height; /* width/height of the screen */
-diff --git a/screen.h b/screen.h
-index 4f9f354..bcaaaf6 100644
---- a/screen.h
-+++ b/screen.h
-@@ -43,6 +43,15 @@
- #include "comm.h"
- #include "layer.h"
- #include "term.h"
-+#include <limits.h>
-+
-+#ifndef NAME_MAX
-+# ifndef MAXNAMELEN
-+# define NAME_MAX 255
-+# else
-+# define NAME_MAX MAXNAMELEN
-+# endif
-+#endif
-
-
- #ifdef DEBUG
-@@ -195,26 +204,26 @@ struct msg
- create;
- struct
- {
-- char auser[20 + 1]; /* username */
-+ char auser[NAME_MAX + 1]; /* username */
- int apid; /* pid of frontend */
- int adaptflag; /* adapt window size? */
- int lines, columns; /* display size */
- char preselect[20];
- int esc; /* his new escape character unless -1 */
- int meta_esc; /* his new meta esc character unless -1 */
-- char envterm[20 + 1]; /* terminal type */
-+ char envterm[NAME_MAX + 1]; /* terminal type */
- int encoding; /* encoding of display */
- }
- attach;
- struct
- {
-- char duser[20 + 1]; /* username */
-+ char duser[NAME_MAX + 1]; /* username */
- int dpid; /* pid of frontend */
- }
- detach;
- struct
- {
-- char auser[20 + 1]; /* username */
-+ char auser[NAME_MAX + 1]; /* username */
- int nargs;
- char cmd[MAXPATHLEN]; /* command */
- int apid; /* pid of frontend */
-diff --git a/socket.c b/socket.c
-index 62a73af..1cc9c27 100644
---- a/socket.c
-+++ b/socket.c
-@@ -45,6 +45,16 @@
-
- #include "extern.h"
-
-+#include <limits.h>
-+
-+#ifndef NAME_MAX
-+# ifndef MAXNAMELEN
-+# define NAME_MAX 255
-+# else
-+# define NAME_MAX MAXNAMELEN
-+# endif
-+#endif
-+
- static int CheckPid __P((int));
- static void ExecCreate __P((struct msg *));
- static void DoCommandMsg __P((struct msg *));
-@@ -1248,7 +1258,7 @@ static void PasswordProcessInput __P((char *, int));
-
- struct pwdata {
- int l;
-- char buf[20 + 1];
-+ char buf[NAME_MAX + 1];
- struct msg m;
- };
-
diff --git a/app-misc/screen/files/4.0.3-extend-d_termname.patch b/app-misc/screen/files/4.0.3-extend-d_termname.patch
deleted file mode 100644
index 1849bf1ebbbb..000000000000
--- a/app-misc/screen/files/4.0.3-extend-d_termname.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -ur screen-4.0.3.orig//display.h screen-4.0.3/display.h
---- screen-4.0.3.orig//display.h 2003-07-01 16:01:42.000000000 +0200
-+++ screen-4.0.3/display.h 2010-11-17 13:18:13.182984179 +0100
-@@ -22,6 +22,16 @@
- * $Id: 4.0.3-extend-d_termname.patch,v 1.1 2010/11/17 14:51:18 jlec Exp $ FAU
- */
-
-+#include <limits.h>
-+
-+#ifndef NAME_MAX
-+# ifndef MAXNAMELEN
-+# define NAME_MAX 255
-+# else
-+# define NAME_MAX MAXNAMELEN
-+# endif
-+#endif
-+
- #ifdef MAPKEYS
-
- #define KMAP_KEYS (T_OCAPS-T_CAPS)
-@@ -85,7 +95,7 @@
- struct win *d_other; /* pointer to other window */
- int d_nonblock; /* -1 don't block if obufmax reached */
- /* >0: block after nonblock secs */
-- char d_termname[20 + 1]; /* $TERM */
-+ char d_termname[NAME_MAX + 1]; /* $TERM */
- char *d_tentry; /* buffer for tgetstr */
- char d_tcinited; /* termcap inited flag */
- int d_width, d_height; /* width/height of the screen */
diff --git a/app-misc/screen/screen-4.0.3.ebuild b/app-misc/screen/screen-4.0.3.ebuild
deleted file mode 100644
index 3a83de5b8ed1..000000000000
--- a/app-misc/screen/screen-4.0.3.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.3.ebuild,v 1.23 2010/11/17 14:51:18 jlec Exp $
-
-WANT_AUTOCONF="2.5"
-
-inherit eutils flag-o-matic toolchain-funcs pam autotools
-
-DESCRIPTION="Full-screen window manager that multiplexes physical terminals between several processes"
-HOMEPAGE="http://www.gnu.org/software/screen/"
-SRC_URI="ftp://ftp.uni-erlangen.de/pub/utilities/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug nethack pam selinux multiuser"
-
-RDEPEND=">=sys-libs/ncurses-5.2
- pam? ( virtual/pam )
- selinux? ( sec-policy/selinux-screen )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- # Make sure utmp group exists, as it's used later on.
- enewgroup utmp 406
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Bug 34599: integer overflow in 4.0.1
- # (Nov 29 2003 -solar)
- epatch "${FILESDIR}"/screen-4.0.1-int-overflow-fix.patch
-
- # Bug 31070: configure problem which affects alpha
- # (13 Jan 2004 agriffis)
- epatch "${FILESDIR}"/screen-4.0.1-vsprintf.patch
-
- # uclibc doesnt have sys/stropts.h
- if ! (echo '#include <sys/stropts.h>' | $(tc-getCC) -E - &>/dev/null) ; then
- epatch "${FILESDIR}"/4.0.2-no-pty.patch
- fi
-
- # Don't use utempter even if it is found on the system
- epatch "${FILESDIR}"/4.0.2-no-utempter.patch
-
- # Don't link against libelf even if it is found on the system
- epatch "${FILESDIR}"/4.0.2-no-libelf.patch
-
- # Patch for time function on 64bit systems
- epatch "${FILESDIR}"/4.0.2-64bit-time.patch
-
- # Patch that makes %u work for windowlist -b formats
- epatch "${FILESDIR}"/4.0.2-windowlist-multiuser-fix.patch
-
- # Open tty in non-blocking mode
- epatch "${FILESDIR}"/4.0.2-nonblock.patch
-
- # compability for sys-devel/autoconf-2.62
- epatch "${FILESDIR}"/screen-4.0.3-config.h-autoconf-2.62.patch
-
- # crosscompile patch
- epatch "${FILESDIR}"/"${P}"-crosscompile.patch
-
- # sched.h is a system header and causes problems with some C libraries
- mv sched.h _sched.h || die
- sed -i '/include/s:sched.h:_sched.h:' screen.h || die
-
- # Allow for more rendition (color/attribute) changes in status bars
- sed -i \
- -e "s:#define MAX_WINMSG_REND 16:#define MAX_WINMSG_REND 64:" \
- screen.c \
- || die "sed screen.c failed"
-
- # Fix manpage.
- sed -i \
- -e "s:/usr/local/etc/screenrc:/etc/screenrc:g" \
- -e "s:/usr/local/screens:/var/run/screen:g" \
- -e "s:/local/etc/screenrc:/etc/screenrc:g" \
- -e "s:/etc/utmp:/var/run/utmp:g" \
- -e "s:/local/screens/S-:/var/run/screen/S-:g" \
- doc/screen.1 \
- || die "sed doc/screen.1 failed"
-
- # reconfigure
- eautoconf
-}
-
-src_compile() {
- append-flags "-DMAXWIN=${MAX_SCREEN_WINDOWS:-100}"
-
- use nethack || append-flags "-DNONETHACK"
- use debug && append-flags "-DDEBUG"
-
- econf \
- --with-socket-dir=/var/run/screen \
- --with-sys-screenrc=/etc/screenrc \
- --with-pty-mode=0620 \
- --with-pty-group=5 \
- --enable-rxvt_osc \
- --enable-telnet \
- --enable-colors256 \
- $(use_enable pam) \
- || die "econf failed"
-
- # Second try to fix bug 12683, this time without changing term.h
- # The last try seemed to break screen at run-time.
- # (16 Jan 2003 agriffis)
- LC_ALL=POSIX make term.h || die "Failed making term.h"
-
- emake || die "emake failed"
-}
-
-src_install() {
- dobin screen || die "dobin failed"
- keepdir /var/run/screen || die "keepdir failed"
-
- if use multiuser
- then
- fperms 4755 /usr/bin/screen || die "fperms failed"
- else
- fowners root:utmp /{usr/bin,var/run}/screen || die "fowners failed"
- fperms 2755 /usr/bin/screen || die "fperms failed"
- fi
-
- insinto /usr/share/screen
- doins terminfo/{screencap,screeninfo.src} || die "doins failed"
- insinto /usr/share/screen/utf8encodings
- doins utf8encodings/?? || die "doins failed"
- insinto /etc
- doins "${FILESDIR}"/screenrc || die "doins failed"
-
- pamd_mimic_system screen auth || die "pamd_mimic_system failed"
-
- dodoc \
- README ChangeLog INSTALL TODO NEWS* patchlevel.h \
- doc/{FAQ,README.DOTSCREEN,fdpat.ps,window_to_display.ps} \
- || die "dodoc failed"
-
- doman doc/screen.1 || die "doman failed"
- doinfo doc/screen.info* || die "doinfo failed"
-}
-
-pkg_postinst() {
- if use multiuser
- then
- chown root:0 "${ROOT}"/var/run/screen
- chmod 0755 "${ROOT}"/var/run/screen
- else
- chown root:utmp "${ROOT}"/var/run/screen
- chmod 0775 "${ROOT}"/var/run/screen
- fi
-
- elog "Some dangerous key bindings have been removed or changed to more safe values."
- elog "We enable some xterm hacks in our default screenrc, which might break some"
- elog "applications. Please check /etc/screenrc for information on these changes."
-}