summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-13 17:18:59 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-13 17:18:59 +0000
commit2de8462966c2414371db075c382ad01bd79848f0 (patch)
treedf744af72d7d42236228d25f65f4ffba178c6f01 /app-misc/tmux
parents390/sh/sparc stable wrt #427546 (diff)
downloadgentoo-2-2de8462966c2414371db075c382ad01bd79848f0.tar.gz
gentoo-2-2de8462966c2414371db075c382ad01bd79848f0.tar.bz2
gentoo-2-2de8462966c2414371db075c382ad01bd79848f0.zip
Version bump.
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog7
-rw-r--r--app-misc/tmux/tmux-1.7.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index a5f1f7e6427d..549b5cd160dc 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.81 2012/09/26 12:19:51 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.82 2012/10/13 17:18:59 radhermit Exp $
+
+*tmux-1.7 (13 Oct 2012)
+
+ 13 Oct 2012; Tim Harder <radhermit@gentoo.org> +tmux-1.7.ebuild:
+ Version bump.
26 Sep 2012; Anthony G. Basile <blueness@gentoo.org> tmux-1.5.ebuild,
tmux-1.6.ebuild:
diff --git a/app-misc/tmux/tmux-1.7.ebuild b/app-misc/tmux/tmux-1.7.ebuild
new file mode 100644
index 000000000000..4aba8e28fbb4
--- /dev/null
+++ b/app-misc/tmux/tmux-1.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.7.ebuild,v 1.1 2012/10/13 17:18:59 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+COMMON_DEPEND="
+ >=dev-libs/libevent-2.0.10
+ sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ NOTES TODO )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.7"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: after updating to ${P} you will _not_ be able to connect to any"
+ ewarn "running 1.6 tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to tmux 1.6 to access them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}