summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-03-20 02:38:21 +0000
committerMike Gilbert <floppym@gentoo.org>2014-03-20 02:38:21 +0000
commit0ae4c702351aacf2a5130d8dfb6a49bbbcbca736 (patch)
treeaba069e77e4869c79cd03848544e325b4c72edf6 /app-misc
parentMask server useflag for rubygems-1.8.x due to ruby1.8 deprecation (diff)
downloadgentoo-2-0ae4c702351aacf2a5130d8dfb6a49bbbcbca736.tar.gz
gentoo-2-0ae4c702351aacf2a5130d8dfb6a49bbbcbca736.tar.bz2
gentoo-2-0ae4c702351aacf2a5130d8dfb6a49bbbcbca736.zip
We only need python if we are not using the precompiled certs.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ca-certificates/ChangeLog6
-rw-r--r--app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/app-misc/ca-certificates/ChangeLog b/app-misc/ca-certificates/ChangeLog
index 7d173462dbc0..c6ded25bf1a2 100644
--- a/app-misc/ca-certificates/ChangeLog
+++ b/app-misc/ca-certificates/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/ca-certificates
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ChangeLog,v 1.99 2014/03/20 02:23:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ChangeLog,v 1.100 2014/03/20 02:38:21 floppym Exp $
+
+ 20 Mar 2014; Mike Gilbert <floppym@gentoo.org>
+ ca-certificates-20140223.3.15.5.ebuild:
+ We only need python if we are not using the precompiled certs.
20 Mar 2014; Mike Gilbert <floppym@gentoo.org>
ca-certificates-20140223.3.15.5.ebuild:
diff --git a/app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild b/app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild
index 3cc5435931e6..86debb770f14 100644
--- a/app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild
+++ b/app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild,v 1.2 2014/03/20 02:23:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ca-certificates/ca-certificates-20140223.3.15.5.ebuild,v 1.3 2014/03/20 02:38:21 floppym Exp $
# The Debian ca-certificates package merely takes the CA database as it exists
# in the nss package and repackages it for use by openssl.
@@ -74,7 +74,10 @@ RDEPEND="${DEPEND}
dev-libs/openssl
sys-apps/debianutils"
-DEPEND+=" ${PYTHON_DEPS}"
+
+if ! ${PRECOMPILED}; then
+ DEPEND+=" ${PYTHON_DEPS}"
+fi
S=${WORKDIR}
@@ -83,7 +86,6 @@ pkg_setup() {
# we need to tell users about it once manually first.
[[ -f "${EPREFIX}"/etc/env.d/98ca-certificates ]] \
|| ewarn "You should run update-ca-certificates manually after etc-update"
- python_setup
}
src_unpack() {
@@ -121,6 +123,7 @@ src_prepare() {
src_compile() {
cd "image/${EPREFIX}" || die
if ! ${PRECOMPILED} ; then
+ python_setup
local d="${S}/${PN}/mozilla"
# Grab the database from the nss sources.
cp "${S}"/nss-${NSS_VER}/nss/lib/ckfw/builtins/{certdata.txt,nssckbi.h} "${d}" || die