summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-25 23:45:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-25 23:45:58 +0000
commit272191a735527581f3c66782cb6ce68ae308017e (patch)
treec75b61a99a75f7230a9a37a33c1c0a34a505f910 /app-misc
parentupdate digest (diff)
downloadgentoo-2-272191a735527581f3c66782cb6ce68ae308017e.tar.gz
gentoo-2-272191a735527581f3c66782cb6ce68ae308017e.tar.bz2
gentoo-2-272191a735527581f3c66782cb6ce68ae308017e.zip
Fix building with gcc-2, dont bomb with alignment errors on some arches, and add support for SONAME scanning in scanelf.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/pax-utils/ChangeLog8
-rw-r--r--app-misc/pax-utils/files/digest-pax-utils-0.1.31
-rw-r--r--app-misc/pax-utils/pax-utils-0.1.3.ebuild30
3 files changed, 38 insertions, 1 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index 8397bc3e3a21..0a1c7b80fb54 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/pax-utils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.30 2005/07/03 22:26:08 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.31 2005/07/25 23:45:58 vapier Exp $
+
+*pax-utils-0.1.3 (25 Jul 2005)
+
+ 25 Jul 2005; Mike Frysinger <vapier@gentoo.org> +pax-utils-0.1.3.ebuild:
+ Fix building with gcc-2, dont bomb with alignment errors on some arches, and
+ add support for SONAME scanning in scanelf.
*pax-utils-0.1.2 (03 Jul 2005)
diff --git a/app-misc/pax-utils/files/digest-pax-utils-0.1.3 b/app-misc/pax-utils/files/digest-pax-utils-0.1.3
new file mode 100644
index 000000000000..80b4e937ccd7
--- /dev/null
+++ b/app-misc/pax-utils/files/digest-pax-utils-0.1.3
@@ -0,0 +1 @@
+MD5 14d37c43a9086e20bb6654d37218dd5c pax-utils-0.1.3.tar.bz2 44302
diff --git a/app-misc/pax-utils/pax-utils-0.1.3.ebuild b/app-misc/pax-utils/pax-utils-0.1.3.ebuild
new file mode 100644
index 000000000000..2e89931ccead
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.1.3.ebuild,v 1.1 2005/07/25 23:45:58 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs
+#RESTRICT="primaryuri"
+DESCRIPTION="Various ELF related utils for ELF32, ELF64 binaries useful for displaying PaX and security info on a large groups of bins"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="caps"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_compile() {
+ if use caps ; then
+ append-flags -DWANT_SYSCAP
+ append-ldflags -lcap
+ fi
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" all || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README
+}