summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-14 07:26:41 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-14 07:26:41 +0000
commita1a0228b3d0efc572a1ad3d9f6a26af3e66336d6 (patch)
tree282f0cea07640b7940d84c3b128c0a27b08d87e5 /app-misc
parentapp-misc/boxes: Version Bump, moved to EAPI=5, #451866 (diff)
downloadgentoo-2-a1a0228b3d0efc572a1ad3d9f6a26af3e66336d6.tar.gz
gentoo-2-a1a0228b3d0efc572a1ad3d9f6a26af3e66336d6.tar.bz2
gentoo-2-a1a0228b3d0efc572a1ad3d9f6a26af3e66336d6.zip
app-misc/realpath: Version Bump, moved to EAPI=5, #451858
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/realpath/ChangeLog7
-rw-r--r--app-misc/realpath/realpath-1.18.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/app-misc/realpath/ChangeLog b/app-misc/realpath/ChangeLog
index bf3e75319be5..ad938605896f 100644
--- a/app-misc/realpath/ChangeLog
+++ b/app-misc/realpath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/realpath
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.39 2013/01/09 17:12:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/ChangeLog,v 1.40 2013/01/14 07:26:41 jlec Exp $
+
+*realpath-1.18 (14 Jan 2013)
+
+ 14 Jan 2013; Justin Lecher <jlec@gentoo.org> +realpath-1.18.ebuild:
+ Version Bump, moved to EAPI=5, #451858
09 Jan 2013; Justin Lecher <jlec@gentoo.org> -realpath-1.16.ebuild,
metadata.xml:
diff --git a/app-misc/realpath/realpath-1.18.ebuild b/app-misc/realpath/realpath-1.18.ebuild
new file mode 100644
index 000000000000..2e356f7b0725
--- /dev/null
+++ b/app-misc/realpath/realpath-1.18.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/realpath/realpath-1.18.ebuild,v 1.1 2013/01/14 07:26:41 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib prefix toolchain-funcs
+
+DESCRIPTION="Return the canonicalized absolute pathname"
+HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
+SRC_URI="
+ mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
+ nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="
+ !sys-freebsd/freebsd-bin
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ x86-interix? ( dev-libs/gnulib )
+ elibc_mintlib? ( virtual/libiconv )"
+
+src_unpack() {
+ unpack ${PN}_${PV}.tar.gz
+
+ if use nls; then
+ # Unpack the .deb file, in order to get the preprocessed man page
+ # translations. This way we avoid a dependency on app-text/po4a.
+ mkdir deb
+ cd deb
+ unpack ${PN}_${PV}_i386.deb
+ unpack ./data.tar.gz
+ fi
+}
+
+src_prepare() {
+ use nls || epatch "${FILESDIR}"/${PN}-1.16-nonls.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.17-build.patch \
+ "${FILESDIR}"/${PN}-1.14-no-po4a.patch \
+ "${FILESDIR}"/${PN}-1.15-prefix.patch
+ eprefixify common.mk
+}
+
+src_compile() {
+ tc-export CC
+ use nls && use !elibc_glibc && append-libs -lintl
+ [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
+ if [[ ${CHOST} == *-irix* || ${CHOST} == *-interix[35]* ]] ; then
+ append-flags -I"${EPREFIX}"/usr/$(get_libdir)/gnulib/include
+ append-ldflags -L"${EPREFIX}"/usr/$(get_libdir)/gnulib/$(get_libdir)
+ append-libs -lgnu
+ fi
+
+ local subdir
+ for subdir in src man $(usex nls po ''); do
+ emake MAKE_VERBOSE=yes VERSION="${PV}" -C ${subdir}
+ done
+}
+
+src_install() {
+ emake \
+ VERSION="${PV}" \
+ SUBDIRS="src man $(usex nls po '')" \
+ DESTDIR="${D}" \
+ install
+ newdoc debian/changelog ChangeLog.debian
+
+ if use nls; then
+ local dir
+ for dir in "${WORKDIR}"/deb/usr/share/man/*; do
+ [ -f "${dir}"/man1/realpath.1 ] || continue
+ newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1
+ done
+ fi
+}