summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-02-03 06:49:06 +0000
committerAlin Năstac <mrness@gentoo.org>2007-02-03 06:49:06 +0000
commitcaf67fdc71e1435638f6afe5cd8a1dbc0813f8e0 (patch)
tree8ccf3752d5ca6699abc10b20a785a60020b8d2d2 /app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild
parentUpdating for re-rolled tarball of imagepak-werschler.tar.gz (diff)
downloadgentoo-2-caf67fdc71e1435638f6afe5cd8a1dbc0813f8e0.tar.gz
gentoo-2-caf67fdc71e1435638f6afe5cd8a1dbc0813f8e0.tar.bz2
gentoo-2-caf67fdc71e1435638f6afe5cd8a1dbc0813f8e0.zip
Add optional sender number, thanks to Andreas Bollhalder <bolle at geodb dot org> (#164954).
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild')
-rw-r--r--app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild b/app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild
new file mode 100644
index 000000000000..dd4f32f9813a
--- /dev/null
+++ b/app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/smsclient/smsclient-2.0.9a-r1.ebuild,v 1.1 2007/02/03 06:49:06 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Utility to send SMS messages to mobile phones and pagers."
+HOMEPAGE="http://www.smsclient.org"
+SRC_URI="http://www.smsclient.org/download/${PN}-${PV%?}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-sender.patch"
+}
+
+src_compile() {
+ rm .configured && ./configure || die "Configure failed"
+ make || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+ dosym sms_client /usr/bin/smsclient
+ dosym sms_address /usr/bin/smsaddress
+
+ diropts -g dialout -m 0770
+ keepdir /var/lock/sms
+ diropts
+
+ doman docs/sms_client.1
+ dodoc Authors Changelog* FAQ README* TODO docs/sms_protocol
+}
+
+pkg_postinst() {
+ local MY_LOGFILE="${ROOT}/var/log/smsclient.log"
+ [ -f "${MY_LOGFILE}" ] || touch "${MY_LOGFILE}"
+ chgrp dialout "${MY_LOGFILE}"
+ chmod g+rwx,o-rwx "${MY_LOGFILE}"
+
+ einfo "If you run sms_client as normal user, make sure you are member of dialout group."
+}