summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-03 00:31:53 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-03 00:31:53 +0000
commita16a1f9dab512fa3530335ae6a959fea30efbdd1 (patch)
tree644a22237284e4283cb7172915fd5ed2b696022c /app-office/abiword/abiword-2.4.6.ebuild
parentVersion bump, bug #159193. (diff)
downloadgentoo-2-a16a1f9dab512fa3530335ae6a959fea30efbdd1.tar.gz
gentoo-2-a16a1f9dab512fa3530335ae6a959fea30efbdd1.tar.bz2
gentoo-2-a16a1f9dab512fa3530335ae6a959fea30efbdd1.zip
version bump (bug #155528)
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'app-office/abiword/abiword-2.4.6.ebuild')
-rw-r--r--app-office/abiword/abiword-2.4.6.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-2.4.6.ebuild b/app-office/abiword/abiword-2.4.6.ebuild
new file mode 100644
index 000000000000..36c177aa58ee
--- /dev/null
+++ b/app-office/abiword/abiword-2.4.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.4.6.ebuild,v 1.1 2007/01/03 00:31:53 compnerd Exp $
+
+inherit alternatives eutils fdo-mime
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gnome spell xml"
+
+RDEPEND="virtual/xft
+ dev-libs/popt
+ sys-libs/zlib
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4
+ >=x11-libs/pango-1.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2
+ >=media-libs/libpng-1.2
+ >=media-libs/fontconfig-2.1
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ xml? ( >=dev-libs/libxml2-2.4.10 )
+ !xml? ( dev-libs/expat )
+ spell? ( >=app-text/enchant-1.1 )
+ gnome? (
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-extra/gucharmap-1.4
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+S="${WORKDIR}/${P}/abi"
+
+src_compile() {
+ # Patch from debian to use fullpath for file history
+ epatch ${FILESDIR}/11_history_fullpath.dpatch
+
+ econf $(use_enable debug) \
+ $(use_enable debug symbols) \
+ $(use_enable gnome) \
+ $(use_enable gnome gucharmap) \
+ $(use_enable spell enchant) \
+ $(use_with xml libxml2) \
+ "--enable-threads" \
+ "--disable-scripting" \
+ "--with-sys-wv" \
+ || die "configure failed"
+
+ emake all-recursive || die "build failed"
+}
+
+src_install() {
+ dodir /usr/{bin,lib}
+ make DESTDIR="${D}" install || die "install failed"
+
+ dosed "s:Exec=abiword:Exec=abiword-2.4:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword
+ rm -f ${D}/usr/bin/abiword-2.4
+ dosym AbiWord-2.4 /usr/bin/abiword-2.4
+
+ dodoc *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ alternatives_auto_makesym "/usr/bin/abiword" "/usr/bin/abiword-[0-9].[0-9]"
+
+ einfo "As of version 2.4, all abiword plugins have been moved"
+ einfo "into a seperate abiword-plugins package"
+ einfo "You can install them by running emerge abiword-plugins"
+}