summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-06-23 22:57:33 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-06-23 22:57:33 +0000
commit0ddada65ab2afb48d72cda0e7aa3614f744b262a (patch)
tree0ad243338738164e7b7fb215a87f00694fc23a91 /app-office/abiword
parentforgot to remove an old file (diff)
downloadgentoo-2-0ddada65ab2afb48d72cda0e7aa3614f744b262a.tar.gz
gentoo-2-0ddada65ab2afb48d72cda0e7aa3614f744b262a.tar.bz2
gentoo-2-0ddada65ab2afb48d72cda0e7aa3614f744b262a.zip
GCC4 upstream patch; closes bug #96796.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/ChangeLog6
-rw-r--r--app-office/abiword/abiword-2.2.8.ebuild5
-rw-r--r--app-office/abiword/files/2.2.8-gcc4.patch13
3 files changed, 22 insertions, 2 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 63ad42380fb5..32fa80307449 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.115 2005/06/19 20:36:05 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.116 2005/06/23 22:57:33 chainsaw Exp $
+
+ 23 Jun 2005; Tony Vroon <chainsaw@gentoo.org> +files/2.2.8-gcc4.patch,
+ abiword-2.2.8.ebuild:
+ Add upstream patch to allow compilation with GCC 4. Closes bug #96796.
19 Jun 2005; Markus Rothe <corsair@gentoo.org> abiword-2.2.7.ebuild:
Stable on ppc64
diff --git a/app-office/abiword/abiword-2.2.8.ebuild b/app-office/abiword/abiword-2.2.8.ebuild
index 4cb0d0a0f864..2fa5f180576e 100644
--- a/app-office/abiword/abiword-2.2.8.ebuild
+++ b/app-office/abiword/abiword-2.2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.2.8.ebuild,v 1.1 2005/06/16 21:08:29 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.2.8.ebuild,v 1.2 2005/06/23 22:57:33 chainsaw Exp $
inherit eutils fdo-mime alternatives
@@ -47,6 +47,9 @@ src_compile() {
cat configure.old |sed s:-pedantic::g >configure
rm -f configure.old
+ # Fix compilation on GCC4; upstream patch
+ epatch ${FILESDIR}/${PV}-gcc4.patch
+
econf \
`use_enable gnome` \
`use_enable gnome gucharmap` \
diff --git a/app-office/abiword/files/2.2.8-gcc4.patch b/app-office/abiword/files/2.2.8-gcc4.patch
new file mode 100644
index 000000000000..609706ef18bc
--- /dev/null
+++ b/app-office/abiword/files/2.2.8-gcc4.patch
@@ -0,0 +1,13 @@
+diff -r -u abiword-2.2.8.orig/abi/src/wp/impexp/xp/ie_mailmerge.h abiword-2.2.8/abi/src/wp/impexp/xp/ie_mailmerge.h
+--- abiword-2.2.8.orig/abi/src/wp/impexp/xp/ie_mailmerge.h 2005-01-23 15:37:50.000000000 +0100
++++ abiword-2.2.8/abi/src/wp/impexp/xp/ie_mailmerge.h 2005-06-06 22:28:30.000000000 +0200
+@@ -28,6 +28,8 @@
+ typedef UT_sint32 IEMergeType;
+ #define IEMT_Unknown ((IEMergeType)-1)
+
++class IE_MailMerge;
++
+ class ABI_EXPORT IE_MergeSniffer : public UT_AbiObject
+ {
+ friend class IE_MailMerge;
+