summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-28 23:18:56 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-28 23:18:56 +0000
commit0db7a1157e1472f9da316af35904e21725df1b52 (patch)
tree05129c2c0de593df078b69c97381f345e5226d6d /app-office/dia
parentRevision bump. (diff)
downloadgentoo-2-0db7a1157e1472f9da316af35904e21725df1b52.tar.gz
gentoo-2-0db7a1157e1472f9da316af35904e21725df1b52.tar.bz2
gentoo-2-0db7a1157e1472f9da316af35904e21725df1b52.zip
add 64 bit compilation fix patch, bug #191673.
(Portage version: 2.2_rc3/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/ChangeLog6
-rw-r--r--app-office/dia/dia-0.96.1-r1.ebuild5
-rw-r--r--app-office/dia/files/dia-0.96.1-64bit-fixes.patch11
3 files changed, 20 insertions, 2 deletions
diff --git a/app-office/dia/ChangeLog b/app-office/dia/ChangeLog
index c4d06aafb5b6..6c08d405fa07 100644
--- a/app-office/dia/ChangeLog
+++ b/app-office/dia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/dia
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.106 2008/05/29 15:46:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.107 2008/07/28 23:18:55 eva Exp $
+
+ 28 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/dia-0.96.1-64bit-fixes.patch, dia-0.96.1-r1.ebuild:
+ add 64 bit compilation fix patch, bug #191673.
29 May 2008; Ali Polatel <hawking@gentoo.org> dia-0.96.1-r1.ebuild:
python_mod_optimize is ROOT aware.
diff --git a/app-office/dia/dia-0.96.1-r1.ebuild b/app-office/dia/dia-0.96.1-r1.ebuild
index 47289f4a6e36..bbf2a17432bf 100644
--- a/app-office/dia/dia-0.96.1-r1.ebuild
+++ b/app-office/dia/dia-0.96.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.96.1-r1.ebuild,v 1.7 2008/05/29 15:46:28 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.96.1-r1.ebuild,v 1.8 2008/07/28 23:18:55 eva Exp $
inherit eutils gnome2 libtool autotools versionator python
@@ -72,6 +72,9 @@ src_unpack() {
# Skip man generation
use doc || sed -i -e '/if HAVE_DB2MAN/,/man_MANS/d' doc/*/Makefile.am
+ # Fix compilation QA, bug #191673
+ epatch "${FILESDIR}/${PN}-0.96.1-64bit-fixes.patch"
+
# Fix tests
echo "dia.desktop.in" >> po/POTFILES.skip
diff --git a/app-office/dia/files/dia-0.96.1-64bit-fixes.patch b/app-office/dia/files/dia-0.96.1-64bit-fixes.patch
new file mode 100644
index 000000000000..68ebf5c897d1
--- /dev/null
+++ b/app-office/dia/files/dia-0.96.1-64bit-fixes.patch
@@ -0,0 +1,11 @@
+--- dia-0.96.1/app/load_save.c~ 2007-06-09 09:55:13.000000000 +0200
++++ dia-0.96.1/app/load_save.c 2007-06-09 10:02:30.000000000 +0200
+@@ -17,6 +17,8 @@
+ */
+ #include <config.h>
+
++/* so we get fdopen declared even when compiling with -ansi */
++#define _POSIX_C_SOURCE 2
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif