summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-08 01:14:53 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-08 01:14:53 +0000
commit3587b7886478ef4864db65877efefbafd0cf59aa (patch)
tree0ba19d1c9c99102a70df104dee4ec75554459e9f /app-office/dia
parentVersion bump, bug #408777: fixes replication bugs. (diff)
downloadgentoo-2-3587b7886478ef4864db65877efefbafd0cf59aa.tar.gz
gentoo-2-3587b7886478ef4864db65877efefbafd0cf59aa.tar.bz2
gentoo-2-3587b7886478ef4864db65877efefbafd0cf59aa.zip
Fix building against >=glib-2.31 (bug #401331, thanks to Maciej Piechotka for reporting).
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'app-office/dia')
-rw-r--r--app-office/dia/ChangeLog9
-rw-r--r--app-office/dia/dia-0.97.2.ebuild5
-rw-r--r--app-office/dia/files/dia-0.97.2-glib-2.31.patch59
3 files changed, 69 insertions, 4 deletions
diff --git a/app-office/dia/ChangeLog b/app-office/dia/ChangeLog
index 82aa6ad55d73..100b4d92f408 100644
--- a/app-office/dia/ChangeLog
+++ b/app-office/dia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/dia
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.134 2011/12/22 17:36:04 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/ChangeLog,v 1.135 2012/04/08 01:14:52 tetromino Exp $
+
+ 08 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> dia-0.97.2.ebuild,
+ +files/dia-0.97.2-glib-2.31.patch:
+ Fix building against >=glib-2.31 (bug #401331, thanks to Maciej Piechotka for
+ reporting).
*dia-0.97.2 (22 Dec 2011)
diff --git a/app-office/dia/dia-0.97.2.ebuild b/app-office/dia/dia-0.97.2.ebuild
index 96df98f500a4..69ed4cffac6f 100644
--- a/app-office/dia/dia-0.97.2.ebuild
+++ b/app-office/dia/dia-0.97.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.97.2.ebuild,v 1.2 2011/12/22 17:37:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.97.2.ebuild,v 1.3 2012/04/08 01:14:52 tetromino Exp $
EAPI=4
@@ -67,6 +67,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.97.0-gnome-doc.patch #159831
+ epatch "${FILESDIR}"/${PN}-0.97.2-glib-2.31.patch #401331
if use python; then
python_convert_shebangs -r 2 .
diff --git a/app-office/dia/files/dia-0.97.2-glib-2.31.patch b/app-office/dia/files/dia-0.97.2-glib-2.31.patch
new file mode 100644
index 000000000000..7429cd217793
--- /dev/null
+++ b/app-office/dia/files/dia-0.97.2-glib-2.31.patch
@@ -0,0 +1,59 @@
+From e3d41e6dd3488a29d23f53c57526871a9b79e9bf Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 7 Apr 2012 20:43:27 -0400
+Subject: [PATCH] Do not include glib subheaders directly
+
+Otherwise, dia cannot build against >=glib-2.31
+
+https://bugzilla.gnome.org/show_bug.cgi?id=673712
+---
+ objects/custom/shape_typeinfo.c | 2 +-
+ tests/test-boundingbox.c | 3 ---
+ tests/test-objects.c | 4 ----
+ 3 files changed, 1 insertions(+), 8 deletions(-)
+
+diff --git a/objects/custom/shape_typeinfo.c b/objects/custom/shape_typeinfo.c
+index c6133b1..3fb3d73 100644
+--- a/objects/custom/shape_typeinfo.c
++++ b/objects/custom/shape_typeinfo.c
+@@ -27,7 +27,7 @@
+ #include "custom_util.h"
+ #include <string.h>
+ #include <stdarg.h>
+-#include <glib/gstrfuncs.h>
++#include <glib.h>
+ #include <glib/gstdio.h>
+ #include <libxml/parser.h>
+
+diff --git a/tests/test-boundingbox.c b/tests/test-boundingbox.c
+index 7adaab5..a13d018 100644
+--- a/tests/test-boundingbox.c
++++ b/tests/test-boundingbox.c
+@@ -28,9 +28,6 @@
+ #include <glib.h>
+ #include <glib-object.h>
+
+-#if GLIB_CHECK_VERSION(2,16,0)
+-#include <glib/gtestutils.h>
+-#endif
+ #include "dialib.h"
+
+ /*
+diff --git a/tests/test-objects.c b/tests/test-objects.c
+index 57d5675..c5980a5 100644
+--- a/tests/test-objects.c
++++ b/tests/test-objects.c
+@@ -28,10 +28,6 @@
+ #include <glib.h>
+ #include <glib-object.h>
+
+-#if GLIB_CHECK_VERSION(2,16,0)
+-#include <glib/gtestutils.h>
+-#endif
+-
+ #include "object.h"
+ #include "plug-ins.h"
+ #include "dialib.h"
+--
+1.7.8.5
+